Jump to content
mdiemer

(SOLVED)Midi Import From Reaper Is Too Loud

Recommended Posts

I'm remixing a piece I did in Reaper. I have imported the midi (midi only - no audio) from Reaper into CbB. It is much louder than the default volume I start my pieces with, even after adjusting everything the same as my other projects in CbB. I have to bring the overall mix level down to -7 or so or it's way too loud. This has me puzzled. It's only midi, so there should not be a difference. I'm using the same compressor I always use, Sonitus Neve. that always brings my orchestral mixes into balance. But not in this case. I can't figure out where these extra decibels are coming from. What in blazes is going on?

Edited by mdiemer

Share this post


Link to post
Share on other sites
41 minutes ago, Max Arwood said:

Did you bring down the audio? or the Midi volume or velocity.  Defaults for MIDI are Volume = 101,  Vel+=0.

 

 

 

 

There is no audio per se, it's all midi. I am doing the same thing I always do with volume and velocity, adjusting everything as I go.

Edited by mdiemer

Share this post


Link to post
Share on other sites
24 minutes ago, William W. Saunders, Jr. said:

What synth/soft synth is your MIDI feeding to make the sound that is too loud?

I'm using Garritan Personal Orchestra, EWSO Gold, Vienna SP 1 Synchron Edition, Cinematic Strings,  Appasionata Strings, and some solo instruments. Here too I have set everything to my usual defaults, then adjusting on the fly.

Edited by mdiemer

Share this post


Link to post
Share on other sites

You should never IMPORT midi Always OPEN the midi file and the previous settings will be maintained. You just have to replace the TTS-1 with what ever synth you want to use. Import is meant to be used for clips not whole songs. 

Share this post


Link to post
Share on other sites

Maybe it's as easy as difference in default midi volume.

If Cakewalk has defaults for MIDI Volume = 101 and Reaper has defaults for MIDI Volume = 64 there's an audible difference.

Share this post


Link to post
Share on other sites
12 hours ago, John Vere said:

You should never IMPORT midi Always OPEN the midi file and the previous settings will be maintained. You just have to replace the TTS-1 with what ever synth you want to use. Import is meant to be used for clips not whole songs. 

 I have successfully imported large orchestral projects many times. This appears to be due to some kind of difference between Reaper and Cakewalk. So, if I import from Reaper (as opposed to importing an old Cakewalk midi file), maybe that difference is causing a problem.

 

Edited by mdiemer

Share this post


Link to post
Share on other sites
5 hours ago, Kurre said:

Maybe it's as easy as difference in default midi volume.

If Cakewalk has defaults for MIDI Volume = 101 and Reaper has defaults for MIDI Volume = 64 there's an audible difference.

That's what I've been wondering also. Different DAWS do have different ways of doing things when it comes to the nuts and bolts. For example, Reaper and Cakewalk treat time differently. They both have Event Lists, where you can see the time of every event.  But they use different formulas. Cakewalk uses "1:02:000" for example, while Reaper displays the same time in a different format (can't recall just how as I haven't used it in awhile). 

But it puzzles me that a midi import would sound different, as I set everything up like I always do. Midi is just information, not sound, so I don't get how this happening. Once the midi is in Cakewalk, and I have set things up as usual, it should behave accordingly.

Share this post


Link to post
Share on other sites

There are two possible explanations (assuming we can ignore the VIs): changes to volume (including expression and aftertouch) or velocity data.

I don't have a great deal of experience importing MIDI, but my recollection is that velocities are not altered on import. I can't imagine why they would be. You'd have to examine the original data in another application or (even better) open it in a hex editor to make sure you know what some of the velocities actually are. If somehow there is no velocity data in the MIDI file (if that's even possible), then Cakewalk would set everything to the default value of 64. Of course, if that was happening it would be obvious because every note would have the same velocity. From your description, it sounds as though the music sounds correct but is just too loud. That would seem to eliminate velocities as the problem.

So I'm guessing volume or expression CCs would be a more likely candidate. By default, Cakewalk does not send any MIDI volume commands to soft synths unless they are already embedded in the MIDI data. If the value over the volume slider says "(101)" that means "not sending anything". You should be able to look at the event list to see if there are any CC7 or CC11 events in there. If there is, then I'd expect Cakewalk to simply process them without modification, in which it comes down to how each synth interprets volume and expression, as there is no standardization here. 

 

Share this post


Link to post
Share on other sites

This why I'm warning against "Importing" It is well known that if you import a midi file to an existing project a lot of data is not going to be there. The project will dictate a lot of parameters, example the projects tempo.  

Take a downloaded midi file, open a blank project and import the file. It will have nothing, no tempo no synth etc. it brain dead. It will have Velocity, I just did this and checked. But there are no patch numbers etc. 

Now if you take that same file and "open" it  Cakewalk will create a new project and all the original data should be 100% intact. If you have nothing checked under Preferences/Midi/ Devices/ output then Cakewalk will insert the TTS-1 and all the tracks will play correctly if the file was a GM file. 

So the standard practice is to SAVE AS  a MID. file in the original DAW and OPEN that file in Cakewalk to preserve important data. 

I would think you would need all the midi tracks on different channels before you save it otherwise they might get jumbled. 

Edited by John Vere
  • Great Idea 1

Share this post


Link to post
Share on other sites
6 hours ago, bitflipper said:

There are two possible explanations (assuming we can ignore the VIs): changes to volume (including expression and aftertouch) or velocity data.

I don't have a great deal of experience importing MIDI, but my recollection is that velocities are not altered on import. I can't imagine why they would be. You'd have to examine the original data in another application or (even better) open it in a hex editor to make sure you know what some of the velocities actually are. If somehow there is no velocity data in the MIDI file (if that's even possible), then Cakewalk would set everything to the default value of 64. Of course, if that was happening it would be obvious because every note would have the same velocity. From your description, it sounds as though the music sounds correct but is just too loud. That would seem to eliminate velocities as the problem.

So I'm guessing volume or expression CCs would be a more likely candidate. By default, Cakewalk does not send any MIDI volume commands to soft synths unless they are already embedded in the MIDI data. If the value over the volume slider says "(101)" that means "not sending anything". You should be able to look at the event list to see if there are any CC7 or CC11 events in there. If there is, then I'd expect Cakewalk to simply process them without modification, in which it comes down to how each synth interprets volume and expression, as there is no standardization here. 

 

The imported midi does have all the volume events (CC 7 & 11), and also the velocities are correct. Not sure what you mean by "embedded in the midi data." Do you mean embedded in CC events, or that the midi data itself contains volume information?

 

Share this post


Link to post
Share on other sites
5 hours ago, John Vere said:

This why I'm warning against "Importing" It is well known that if you import a midi file to an existing project a lot of data is not going to be there. The project will dictate a lot of parameters, example the projects tempo.  

Take a downloaded midi file, open a blank project and import the file. It will have nothing, no tempo no synth etc. it brain dead. It will have Velocity, I just did this and checked. But there are no patch numbers etc. 

Now if you take that same file and "open" it  Cakewalk will create a new project and all the original data should be 100% intact. If you have nothing checked under Preferences/Midi/ Devices/ output then Cakewalk will insert the TTS-1 and all the tracks will play correctly if the file was a GM file. 

So the standard practice is to SAVE AS  a MID. file in the original DAW and OPEN that file in Cakewalk to preserve important data. 

I would think you would need all the midi tracks on different channels before you save it otherwise they might get jumbled. 

I think I have done it other way in the past. and you're right, the result is better. Unfortunately I'm not always consistent in how I do things, and I don't do a midi transfer that often. On this occasion, although all the notes were there, as well as all CC events and velocities, it didn't have any tempos. I had to go back to the original project in Reaper and copy them down, then put them in CbB. As this is a large-scale, 16 minute piece, with lots of tempo changes, well it took me a while. Next time I'll be sure to do it the right way.

  • Like 1

Share this post


Link to post
Share on other sites

I did a walk through how Cakewalk works in the regard when midi CC#7(volume) is sent.

Unless you touch a midi track faderin Cakewalk, no CC7 is sent. In Reaper when I ran v3/v4 you could activate that fader is midi - and it is sent every time as you start transport, all 16 channels sent even an initial value as transport is started every time. I had some issues with this how it worked.

But if you happend to touch it, it stays there in Cakewalk and the synth is playing back on that volume, which could be very different next time you load the project. So something to watch out for.

 

My link explain Cakewalk a bit, but also that modifier on midi track are after plugin bay for midi - so a midi monitor could not see what is actually sent as modified.

For newcomers I link to some decent plugins for monitor, TrackDiag and PortDiag anyway, very useful. PortDiag do realtime through monitoring and playing, TrackDiag what clips on track sends.

http://www.tencrazy.com/gadgets/mfx/

Share this post


Link to post
Share on other sites
14 hours ago, mdiemer said:

The imported midi does have all the volume events (CC 7 & 11), and also the velocities are correct. Not sure what you mean by "embedded in the midi data." Do you mean embedded in CC events, or that the midi data itself contains volume information?

 

Yes, that's what I meant - that CC7 and/or CC11 messages are included in the data stream. Those are normally the only way volume information is conveyed. There is, I believe, a SysEx command for setting the master volume (similar to the master tuning SysEx command), but that's rarely used and certainly wouldn't be applied by default. 

Of course, individual instruments can choose how they respond to any CC, such as some orchestral libraries that tie CC1 to volume to make it easier to automate swells.

Given that the files do contain volume information and it hasn't been modified, and those are just numbers that presumably Cakewalk doesn't alter, then we have to conclude that it's down to the way the VIs are responding - either in Cakewalk or in Reaper. There could have been some CC scaling going on in Reaper, making the instruments quieter and now they're just back where they should have been all along. 

Share this post


Link to post
Share on other sites
On 11/8/2020 at 12:40 AM, LarsF said:

I did a walk through how Cakewalk works in the regard when midi CC#7(volume) is sent.

Unless you touch a midi track faderin Cakewalk, no CC7 is sent. In Reaper when I ran v3/v4 you could activate that fader is midi - and it is sent every time as you start transport, all 16 channels sent even an initial value as transport is started every time. I had some issues with this how it worked.

But if you happend to touch it, it stays there in Cakewalk and the synth is playing back on that volume, which could be very different next time you load the project. So something to watch out for.

 

My link explain Cakewalk a bit, but also that modifier on midi track are after plugin bay for midi - so a midi monitor could not see what is actually sent as modified.

For newcomers I link to some decent plugins for monitor, TrackDiag and PortDiag anyway, very useful. PortDiag do realtime through monitoring and playing, TrackDiag what clips on track sends.

http://www.tencrazy.com/gadgets/mfx/

Very interesting, thanks for all that good info Lars. It will take me awhile to digest it, however!

Share this post


Link to post
Share on other sites
On 11/8/2020 at 11:58 AM, bitflipper said:

Yes, that's what I meant - that CC7 and/or CC11 messages are included in the data stream. Those are normally the only way volume information is conveyed. There is, I believe, a SysEx command for setting the master volume (similar to the master tuning SysEx command), but that's rarely used and certainly wouldn't be applied by default. 

Of course, individual instruments can choose how they respond to any CC, such as some orchestral libraries that tie CC1 to volume to make it easier to automate swells.

Given that the files do contain volume information and it hasn't been modified, and those are just numbers that presumably Cakewalk doesn't alter, then we have to conclude that it's down to the way the VIs are responding - either in Cakewalk or in Reaper. There could have been some CC scaling going on in Reaper, making the instruments quieter and now they're just back where they should have been all along. 

Yeah, it's kind of mysterious. I'll probably never know exactly what happened here. I won't be importing again from Reaper. I won't go back to Reaper unless I can use it on Linux. While that's possible now, it's really not if you need Windows VSTs.

Share this post


Link to post
Share on other sites

I'm now wondering whether I accidentally nudged the input dial on my audio interface. It's close to the headphone jack, and it's possible I moved it up while connecting or disconnecting that line out. This would explain it. I have been over and over my setup, and nothing is different. I can't be sure however, as I don't remember exactly where I had set the input volume (note to self: make a note of all settings on audio interface). But I'm going to assume that's the explanation as nothing else really makes sense.

Share this post


Link to post
Share on other sites

Nope, that wasn't it (see previous post).  When I tested this theory by opening another project, I had to turn the input back up, proving that was not the cause. Back to the drawing board...or sounding board I guess....

Share this post


Link to post
Share on other sites

I love a mystery, but by this point I'd have just chalked it up to "I guess I'll never know" and moved on. I commend your tenacity, but maybe there are greater mysteries deserving of your attention. :) Like what, exactly, is Kid Rock's talent?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...