Jump to content
Laurence Levin

MIDI channel silent

Recommended Posts

In a project, I tried to use the Mute button on several MIDI channels as an automation snapshot. When I switched to Automated Mute, for some reason the channels were silent even with the Mute off. Something buggy? So I decided to remove the Automated Mute from these channels and use volume control to silence these channels during certain sections of the project. 

For some reason, one MIDI channel no longer plays. I removed Automated Mute. I removed Read Automation. I removed Write Automation. I checked volume. Made sure the channel was no longer on Mute. I checked the Event List. When I transfer the MIDI data to a different channel and select the same instrument, everything sounds fine. I'm just wondering what is going on. 

Share this post


Link to post
Share on other sites

You need to look for a CC volume event on the event list for that track. If it's not showing there look in PVR down in the very bottom left and open the + to add CC lanes that might contain volume as in 7  or velocity  Make sure to toggle show controller pane found under view upper left. 

Edited by John Vere

Share this post


Link to post
Share on other sites
2 hours ago, John Vere said:

You need to look for a CC volume event on the event list for that track. If it's not showing there look in PVR down in the very bottom left and open the + to add CC lanes that might contain volume as in 7  or velocity  Make sure to toggle show controller pane found under view upper left. 

There's nothing in the Event List or in Piano Roll that has to do with volume or velocity. And why would the track play fine when copying and pasting to another MIDI channel? But it won't play when I change MIDI channels of the problematic track.  Something's buggy!

Share this post


Link to post
Share on other sites

What VST are you using for playback? 

Are you dead sure there are no volume envelopes in the track.  When you expand the track view and look in the header lower left for the envelope icon. Click that to open the automation lane.  You can delete the green line right click on it and delete envelope. Also check the instrument track. 

Edited by John Vere

Share this post


Link to post
Share on other sites
19 hours ago, John Vere said:

What VST are you using for playback? 

Are you dead sure there are no volume envelopes in the track.  When you expand the track view and look in the header lower left for the envelope icon. Click that to open the automation lane.  You can delete the green line right click on it and delete envelope. Also check the instrument track. 

Dead sure. I never inserted a volume envelope in the first place. Just an automated mute message, but then I eliminated Read and Write enable on that track. And there's nothing in the event view, PRV, on this or any track, and no envelope shows up in track view even after expanding the track. I copied the events in the track, deleted the track, and added a track with the same MIDI channel to get everything working like it should. But WTF?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...