Jump to content
  • 0
JohnK

strange - MIDI Volume Limited to 12 instead of 127

Question

I have a single project, where one (only the one track in the project) appears to be limited with a maximum MIDI Volume of 12 instead of 127.  To try and see what the heck has been sent to the VSTi, I replaced it with a MIDI monitor, and when I drag the volume control, it only goes between 0 and 12.

maxvolume.png.51a6b4f73e2e2f1428070bc87ad92c6a.png

I have also tried closing and re-opening the project (with the monitor on) to see if there are any stray MIDI events being sent, and there are none. The only other thing being sent are "all notes off" messages to every channel (ie 1-16) of the VSTi; in this case a MIDI monitor.

I also tried pressing the MIDI Panic, and that does not fix the issue.

If I insert Volume MIDI message into the event list for the track (of 127), then that gets sent / received as expected (ie it works).  However, as soon as I try the volume slider on the track, it is again only sending values 0-12.

I have also checked the LSB for volume, and that made no difference. I have also tried (not that it should) set the value for Expression to 127.

I have looked everywhere I could think of and I can not find anywhere where you can set the range for the volume slider to only send 0-"v" (v=12 in this case).

Does anyone know of what could be causing the above behavior?

Some extra info, this project was originally created using an older version of SONAR.

 

 

Edited by JohnK

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

What happens if you add a single SIT using MIDImonitor as the VSTi?

I did just that here and when I moved the volume slider of the MIDI track inspector, I get the range between 0 and 127 on CC7 (as expected)

The only difference here is that I am using the 64 bit version of MIDImonitor where as you appear to be using the 32 bit version - but that shouldn't make a difference in the actual MIDI data.

Could be an issue with that particular project.  What that issue is, I couldn't say.

Share this post


Link to post
Share on other sites
  • 0
32 minutes ago, Promidi said:

What happens if you add a single SIT using MIDImonitor as the VSTi?

I did just that here and when I moved the volume slider of the MIDI track inspector, I get the range between 0 and 127 on CC7 (as expected)

The only difference here is that I am using the 64 bit version of MIDImonitor where as you appear to be using the 32 bit version - but that shouldn't make a difference in the actual MIDI data.

Could be an issue with that particular project.  What that issue is, I couldn't say.

Not sure what you mean by ""SIT"?

originally, the MIDI track pointed to an actual VSTi (64b), and i found I could not raise the volume on that track. Then when I checked, i saw that the volume only moved a little (ie 0 to 12).

So I added an instance of TTS-1 and pointed the MIDI track to it (in case it was a VSTI specific issue). And its sliders could only be moved from 0-12. ie its not the VSTi. And that's when I downloaded a MIDI Monitor VST (I only found a 32b version), as used in the above screen shot, it clearly showed that the MIDI CC7 (ie Volume) only moves between 0 and 12.:o

The fact that TTS-1 also acts the same, it is clearly not dependent on if its 32 or 64b. And further, the original VSTi that I noticed it on, was also 64b.

And hence my question, what is the issue? Its as if there is some track setting, that i cannot find, which sets a map of the Volume slider range output to 0-12, instead of 0-127. 

Going out on a limb with a crazy idea, because it was a project from an older version of Sonar, It may be possible that Sonar had the functionality to set the limits of a control (ie volume), and now Cakewalk can read and apply those values, but does not have an interface to edit/view/change/reset this property?O.o

It is specific to this project, however, I just noticed that another MIDI track is having the same issue, but it is being mapped from 0-67. ARRRrrrrrgghhhhh!

The original track is very simple (a single hi-hat clip repeated throughout, using a linked clip). So I created a new MIDI track, copied and pasted the clip (as linked) into the new MIDI track (at bar 3), and then copied and pasted-special that new copy of the clip throughout the song (as repeated linked clips)  and changed the MIDI channel to something unused (its a multi-timbral VSTi), while using the bank and patch of the original. Then Deleted the original track. And now the MIDI volume works 100% as expected.

Its a workaround, but I would prefer to know how to fix it correctly, instead of the kludge / nuclear approach I used above.

Share this post


Link to post
Share on other sites
  • 0

A SIT is a "Simple Instrument Track".  That is, it has all the component tracks (MIDI, VSTi, Audio) combined into one track with all the routing correctly set so you can just put MIDI into the track and it is heard as the track is played.

If you save the problem track as a Track Template and then load that Track Template in a blank project, does it happen then?

To be brutally honest and frank, I am actually stumped with your issue as, in the 25 years of using Cakewalk, I have never come across this particular issue. Moving any volume slider in any console has always given me the full range (0 to 127).

I am assuming you're using Cakewalk by Bandlab 2020.9 Build 006.
 
Maybe drop a note to Cakewalk support with a copy of a project where this issue manifests. If possible, You might want to strip the project down so that it contains just the problem track (as long as that track manifests the issue). 

https://help.cakewalk.com/hc/en-us/requests/new?ticket_form_id=360000025633

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

Could it be one of a Grouped control?  If you have 2 controls in a group and a custom relationship set up, it's possible to get one to be limited to a maximum of 12, when the other moves up to 127.  I don't *think* that's the case here, but it's all I can think of and may be worth digging into.

  • Thanks 1
  • Great Idea 2

Share this post


Link to post
Share on other sites
  • 0

 

16 hours ago, Promidi said:

A SIT is a "Simple Instrument Track".  That is, it has all the component tracks (MIDI, VSTi, Audio) combined into one track with all the routing correctly set so you can just put MIDI into the track and it is heard as the track is played.

The VSTi is loaded into a SIT.  I used the insert VSTi when i was converting over from my old LiveSynth DXi to the VSTi (BassMIDIVsti) as the soundfont player. I probably used "Replace Synth", but since its multi-timbral, all my individual midi channels are on different tracks. There is no MIDi on the SIT, its just for an audio out for the synth,

16 hours ago, Promidi said:

If you save the problem track as a Track Template and then load that Track Template in a blank project, does it happen then?

i'll do that when I get a chance a little later, and let you know. i understand it is really just for extra info, and wont really pin-point a specific issue?

16 hours ago, Promidi said:

I am assuming you're using Cakewalk by Bandlab 2020.9 Build 006.

Of course, you should never assume, i am with you on that one,  even the obvious👍 I am using the latest available. Just explicitly checked the help/about, and it shows as 'Version: 2020.09 (Build 006, 64bit)'

As for dropping a line into Bandlab, i was trying here first as it seemed like i was missing something obvious. i have used cakewalk since back in v1.0 for windows, then Sonar, and have recently switched to cakewalk by bandlab, and hence the conversion of old projects. But it has always been with years and years of breaks between each change, and hence i thought i better ask here, after I searched the help of course.      

16 hours ago, Kevin Perry said:

Could it be one of a Grouped control?  If you have 2 controls in a group and a custom relationship set up, it's possible to get one to be limited to a maximum of 12, when the other moves up to 127.  I don't *think* that's the case here, but it's all I can think of and may be worth digging into.

Cant remember if i made this clear previously, but if i explicitly insert a MIDI CC7 (ie volume) into the MIDI track, that gets sent unmodified, so it really is the control. Hence this group/link thing with a relationship may just be the ticket. i'll have to read the help, have a play, and get back to you on this one a little later.

Share this post


Link to post
Share on other sites
  • 0
17 hours ago, Kevin Perry said:

Could it be one of a Grouped control?  If you have 2 controls in a group and a custom relationship set up, it's possible to get one to be limited to a maximum of 12, when the other moves up to 127.  I don't *think* that's the case here, but it's all I can think of and may be worth digging into.

Nope. I checked, and I have no groups assigned.

group.PNG.0da3a4af55132009ce5050831ac6881a.PNG

i also tried adding a group, and found that there is a pretty clear indicator that the control is in a group.

groupindicator.PNG.06b34a4609adb03c62475012d50092dc.PNG

i guess cutting back the project and forwarding to Cakewalk will be my only option.

although i know how to "correct it' (ie moving all the MIDI to a new track), i have a lot of old projects I have converted, so its probably not the only project with the issue, but simply the first one I have noticed it. i was messing with the project last night, and noticed the final audio out signal was pretty low, but when i went to turn up the midi parts, I found that this project is rife with this issue, to the point where I need to set the volume to >127, which gets scaled down >:( even when set to 127, so i cant mix it.

thanks to all for your input & help.

Share this post


Link to post
Share on other sites
  • 0
3 minutes ago, msmcleod said:

Are you in offset mode perhaps?

I think you've got it.  I added a SIT with MIDImonitor.  played around with offset mode - I was able to replicate the OP's issue exactly.

Share this post


Link to post
Share on other sites
  • 0
43 minutes ago, msmcleod said:

Are you in offset mode perhaps?

Yep, that was it. 🏁

Now in hindsight, on reading the manual, it says all controls that are in offset mode have a "+" symbol next to them, and looking back at my screenshots above, they all have the "+" symbol.

I don't normally have the Mix module visible in my control bar. What I am also *guessing* is that there is possibly a hot key (couldn't find it documented) as I often start typing into a text entry (such as a track name) while looking down at my keyboard, but when I look up, I notice I have left the text entry and have been unwittingly pressing numerous unknown hot-key combinations.:$

Now to somehow revert the support request I made yesterday to Cakewalk.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, JohnK said:

Now to somehow revert the support request I made yesterday to Cakewalk.

Just reply to the email they would have sent you, letting them know to cancel the request and that the ticket can be deemed closed.

Edited by Promidi

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, Promidi said:

Just reply to the email they would have sent you, letting them know to cancel the request and that the ticket can be deemed closed.

ahhh yes, I forgot they sent me a email on receipt. I ignored and forgot it, as it had a bunch of unrelated suggestions for fixing audio dropouts.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...