Jump to content
skavan

Midi Control -- there must be a way!

Recommended Posts

Hi,

Seemingly simple question -- but I can't get it to work.

I have a software controller, with a Pan Knob and a Volume Fader.

Example: Basic Cakewalk

  • If I twirl the Pan Knob in my surface, it sends Midi CC 10 messages to Sonar.
  • Sonar reflects the change internally, but does not update the Knob in the console.
  • Sonar does not send back out the changed value via Midi.
  • If I twiddle the knob in Sonar, it sends out the Midi CC change to my controller.

Example 2: "Remote Control Mode":
Using remote control mode, one can assign Controllers to Cakewalk widgets. So, I can assign CC 10 to the pan knob, for example.

  • If I twirl the Pan Knob on my surface it sends Midi CC 10 messages to Sonar.
  • Sonar reflects the change graphically, and passes the change back to my Surface!! Yes !! BUT:
  • When I twiddle the knob in Cakewalk, it sends the CC Message and endlessly repeats it (confirmed with Midi Monitoring software). and I mean endlessly!

Anybody out there who can shed light on this? Is it a bug, or am I missing some obvious thing?

Thanks.

 

s.

Share this post


Link to post
Share on other sites

I'm not sure what you mean by a "software Controller". Please explain. 

Share this post


Link to post
Share on other sites

A piece of software that sends and receives midi messages and presents the user with a volume slider, pan control and other buttons.

see attached pic.

If you push the slider, it sends CC 10 messages to a given midi port/channel. If you twiddle the knob it sends CC 07 messages.

In both cases if it receives CC messages, the slider and knob move accordingly.

Like a hardware controller surface, but in software.

Strip.JPG

Share this post


Link to post
Share on other sites

Sending CC data endlessly implies a midi input and output are somehow connected together.  When that happens the CC commands continually circle around in an endless loop just like you dexcribe.

Perhaps you have midi echo enabled when it should be disabled.

Share this post


Link to post
Share on other sites

Thanks for the input.

To the best of my knowledge that isn't the case. (midi loop). Echo is off both in preferences and in the strip. Discrete input and outputs are being used.

Also - the messages are evenly spaces, separated by 200ms or so -- which implies some gremlin somewhere (I think)...it's almost like the knob/slider in cakewalk is sending the message to itself and then rebroadcasting it...which is a sort of midi loop...but one I can't seem to prevent!

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...