Jump to content
  • 0
nicole

No audio coming out of Cakewalk.

Question

Hi, I just found out about Cakewalk today and thought I'd give it a shot as a beginner producer since it's free. I've run into a problem though regarding playback: there is none.

Earlier actually it was totally wack. I had to reinstall the application TWICE today because the first time I did, whenever Cakewalk was open, either of two things would happen: no audio AT ALL would come out of my laptop from any application, or audio would play from my left speaker, and the right speaker would crackle and hiss at a deafening volume (didn't get to test Cakewalk itself, but I'm assuming it's the same). I thought I broke my speaker lol so I uninstalled and reinstalled the application.

ANYWAY, it doesn't crackle anymore. All other applications now seem to sound fine BUT I tried playing some files on Cakewalk and it just won't play anything at all!!

I know there are a lot of Q&As like this on the internet but I've done everything that has worked for those folks and so far still yielded nothing. I have:

  • Switched to WASAPI Exclusive
  • Made sure the sampling rate was the same for both Cakewalk and Windows (both 44.1k and 48k)
  • Checked the option to "Suspend Audio Engine when Cakewalk is Not in Focus"

And still I get the Audio Driver Error saying "The following driver(s) either do not support the current audio format, or are in use by another application. Please choose whether you want to disable them or use them anyway."

Just clicking "Use Anyway" has worked for others but it does not work for me.  No sound still.

Attached are screenshots of the error and... idk I guess a pic that basically summarizes the situation. Please help, I really want to start making music. :(

image.png

image.png

Edited by nicole
typo

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 1

1) Use WASAPI Shared.

2) The bit rates and bit depths must match Windows' settings:

Windows: Right-click the speaker icon -> Open Sound Settings -> Sound -> Output -> Device Properties -> Additional Device Properties -> Advanced.
Make a note of the values in the dropdown.

Cakewalk: Edit -> Preferences -> Audio -> Driver Settings: Audio Driver Bit Depth and Sampling Rate. Set them the same as Windows.

 

If that doesn't help, let us know and we can explore further.

If it does help, then:

3) You only have a MIDI track. MIDI is instructions such as Start playing Middle C, start playing the E above Middle C, stop playing the E above Middle C, stop playing Middle-C.

But you still need an instrument to play the notes. You need to add a synth.
Above the list of HipHop beats is a tab Plugins. Click on it and then Sort by Manufacturer. Under that click on Instruments.
Open the Cakewalk folder and drag and drop TTS-1 under the MIDI track. In the dialog box make sure MIDI Source and First Synth Audio Output are selected.

Track 2 will be Cakewalk TTS-1 audio, track 3 will be Cakewalk TTS-1 MIDI.
Cakewalk has routed the output of MIDI track 3 to the synthesiser TTS-1 in track 2.
Cakewalk has routed the audio coming out of TTS-1 to the speakers, via the Master fader.
Click on the number 3, then Views -> Piano Roll View.
Click on the keys on the keyboard. You will hear a piano.
If you don't let us know.

Then go through the first few of these tutorials.

 

  • Like 1

Share this post


Link to post
Share on other sites
  • 1

Hmm. Also have Realtek on my PC. I use powered speakers plugged into the headphone socket on the PC and when I plug in, the Realtek driver asks me what it was I plugged in. So it is something to do with WASAPI/your particular laptop I should imagine.

I suggest asking it as a new question. Specify make and model of laptop. Also that you are using WASPI Shared.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
43 minutes ago, Nigel Mackay said:

1) Use WASAPI Shared.

2) The bit rates and bit depths must match Windows' settings:

Windows: Right-click the speaker icon -> Open Sound Settings -> Sound -> Output -> Device Properties -> Additional Device Properties -> Advanced.
Make a note of the values in the dropdown.

Cakewalk: Edit -> Preferences -> Audio -> Driver Settings: Audio Driver Bit Depth and Sampling Rate. Set them the same as Windows.

 

If that doesn't help, let us know and we can explore further.

If it does help, then:

3) You only have a MIDI track. MIDI is instructions such as Start playing Middle C, start playing the E above Middle C, stop playing the E above Middle C, stop playing Middle-C.

But you still need an instrument to play the notes. You need to add a synth.
Above the list of HipHop beats is a tab Plugins. Click on it and then Sort by Manufacturer. Under that click on Instruments.
Open the Cakewalk folder and drag and drop TTS-1 under the MIDI track. In the dialog box make sure MIDI Source and First Synth Audio Output are selected.

Track 2 will be Cakewalk TTS-1 audio, track 3 will be Cakewalk TTS-1 MIDI.
Cakewalk has routed the output of MIDI track 3 to the synthesiser TTS-1 in track 2.
Cakewalk has routed the audio coming out of TTS-1 to the speakers, via the Master fader.
Click on the number 3, then Views -> Piano Roll View.
Click on the keys on the keyboard. You will hear a piano.
If you don't let us know.

Then go through the first few of these tutorials.

 

omg I hear the piano out of my laptop speakers!! :D Thank you. But, now, after plugging in my headphones, the sound continues to come out of the speakers instead of the headphones. Other applications work on the headphones. I thought I'd just have to manually adjust the output device and select headphones, but this is all I see. :/ Do you know how I can fix this? Thanks again so much.

image.png

Edited by nicole
typo

Share this post


Link to post
Share on other sites
  • 0

Okay, I think I managed to fix the headphone problem. I just had to go to Realtek Audio Console and adjusted this setting (see attached).  Everything is working as it should now :) Thanks for your help!!

image.png

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I downloaded cakewalk the other week and i was so happy when everything was working fine. About a few days ago, I booted the app to record some music but my microphone was not appearing, so i went to preferences and selected them but every time I would go back it would unselect. I thought it was the microphone but when I tried it out on my recorder it was working fine. After a while, I managed to get the microphone working but the audio would not play back in my headphones nor through my laptop speakers. When I would use my Bluetooth speakers they would come out but they wouldn't play through the headphones like they use to.  

I have re-installed the app like 6 times but to no avail. I have watched several YouTube videos but TO NO AVAIL. I have done all things I can but its still not working. It use to work perfectly and now its all gone to waste. I dont know what to do, even some of my older recorded tracks dont play or pan to the right or mess up in some way,

Please I NEED HELP ASAP

By the way I use a usb microphone but everything was fine until yesterday. It keeps saying silent buses and thing..

Share this post


Link to post
Share on other sites
  • 0

First you should always start your own thread instead of hijacking a 2 year old topic. 
 

Your issue is that USB mikes are made for podcasts not DAW recording. DAW’s work best with a proper ASIO audio interface and real microphones using XLR cables. 

And you can’t use Bluetooth either because of the latency. And on all systems including cell phones you can’t use Bluetooth and the built in speakers together. 

Watch Tutorial #1 

Share this post


Link to post
Share on other sites
  • 0
9 minutes ago, John Vere said:

First you should always start your own thread instead of hijacking a 2 year old topic. 
 

Amen!

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...