Jump to content
Morten Saether

[CLOSED] Version 2020.08 Hotfix Sneak Peek

Recommended Posts

UPDATE 10-Sep-2020: The planned 2020.08 hotfix has been released as version 2020.09. For details, see https://discuss.cakewalk.com/index.php?/topic/19403-current-release-202009/.

 

We plan to release the official 2020.08 hotfix in the near future. In the meantime, we wanted to make an updated build available to you immediately in case you are affected by the following issues:

  • Control surface settings are not being saved when a surface is disabled or the surface UI dialog is closed.
  • Save As dialog ignores custom typed paths for Project Path and Audio Path.
  • Arranger-related menus may appear incorrectly with multi-monitor configurations.
  • Changing Picture Cache to high values would cause waveforms to stop drawing. Picture cache sizes > 2GB now work properly. The max size for PicCacheMB in Aud.ini has been increased to 10000 MB.
    • Picture cache is now automatically managed and will self delete the oldest files when the size limit is reached.
  • Mojibake (garbage text) occurs when using Unicode multibyte characters (Japanese, Chinese, etc.) on OS that differs from the selected CbB language.
    • Cakewalk now uses UTF-8 encoding by default for all text strings, including track name, clips names, Lane descriptions, Arranger sections, Notes Browser, Lyrics view, etc.
    • Backwards compatibility: Legacy projects not saved with UTF-8 will continue to open correctly in 2020.08 Hotfix and higher
    • Projects saved with multibyte characters from 2020.08 Hotfix and higher can now be opened on any OS, retaining the original Unicode characters.

 

Other bugs fixed in build 2020.08.0.120

  • Crash starting playback in project when the picture cache is full.
  • Crash when inserting multiple instrument tracks with no tracks enabled.
  • Closing a 3rd party plug-in UI can crash the application by sending WM_QUIT message.
  • Crash when deleting an Arranger section selection twice.
  • Crash inserting Per-Output Instrument tracks when Auto Track Zoom & Show Synth Properties are enabled.
  • Insert Soft Synth Options should disable Track Number options for First/All synth output options.
  • Arranger Section Rename intermittently becomes stuck.
  • Clip crops unexpectedly on Undo of Apply Region Tempo.
  • The Synth Rack and plug-in views are not opened when inserting an instrument via the Add Track menu. It will now follow the default as specified in the Insert Soft Synth Options dialog.
  • Record Arm/Virtual Controller toggle fail to enable when adding Instrument Track per Output from Add Track menu
  • Add Track menu does not activate 'Enable MIDI Output for Synths' by default. It will now follow the default as specified in the Insert Soft Synth Options dialog.
  • Correct Chinese translation for "Rename Clip".

 

  • Like 12
  • Thanks 3

Share this post


Link to post
Share on other sites

A small request for the hot fix.   Could the 'Silent bus detected' & Missing VST dialogs (that pause project loading) be turned into a toast notifications?

Thanks

  • Like 2

Share this post


Link to post
Share on other sites

Alot of great bug fixes in this one good job..😄🙏

Even the MPC Beats seem to be working. 

  • Like 2

Share this post


Link to post
Share on other sites

When inserting two mono inserts of the TTS-1, the DAW crashes. Also no sound coming through while recording the Midi insert in Mono. 

Edited by Will_Kaydo

Share this post


Link to post
Share on other sites

Thanks for the info. I have been trying to update to 2020.08 for weeks, 64 bit, no errors or problems on my current version. I click on update, system looks like it is downloading, and the the ‘installing’ process begins and never ends, never installs. I have tried this from the BandLab assistant and from within Cakewalk itself, to no avail. I am using te Sonar Platinum version. I have actually let it go overnight and still no install completed.

Cakewalk forums say to uninstall and then reinstall, but I have a problem uninstalling a version that works perfectly.

Would really appreciate any guidance if available. Thanks.

Edited by ddalio

Share this post


Link to post
Share on other sites
3 hours ago, ddalio said:

Thanks for the info. I have been trying to update to 2020.08 for weeks, 64 bit, no errors or problems on my current version. I click on update, system looks like it is downloading, and the the ‘installing’ process begins and never ends, never installs. I have tried this from the BandLab assistant and from within Cakewalk itself, to no avail. I am using te Sonar Platinum version. I have actually let it go overnight and still no install completed.

Cakewalk forums say to uninstall and then reinstall, but I have a problem uninstalling a version that works perfectly.

Would really appreciate any guidance if available. Thanks.

This has been discussed earlier. Just run the installer manually outside of BandLab assistant and it should launch and run properly.
You will find the downloader at %appdata%\bandlab-assistant\downloads

  • Like 1

Share this post


Link to post
Share on other sites

build 2020.08.0.120

at Arranger view title 

> ::CMixerInspectorSiteView:CMixerViewInspectorFrame::Arranger::View::Inspector::InspectorBorderComponent<Arranger::View::Inspector::ArrangerInspectorComponent>

English text

Selections
Arrangements

Japanese 
[][][][][]
[][][][][]

 

font-bad-1.jpg.ff2d181092345f98ad940d3544c1a51b.jpg

 

> Mojibake (garbage text) occurs when using Unicode multibyte characters (Japanese, Chinese, etc.) 
> on OS that differs from the selected CbB language.

not sure this Mojibake means TEXT to [][][][] and where you fixed.
with prev Version: 2020.08 (Build 20?) 
all are ok at simple plain Win10.

font-ok-win10-1.jpg.c849c15ed061ab336fe384515cd90ba2.jpg

 

and some setup OS(with external font control tool, DPI change etc) 
Win10 and Win7, its not fixed.

now build 2020.08.0.120 fixed and 
found only 2 text are Mojibake

Selections
Arrangements

to 
Mojibake [][][][]
 

font-bad-1.jpg.ff2d181092345f98ad940d3544c1a51b.jpg

 

Edited by JM2
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Problemas na exportação de vídeo para MP4.

Meu disco tem espaço livre.

 

image.png.f6339e1ea64ed1c5657e492774e32e50.png

Edited by Milton Sica

Share this post


Link to post
Share on other sites
7 hours ago, Milton Sica said:

Problemas na exportação de vídeo para MP4.

Meu disco tem espaço livre.

 

image.png.f6339e1ea64ed1c5657e492774e32e50.png

Per Google Translate: 

Quote

Problems exporting video to MP4.  My disk has free space.

 

Share this post


Link to post
Share on other sites
On 9/2/2020 at 9:44 AM, Will_Kaydo said:

When inserting two mono inserts of the TTS-1, the DAW crashes. Also no sound coming through while recording the Midi insert in Mono. 

Same here... Not sure why. 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...