Jump to content
glen dale

"Unable to open audio record device"

Recommended Posts

Hi,

when arming and then trying to record an audio track I get the error message: "Unable to open audio record device. Device may not support the current project's audio format or may be in use" (see attached screenshot). "Soundcard" is onboard realtec. Audio output works fine!

I tried multiple things already:

  • Changing the audio format (44/16, 44/24, 48/16, 48/24) and also changed it accordingly in the realtec configuration
  • Wave Profiler actually shows for all of the formats above "OK".
  • I bought another soundcard (cheap noname pci express card) to have the output on one device and recording on the other. Still the same message.
  • Also played around and used both input and output on the soundcard or on the mainbaord.

[edit] I also discovered that changing the bitrate from 24 to 16 is displayed correctly in the settings, but the indicator in the track view still shows 24. See attached screenshot. Does it maybe mean, it doesn't actually switch to 16? And maybe my onboard and cheap soundcard only support 16? [/edit]

Still the same message. I'm now a bit confused and am hoping that someone already went through this mystery and can point me into another direction. Any help highly appreciated! :)  (I'm a Cakwalk user since the very early years and can't rememver to ever have had this message. So I'm guessing I'm just to blind to spot the error 🙈)

Setup: Win10x64, ASUS b450 PLUS board (with realtext onboard sound), AMD Ryzen 5 3600 and a "docooler" pci express soundcard

Thanks and best,
Chris

 

cakewalk-error.png

cakewalk-sampling-rate.png

Edited by glen dale

Share this post


Link to post
Share on other sites
47 minutes ago, glen dale said:

I also discovered that changing the bitrate from 24 to 16 is displayed correctly in the settings, but the indicator in the track view still shows 24. See attached screenshot. Does it maybe mean, it doesn't actually switch to 16? And maybe my onboard and cheap soundcard only support 16?

The transport shows the Record Bit Depth NOT the Audio Driver Bit Depth

Try the WASAPI Driver Modes

Make sure Windows and CbB use the same sample rate and that Windows does not have Exclusive mode enable.

  • Thanks 1

Share this post


Link to post
Share on other sites

Hi Scook,

thanks for your reply! Indeed, the exclusive mode was enabled. Nontheless, I've now disabled it, set all of the devices (input and output) to 48/24, set the preferences in Cakewalk accordingly, but still the same error. For better debugging I've also unplugged my new soundcard. Also tried the different WASAPI settings, the audio devices are only recognized in "WASAPI (shared)" - not in "WASAPI (exclusive)".

So maybe let me phrase a different question: Does anyone use the onboard realtec sound device for playback and recording? How have you configured Cakewalk?

Best,
Chris

Share this post


Link to post
Share on other sites
1 hour ago, glen dale said:

Does anyone use the onboard realtec sound device for playback and recording? How have you configured Cakewalk?

Onboard sound chips do not have good drivers, pre-amps, good line inputs, good circuitry and have sub-par converters. you can get a sound card made for recording for very little money. If you want to record, i would invest in one.

MOTU, Focusrite and RME are good sound card companies that make great interfaces for recording

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks CJ, indeed, I'd also prefer a dedicated card (had the delta1010lt before).

But before I spend a bunch of money on a soundcard, I want to solve the problem itself (so that it doesn't continue with an expensive card as well). 

Share this post


Link to post
Share on other sites
4 hours ago, glen dale said:

Thanks CJ, indeed, I'd also prefer a dedicated card (had the delta1010lt before).

But before I spend a bunch of money on a soundcard, I want to solve the problem itself (so that it doesn't continue with an expensive card as well). 

You're welcome and if you get a dedicated audio interface, the problem will solve itself.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

A dedicated audio interface is really the best solution, but if you're having trouble with WASAPI, integrated audio cards should be able to play back with the MME driver mode.

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites

Just in case, someone else is having this issue, I finally found the reason: The windows privacy settings deny access to the microphone and this seems to be also valid for line-in 🤦‍♂️. Once I allowed access to the Microphone, Cakewalk finally started recording 😅

  • Like 2
  • Great Idea 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...