Jump to content
Sign in to follow this  
jono grant

Cakewalk exporting waves out-of-sync when using certain video files

Recommended Posts

Hi, I had been in contact with Noel Borthwick some time ago trying to deal with an issue (bug) in Sonar. It has been an issue ever since the X series of Sonar and still exists in the most recent band lab version. The issue was never resolved and Noel had me send files and explanations in to have the issue looked at but I don't believe it ever was. Not sure how to get this post to his attention but it would be great to resolve.

Here's the issue:

Any session file that contains a compressed video file such as an MP4 or QuickTime file, somehow adds a small amount of silence to the beginning of the file. This is not apparent or noticeable in Sonar but once you mix-down any audio from the session it will be out of sync with the same video file when brought into ANY other program such as Vegas video or ProTools etc. This added silence or (padding I think someone called it) is somehow added to the beginning of anything exported out of Sonar when an mp4 or QT is present in the file. The result is that Sonar's exported audio is late by around a frame and a half. It has added silence at the beginning.

I use Sonar/Cakewalk to score for film and television and I have to manually re-sync everything I send out in another DAW or video editor. It's crazy and I have no idea why there aren't more folks complaining about it.

I did several different tests to see if the problem was user related...

- I got same result on a different computer, running a different OS. (win 10) - I'm on Win 8.1

- I got the same result when testing in X1, Platinum and now in Band Lab version. (all slightly different in the amount of silence added but usually a frame or more)

- I tried different codec packs to see if it had anything to do with it. It didn't.

- If you test the sync by bringing the exported audio back into Sonar with the same video file, it's not out of sync because the video file adds the silence again in Sonar so any test done back in Sonar won't have the issue. The test needs to be checked in a different program. TV and film mixers don't generally use Sonar.

- When using another type of video file, AVI orWMV or something, Sonar acts normally when exporting. It has something to do with the MP4 or QT.

- I've tested this same method using different programs and everything syncs as it should.

If you are doing music for film, TV or commercials using MP4 or QuickTime files and exporting audio from Sonar/CBL, your deliveries will be out-of-sync by a frame or more.

To test this yourself, you can download a test MP4 file from here: https://sample-videos.com/ Or use an MP4 from your collection, insert the video into Sonar/CBL and export the audio as a wave file. Then open the same video in another program such as Vegas video or ProTools or another DAW. Import the audio you exported from Sonar, zoom in and compare the audio with the audio attached to the video file. It will be out-of-sync. Note: some QuickTime files don't have the issue so it may be codec related... or something to do with video files inside a container. (sorry, I'm not a video expert) I've attached a screen shot of the video clip in Vegas video, the wave on the bottom is the audio exported from Cakewalk. You can see it is late in relation to the original wave above.

 

If anyone has any info about this issue I'd surely appreciate it!

Thanks!

Jono

 

 

 

 

sonar sync.png

Edited by jono grant

Share this post


Link to post
Share on other sites

I rarely use video with Sonar/CbB, so I can't say I've see the issue. I think the last time I did, it was an AVI file and as you say, AVI files are fine.

My first suggestion would have been to check your codecs, but I see you've already done this.

Although remember MP4 is just a container, so the codec could still be the issue. Some codecs can be particularly CPU intensive, and the CPU usage changes constantly throughout the video. I doubt if Cakewalk's PDC takes account of this in the same way it can with VST's.

The only other suggestion I can think of is to convert your MP4  / QT files to AVI before working with it within Sonar.

I've used this in the past, and it's worked ok for me: http://www.effectmatrix.com/total-video-converter/ , although nowadays I tend to use ffmpeg from a command line: https://www.ffmpeg.org/

It would be interesting to see if just converting it to AVI (but keeping the codec the same) actually fixes the issue. 

If it doesn't, try re-encoding with a different (or no) codec. 

Share this post


Link to post
Share on other sites

Thanks for the reply. This wasn't an issue in earlier versions of Sonar. Converting video files isn't really an option. I get so many mp4s and QTs as it is the most popular format among tv/film productions, there just isn't time for me to do that. Also, the reason MP4s are used as they are small in file size. Converting to something like an AVI for a whole film would be massive in size. The files work and there is no other problem except this export audio out of sync issue.

Any other DAW I have is rock-solid when working with mp4s/QT files. I like Cakewalk though as my music DAW so I'd love for it to work the same way.

I'd love for anyone to do this test and not have the same result. I could then look at options outside of Cakewalk. I have a feeling people might have the same issue though.

Jono

Share this post


Link to post
Share on other sites

You're welcome. FWIW I have always found QuickTime and MP4 dodgy in  SONAR and assume that would still be the case in Bandlab. That's why I tried the vst player originally. 

Share this post


Link to post
Share on other sites
10 minutes ago, Brando said:

You're welcome. FWIW I have always found QuickTime and MP4 dodgy in  SONAR and assume that would still be the case in Bandlab. That's why I tried the vst player originally. 

Just tried vidplayvst and did the same test. The exported audio is out of sync... exactly the same.

Does this rule out a codec? Still thinking it's directly a cakewalk issue

Share this post


Link to post
Share on other sites

Actually I think that suggests to me it IS a codec. Chances are that the exact same codec is being used by Cakewalk as is used by the vidplayer. The only hope (apart from conversion) is to try to install a  different codec/codec pack.

Share this post


Link to post
Share on other sites
6 minutes ago, Brando said:

Actually I think that suggests to me it IS a codec. Chances are that the exact same codec is being used by Cakewalk as is used by the vidplayer. The only hope (apart from conversion) is to try to install a  different codec/codec pack.

I swear I've tried every codec pack out there... same issue. The other programs I have would use those same codecs and without issue, this is just cakewalk.

I just did a test again using an avi and also a wmv file. No issue. Cakewalk does not correctly support mp4/quicktime files, they say they do but they don't.

I think if I told another film/tv composer to try out cakewalk because it's awesome BUT none of your work will deliver in sync, they would likely avoid cakewalk.

I've emailed the post to Noel Borthwick, haven't heard back yet.  Perhaps I'll send to Craig Anderton as well.

Will post any updates. Thanks

Jono

 

 

 

 

Share this post


Link to post
Share on other sites

PM him. (Copy the link then choose the mail icon from your user profile- his info will come up when you start to type his name).

 

  • Thanks 1

Share this post


Link to post
Share on other sites

I can't help but wonder if maybe Cakewalk isn't adding some more info to identify the audio codec. If you take video out of the equation and only looked at the audio, then any wav will be out of sync with it's Mp4 copy because of the codec information added to it. Are you bringing in a wav at the beginning of the mix?

Until this is resolved I would likely keep the wav file and simply realign to it.....or use Vegas.

Share this post


Link to post
Share on other sites
13 minutes ago, Starise said:

I can't help but wonder if maybe Cakewalk isn't adding some more info to identify the audio codec. If you take video out of the equation and only looked at the audio, then any wav will be out of sync with it's Mp4 copy because of the codec information added to it. Are you bringing in a wav at the beginning of the mix?

Until this is resolved I would likely keep the wav file and simply realign to it.....or use Vegas.

Thanks. Whatever it's doing, it shouldn't mess with the time line. It shouldn't matter where anything is on the time line, the video always starts at the beginning of the session unless you set a trim time (which never works properly). Point is, if you open an mp4 in Vegas, ProTools, Cubase, you-name-it, everything will be frame accurate when you export your audio out of the file and into any other program and there is no "adding info to support a codec". This is a bug in cakewalk. I'm just tired of manually re-syncing wave files that I need to deliver, been doing it for years. It's an unacceptable work-around.

Hoping someone from Cakewalk will look at this issue.

Share this post


Link to post
Share on other sites

This is known for mp3s, and the lead padding is variable depending on the specific file (no set offset will solve it). Unfortunately that padding is front-loaded, which is why sending mp3s for collaboration can cause a headache without an audio transient to align to.

I can only assume this is similar for compressed video, so the advice above to convert to uncompressed prior to editing would be wise.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...