Jump to content
Jesse Bruce

Mercuriall secret sale

Recommended Posts

Exellent amp , one of the best i tried , skipped beacuse of cpu and also price ....

  • Like 1

Share this post


Link to post
Share on other sites
On 8/7/2020 at 10:20 AM, Jesse Bruce said:

72-hour, "40% off" sale

Euphoria

https://mercuriall.com/cms/details_xtc

Same discounts for other products.

Not secret anymore..at least not after posting on this forum :)

Saw a few comments that for 80/90’s sounds these amps are awesome but they do have a warning about underperforming in studio one and ableton live so they recommend trying out demos extensively first if using those DAW’s

 

  • Haha 1

Share this post


Link to post
Share on other sites

Exactly!
They're good developers who say it's a secret to their existing customers, but are willing to share it with you all please.
NRQ's accompanying IR is good.👌

Share this post


Link to post
Share on other sites

I also gave Euphoria a test spin and was quite impressed with it. Might just get this as well. :)

 

Share this post


Link to post
Share on other sites

Tried it, too. To my ears, it's quite responsive, cleans/crunch are decent, effects so-so. You can tell the same people are behind Audio Assault and Mercuriall: UI is pretty terrible, even the bugs are the same! To me, it feels way unpolished and overpriced, but good enough that it might be getting somewhere, someday.

Disclaimer: I don't take into account heavy/metal sounds here, because I never know how to evaluate them. As a blues/(soft) rock guitarist and to the despair of my shredding brethren, I suffer from a persistent bias in that I believe heavy distortion is the big equalizer, and I can take any decent high-gain amp sim (say, a Nembrini), feed it some nice IRs and maybe tweak it with a good EQ/compressor, and make it sound like any other 'great' high-gain amp sim :/

Share this post


Link to post
Share on other sites
43 minutes ago, Mesh said:

Which bugs did you run into Fitz?

I can't get it to work in standalone. Just like the Audio Assault bass plugin I bought a few days ago, which has the same audio settings UI. They both work fine in Reaper. 

Share this post


Link to post
Share on other sites
4 hours ago, fitzroy said:

I can't get it to work in standalone. Just like the Audio Assault bass plugin I bought a few days ago, which has the same audio settings UI. They both work fine in Reaper. 

Check your samplerate , some standalone software are really peaky about that , so try changing those sample rate values and test ...

  • Thanks 1

Share this post


Link to post
Share on other sites

Interestingly, I  only have used it in standalone mode. The only issue I have is the gui is a bit too big ('medium' is the smallest setting) and it takes up the whole screen. Other than that, it works fine (sample rate is 48Hz and buffer size 256  with   5.3 ms)

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, Mesh said:

Interestingly, I  only have used it in standalone mode. The only issue I have is the gui is a bit too big ('medium' is the smallest setting) and it takes up the whole screen. Other than that, it works fine (sample rate is 48Hz and buffer size 256  with   5.3 ms)

That's what I use (48 kHz, 256/5.3ms). I think it might not like my legacy MOTU drivers. It's the only standalone amp sim that I can't run though, so there's that. The UI is terrible (Audio Assault's Duality, probably from the same team, is even worse). Kinda' makes Neural DSP's stuff feel cheap in comparison :)

Edited by fitzroy

Share this post


Link to post
Share on other sites

Did they ever fix up the need to reauthorize after every major Win 10 upgrade?

They said they were going to, but the last time I tried to fire one of them up it wanted me to reauth, so I just couldn't be bothered.

I own them all except this latest one, but the fact that I run into the reauth thing when I go to fire them up probably speaks to how often I have had a desire to run them.

I noticed in the ChangeLogs for the latest versions of the other Amps  it says under Improvements, 'Copy protection code' so maybe they did fix it.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...