Jump to content

Recommended Posts

1 hour ago, jghford@gmail.com said:

Issue Resolved. Stupidly forgot to plug in my Scarlet 2i2 before starting up cakewalk. Everything works perfectly now.

Happens to the best of us.¬†ūüĎć

  • Like 1

Share this post


Link to post
Share on other sites
On 8/25/2020 at 2:18 PM, Jonathan Sasor said:

Mix Recall is also your friend.¬†ūüĎć

I'll have to give it a look. My gut feeling is that there's too much that it doesn't remember. 

Share this post


Link to post
Share on other sites

So I didn't want to update CbB whilst in the middle of a tracking sessions, - is it safe and stable to do so now?  What has been the main issue I need to look out for (if anything) 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Respecting the Global Snap for Staff view is very inconvenient.

Normally the precision of editor and track views are different. PRV has an independent Snap options exactly for that reason, e.g. I always have it at 32nd in the PRV and Smart Grid globally. With Staff view it's even worse as there's no way to zoom in horisontally in a hope that Smart Grid would pick the right snap resolution, so you have to change the Snap all the time as you switch between SV and TV.

I think a good solution would be to add the same independent snap settings to the staff view as there are for PRV, i.e. this

image.png.0f2c4fd0296d0c5fe05666e377c98c7e.png

I know this has been a workflow showstopper for a couple of colleagues of mine, and every one of them has reverted to the previous version.

 

Edited by Helene Kolpakova
  • Like 1
  • Great Idea 1

Share this post


Link to post
Share on other sites
Quote

The Staff view respects the global Snap to Grid settings for note positioning when drawing notes.

Is it possible to disable this and do it as it was in previous versions?

UPD Maybe I translated something wrong with the help of Google translator.
I ask you to suggest how to change the spelling of notes in version 26.08 to the previous method (as in version 26.05).

26.08

https://1drv.ms/u/s!AlLNG4SDVWiJgqYoHPS-DatGIZBYiQ

26.05

https://1drv.ms/u/s!AlLNG4SDVWiJgqYnewqpOfC0wm4izA

Share this post


Link to post
Share on other sites
10 hours ago, Vyacheslav said:

The Staff view respects the global Snap to Grid settings for note positioning when drawing notes.

Is it possible to disable this and do it as it was in previous versions?

UPD Maybe I translated something wrong with the help of Google translator.
I ask you to suggest how to change the spelling of notes in version 26.08 to the previous method (as in version 26.05).

26.08

https://1drv.ms/u/s!AlLNG4SDVWiJgqYoHPS-DatGIZBYiQ

26.05

https://1drv.ms/u/s!AlLNG4SDVWiJgqYnewqpOfC0wm4izA

 

On 8/30/2020 at 7:50 PM, Helene Kolpakova said:

Respecting the Global Snap for Staff view is very inconvenient.

Normally the precision of editor and track views are different. PRV has an independent Snap options exactly for that reason, e.g. I always have it at 32nd in the PRV and Smart Grid globally. With Staff view it's even worse as there's no way to zoom in horisontally in a hope that Smart Grid would pick the right snap resolution, so you have to change the Snap all the time as you switch between SV and TV.

I think a good solution would be to add the same independent snap settings to the staff view as there are for PRV, i.e. this

image.png.0f2c4fd0296d0c5fe05666e377c98c7e.png

I know this has been a workflow showstopper for a couple of colleagues of mine, and every one of them has reverted to the previous version.

 


Just click the Global Snap to turn it off - it'll revert back to the old behaviour of  1/32nd (or 1/24 when using triplets).  

 

  • Thanks 1

Share this post


Link to post
Share on other sites

An official 2020.08 hotfix will roll out very soon to all users, but if you are affected by any of the issues listed below you may download the 2020.08 hotfix now.

  • Thanks 2

Share this post


Link to post
Share on other sites
3 hours ago, msmcleod said:

Just click the Global Snap to turn it off - it'll revert back to the old behaviour of  1/32nd (or 1/24 when using triplets).  

I appreciate the workaround, thank you. It still however implies clicking/hotkeying the global snap button every time one switches between Staff and TV. That's a lot of unnecessary, and thus unwanted, extra clicking/key pressing.

  • Like 2

Share this post


Link to post
Share on other sites

I could not get the updater to run without error messages. I uninstalled both bandlab assistant and cakewalk and then reinstalled them and still no good.

Error messages can be viewed here  https://www.dropbox.com/s/uyxcqvc7r40hxvi/install error messages.pdf?dl=0

I hope someone is able to point me in the right direction to get Cakewalk back up and running.

Thanks in advance, Best regards,

Ian

  • Sad 1

Share this post


Link to post
Share on other sites
14 hours ago, msmcleod said:

Just click the Global Snap to turn it off - it'll revert back to the old behaviour of  1/32nd (or 1/24 when using triplets).  

Thanks! But this is not convenient! It is very inconvenient to do this every time you switch between the Staff and Tracks windows.

It is also inconvenient, because without being bound to the rhythmic grid, all the notes have to be entered, literally aiming with the mouse not only at the stave's rulers in terms of the pitch of the notes, but also in terms of their rhythm.

Edited by Vyacheslav
  • Thanks 1

Share this post


Link to post
Share on other sites
On 8/31/2020 at 8:03 PM, ian myers said:

I could not get the updater to run without error messages. I uninstalled both bandlab assistant and cakewalk and then reinstalled them and still no good.

Error messages can be viewed here  https://www.dropbox.com/s/uyxcqvc7r40hxvi/install error messages.pdf?dl=0

I hope someone is able to point me in the right direction to get Cakewalk back up and running.

Thanks in advance, Best regards,

Ian

So this error is with the Microsoft VS2019 redist that is a sub installer required for Cakewalk. Check your Add/Remove programs list for what redists that you currently have installed. You might need to remove ones that are already installed, and then run the Cakewalk installer again. 

You can also try manually reinstalling the Visual Studio C++ redist directly from Microsoft here:

https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads

Share this post


Link to post
Share on other sites
On 9/1/2020 at 8:50 AM, Vyacheslav said:

Thanks! But this is not convenient! It is very inconvenient to do this every time you switch between the Staff and Tracks windows.

It is also inconvenient, because without being bound to the rhythmic grid, all the notes have to be entered, literally aiming with the mouse not only at the stave's rulers in terms of the pitch of the notes, but also in terms of their rhythm.

@Vyacheslav - can you clarify this for me?

In the previous release, the snap was hard-coded to 1/32... so you would have to aim quite precisely between the two bar lines to correctly position the notes rhythmically. In other words, there was always 32 positions between the bars where the note could be placed.

Now, when global snap is on and set (for example) to 1/4, you don't need to be as precise as there's only 4 positions it could be placed in rhythmically.

When global snap is off, it reverts back to the previous release's behaviour of 1/32.

To my mind, having the global snap set to a less precise amount makes it easier to aim, not more difficult.... or am I missing something?
 

Share this post


Link to post
Share on other sites
12 hours ago, Jonathan Sasor said:

So this error is with the Microsoft VS2019 redist that is a sub installer required for Cakewalk. Check your Add/Remove programs list for what redists that you currently have installed. You might need to remove ones that are already installed, and then run the Cakewalk installer again. 

You can also try manually reinstalling the Visual Studio C++ redist directly from Microsoft here:

https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads

Thanks Jonathan for your reply. I tried removing all redists and then manually installing from the link above. All went fine until the latest x64 version of the redist. The first error again was Microsoft Visual C++ 2017 x64 Minimum Runtime 14.16.27024 is missing and needed. Then the message came up for me to insert a cd to install this or to search for it on my pc. I neither have a cd containing this software and neither can i find it on my pc. The second error informs me that Microsoft Visual C++ 2019 x64 Minimum Runtime 14.27.29016 cannot be removed yet it does not appear in my Add/Remove programs list for me to manually uninstall. I have not yet tried to remove redists that are already installed, and then run the Cakewalk installer again butI have  been on the Microsoft forum and received suggestions from a guy on there. Mainly instructions on how to remove old redists and then how to reinstall all redists.  All of those suggestions still ended with the same problem. This is very frustrating and is preventing me from updating to the latest version of Cakewalk.

Share this post


Link to post
Share on other sites

Hello !

I don't know if this problem has been reported here, and if so I apologize, but I don't have time to read the 7 pages of this topic, knowing moreover that I am not very good in english (thanks google translate).

So here is my problem:

On a project I'm working on, every time I try to turn the music into mp3 via the quick exporter, it sets all my controllers to zero (control via automation curves), and Cakewalk no longer recognizes them when I replay my song from the beginning, until I enter each track to handle them.
Listening to the mp3 create, I notice Cakewalk recorded it with the problem included.

I will try it with the file menu exporter to see if it can work.

Edit :

The file menu exporter works fine, so the problem is with the quick version of the program.

I would like to add a suggestion for something that is not a bug, but is annoying.
You have updated the instrument tracks by allowing the use of Midi automations, but it would also be useful to have the possibility of including the Midi plugins in these tracks as easily as an audio plugin, all side by side.
For the moment we are obliged to enter the track parameters to put a Midi plugin or to divide the instrument track to be able to put a Midi plugin directly.
In short, it's boring especially if you want to copy a midi plugin on several tracks.

Edited by lychee
rewriting some part of my comment

Share this post


Link to post
Share on other sites

I just updated to 2020.08 Build 100, and it seems that the ''surround'' feature of Cakewalk are gone.

In the preferences of build 100, under the Project tab, there's no more ''surround'' available: 

image.png.3999905fa19e827ebf8a7ea4028f6703.png

While on my other PC, I have build 39, and the feature is available:

image.png.cc2b513851135c5d570f185575b122ff.png

 

Share this post


Link to post
Share on other sites
7 minutes ago, Musicflow said:

I just updated to 2020.08 Build 100, and it seems that the ''surround'' feature of Cakewalk are gone.

In the preferences of build 100, under the Project tab, there's no more ''surround'' available: 

image.png.3999905fa19e827ebf8a7ea4028f6703.png

While on my other PC, I have build 39, and the feature is available:

image.png.cc2b513851135c5d570f185575b122ff.png

 

Are you using Workspaces? If you're on the Basic Workspace, Surround is omitted, but setting to None or Advanced should show it. 

  • Like 2

Share this post


Link to post
Share on other sites
10 minutes ago, Jonathan Sasor said:

Are you using Workspaces? If you're on the Basic Workspace, Surround is omitted, but setting to None or Advanced should show it. 

I was using the default Workspace, which is basic. I wasn't aware of that... Setting the workspace to None solved problem!

 

Thank you Jonathan!

  • Like 2

Share this post


Link to post
Share on other sites
On 9/2/2020 at 7:42 PM, msmcleod said:

@Vyacheslav - can you clarify this for me?

In the previous release, the snap was hard-coded to 1/32... so you would have to aim quite precisely between the two bar lines to correctly position the notes rhythmically. In other words, there was always 32 positions between the bars where the note could be placed.

Now, when global snap is on and set (for example) to 1/4, you don't need to be as precise as there's only 4 positions it could be placed in rhythmically.

When global snap is off, it reverts back to the previous release's behaviour of 1/32.

To my mind, having the global snap set to a less precise amount makes it easier to aim, not more difficult.... or am I missing something?
 

@msmcleod - Thanks for the answer!

If I understood you correctly ...

https://1drv.ms/u/s!AlLNG4SDVWiJgqYoHPS-DatGIZBYiQ - Here you can see that (figuratively speaking) I do not have four positions and all the notes fall into the first beat of the measure, wherever I clicked with the mouse in the measure.

Share this post


Link to post
Share on other sites
Just now, Vyacheslav said:

@msmcleod - Thanks for the answer!

If I understood you correctly ...

https://1drv.ms/u/s!AlLNG4SDVWiJgqYoHPS-DatGIZBYiQ - Here you can see that (figuratively speaking) I do not have four positions and all the notes fall into the first beat of the measure, wherever I clicked with the mouse in the measure.

There's two things in play here:

1. The positioning resolution (dictated by the Global Snap - which is set to whole measures)
2. The note length, which is dictated by which note you've clicked.

What you're selecting is different note lengths,  not different position resolutions.

There's actually a couple of other settings in the View menu that may affect things:

3. The "Display Resolution" - I pretty much always keep this at 1/32.
4. The "Fill Durations" setting, which I suspect is checked on your set up. I normally keep this unchecked.
 

Share this post


Link to post
Share on other sites
18 hours ago, msmcleod said:

There's two things in play here:

1. The positioning resolution (dictated by the Global Snap - which is set to whole measures)
2. The note length, which is dictated by which note you've clicked.

There's actually a couple of other settings in the View menu that may affect things:

3. The "Display Resolution" - I pretty much always keep this at 1/32.
4. The "Fill Durations" setting, which I suspect is checked on your set up. I normally keep this unchecked.
 

1. That's just it, that in version 2020.05 nothing in the staff does not depend on this setting - the notes can be inscribed in any part of the rhythm.

https://1drv.ms/u/s!AlLNG4SDVWiJgqYnewqpOfC0wm4izA

2. Sorry, but because of the difficulty of translating this phrase, I don't understand.

3. Yes, I do the same.

4. Disabling this feature does not affect anything.

Quote

What you're selecting is different note lengths,  not different position resolutions.

No matter what I do, a note of any length hits the first beat of a measure.

Edited by Vyacheslav

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

√ó
√ó
  • Create New...