Jump to content
Fleer

OB-XD 2.0 - still free

Recommended Posts

Nope. 
“OB-Xd Desktop has no restrictions and is free to use.“

but you may always make a donation of $49. 

Share this post


Link to post
Share on other sites

Changes in OB-Xd v2.0

7x faster GUI controls.

Linux build.

Standalone app.

Signed and notarized installers.

Updated JUCE framework to 5.4.7 for better stability and compatibility.

Updated Banks with 2.0 compatibility.

Ilkka Rosma Dark Theme.

MacOS Catalina support.

MIDI CC learn.

MIDI CC support.

Parameter refactor.

XML based skinning and HiDPI (Retina) ready GUI themes.

OB-Xd for Windows, Mac and Linux (VST/VST3/AU/Standalone) is available as a free download with an optional donation of $49 USD.

  • Thanks 1

Share this post


Link to post
Share on other sites

Any info on how to access other skins? The default is very blah...

 

Just found it in the standalone. Now to see if that carries over if if similar setting is available in the plugin.

Yup. Skin selected in the standalone carries to the plugin. Nice.

Nice sounding synth!

 

Edited by Keni

Share this post


Link to post
Share on other sites
13 minutes ago, LAGinz said:

I must be blind. I see where the banks are selected, but where is the preset window in the GUI?

"Right click anywhere on the GUI ..."

 

Edited by Wibbles

Share this post


Link to post
Share on other sites

OB-Xd v2 VST3 displays the programs in the host VST window in at least CbB and Reaper. May be others...

Or you can use the VST2 version in other DAWs that do not. The VST2 works in the same fashion elsewhere.

However, the previous advice is the only method I am aware of for switching banks in any version.

Cakewalk w/ VST3:

OB-Xd Cakewalk Programs VST3.PNG

 

Reaper w/ VST3:

OB-Xd Reaper Programs VST3.PNG

Edited by abacab
  • Like 1

Share this post


Link to post
Share on other sites

sounds nice, why hadn't I heard about this?!

re presets, you can just left-click on the menu symbol at the top left corner

image.png.66605647836a4ea2be0d82f029bd323e.png

Share this post


Link to post
Share on other sites

If you own PluginGuru Unify which comes with a "Unified" version of OB-Xd this is what the developer says about installing version 2...

Quote

Probably best not to replace the present version of OB-Xd just yet. I've installed the new version here, but haven't yet done much testing.

Nothing of importance has changed. The major new feature is MIDI-learn, but in Unify you already have MIDI-learn for macros, and far more flexible parameter linking. There are also some changes to the installers for MacOS Catalina, which we had dealt with already. Everything else is cosmetic.

If you want to test the new version, just install it normally, to one of your regular VST folders, then scan it in the usual way. Please don't attempt to replace anything in Unify's own VST folder. This way, you'll still be able to use the older one (listed as "Obxd" by "Datsounds") as well as the newer one (listed as "OB-Xd" by "DiscoDSP").

My main concern is that the new installer will overwrite the OB-Xd presets, possibly with changes (the news link mentions "parameter refactor" and "updated banks with 2.0 compatibility") that might cause the older version to load them incorrectly.

I had a problem with Unify crashing a while back which turned out to be due to having a different version of Dexed installed before I purchased Unify which comes with its own version. Unify had scanned my VSTis and included both versions of Dexed in its list of plugins. The solution, which also meant I could keep my version of Dexed with lots of patch banks, was to remove the non-Unify version of Dexed from Unify's plugin list. This is easy to do as Unify will not let you remove "internal" plugins. 

Edited by ZincT
  • Thanks 1

Share this post


Link to post
Share on other sites

Is it really worth getting if you own opx pro , arturia s and omnisphere ? 

  • Confused 1

Share this post


Link to post
Share on other sites
2 hours ago, Zo said:

Is it really worth getting if you own opx pro , arturia s and omnisphere ? 

Your comment could be characterized as "I have enough plugins already," do you want to clarify before being banned forever from this forum?

  • Haha 7

Share this post


Link to post
Share on other sites
2 hours ago, Monomox said:

Your comment could be characterized as "I have enough plugins already," do you want to clarify before being banned forever from this forum?

source.gif

Edited by Zo
  • Haha 2

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...