Jump to content
tdehan

How do I stop the delay when using MIDI controller?

Recommended Posts

When I attempt to add a MIDI part with my Roland PC-200 MK II Midi Controller there is an obvious delay which makes it impossible to play along with my recorded tracks.  I am coming out of the Roland into my Berhinger U-Phoria UMC4040HD.    Under Audio Devices I am using the UMC ASIO Driver:

Capture.JPG.5dfa6abc87b0fe8dd9772c39848a3d9c.JPG

The Audio Driver Settings are set like this:

Capture.JPG.0151e0395f0a4abe47185948829ba0df.JPG

Driver Mode is set to ASIO

Capture.JPG.187a4e001d61ad10b4332ab0f97d1f9d.JPG

MIDI Devices is set to the UMC4040HD

Capture.JPG.d7e4cf357320841a7dca07d42263001f.JPG

What am I missing?

 

Share this post


Link to post
Share on other sites

There are two things users can change that contribute to the delay from pressing a key on the controller and hearing the result.

  • audio driver buffer size
  • plug-in delay compensation

A 256 sample buffer size is at the upper limit for real time monitoring through the DAW.

To see if plug-ins are contributing to the delay click the FX button in the Mix Module to bypass all effects. While reading these sections in the help take a look at the PDC button too.

To avoid PDC do not use plug-ins that need a look ahead buffer while tracking. Generally these plug-ins are intended for mastering and include dynamics processors, linear phase EQs and impulse response reverbs.

Another way to work around large amounts of PDC is temporarily bounce all the tracks, archive everything except the temporary track and the track being recorded.

 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

+1 to what @scook has said.

Your total round trip is 18.3 ms... you want to aim for less than 10ms if not less for recording in real time.  Try reducing your buffer size to 128 or even 64  ( personally, I can't tolerate playing with anything above 64 ). 

Bypass any effects you don't actually need while recording - you can always enable them afterwards and/or turn up your buffer for mixing. Alternatively, freeze the other tracks with the effects on them if you really require them to be heard as is when recording, then unfeeze afterwards.

It's quite normal to have a low buffer size of say 64 for recording (with minimal effects), and then jump to 512 or 1024 for mixing later.

Share this post


Link to post
Share on other sites
Posted (edited)

I turn off all effects (highlight FX), turn on PDC (highlighted) and set the buffer down to 128 or 256. At that point the delay is not noticeable but my system sometimes starts going static at 128. 256 is good enough for me.

Considering how slow MIDI really is, it's disappointing that you have to defeat so many thing to get it to pass from the keyboard/controller to Cakewalk without taking seconds (ok, it's less than a second with effects turned on. no PDC and a larger buffer.) It's a Windows issue. DOS didn't have this issue even with the generally slow MIDI data rate and opto-isolater delays.

Edited by Terry Kelley

Share this post


Link to post
Share on other sites
17 hours ago, scook said:

There are two things users can change that contribute to the delay from pressing a key on the controller and hearing the result.

  • audio driver buffer size
  • plug-in delay compensation

A 256 sample buffer size is at the upper limit for real time monitoring through the DAW.

To see if plug-ins are contributing to the delay click the FX button in the Mix Module to bypass all effects. While reading these sections in the help take a look at the PDC button too.

To avoid PDC do not use plug-ins that need a look ahead buffer while tracking. Generally these plug-ins are intended for mastering and include dynamics processors, linear phase EQs and impulse response reverbs.

Another way to work around large amounts of PDC is temporarily bounce all the tracks, archive everything except the temporary track and the track being recorded.

 

Thanks!  Are you referring to this setting to decrease the buffer size?

Untitled.png.5e6469fddeec188cc9c73a2db2fa04e3.png

Share this post


Link to post
Share on other sites

Yes, move the slider to the left (Fast) if the machine and interface can tolerate a smaller buffer.

 

Share this post


Link to post
Share on other sites

Ok.  

Can you please elaborate on what you mean by "if the machine and interface can tolerate a smaller buffer"?

 

Share this post


Link to post
Share on other sites

Too small a buffer can cause dropouts or audible clicks and pops.

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...