Jump to content
Bassfaceus

x touch mini and ACT

Recommended Posts

Posted (edited)

ok this is frustrating..

i just want to be able to manipulate my vst plug in knobs EQ ,compressor etc 

via the rotary pots on my X touch mini ..thats all. no playback transport control...dont care about that.

Now using both azlow  AZ controller or the inbuilt ACT midi controller...

I can get it to work initaily in a project but then after while (i know scientific,right)

it stops working and ive tried everything i can think of to reconnect with either drivers.

so all i want is reliable control of the plug in knobs..is anybody doing this?

if so please tell me how/what your are using..

OK more details... i setup AZ controller hit ACT button

wiggle a vst knob then wiggle an x touch knob and cakewalk says

"parameter control were touched etc" just like it should but no lights on the rotaries and when

i bring up the AZ display it says no mapping so WTF

Edited by Bassfaceus

Share this post


Link to post
Share on other sites

As first, with one device I strongly recommend to use ONE plug-in in a time. So, if you want use "ACT MIDI" you have to remove "AZ Controller" (or reversed).

When you write "stops working", what exactly do you mean? So, when it "stops":

  1. Do you still see X Touch Mini in Cakewalk MIDI preferences?
  2. If yes, do its inputs/outputs still assigned in Cakewalk Control Surface preferences?
  3. If yes and you use AZ Controller, open its GUI and move some control, do you see changes in the "Last MIDI event"?
  4. Does Cakewalk display some dialogs like "MIDI device connected/disconnected"?
  5. Do you use other software with controller?

X Touch Mini sometimes has strange reaction on Mackie "Bye" command (at least my does), so after running DAWs which use that protocol the device is "disconnected" when the DAW is closed (normally reconnect immediately, but not always).

If you connect it throw USB hub (especially with long cable), try shorter way to the computer. Note that it will be "new device" on another port, which in turn can be problematic for Cakewalk (there are many threads about the issue, cleanup not existing instances in Windows Device Manager and delete Cakewalk MIDI INI file, search the forum in case you want more detailed instructions how to do that).

---------------

In case controller is working, but Plug-in mapping "disappear" or you have other mapping issues: http://www.azslow.com/index.php/topic,297.0.html

Note this utility works for all ACT mappings, not only for AZ Controller.

Share this post


Link to post
Share on other sites

Thanks for trying to help me ,azslow3

answers to your questions...

1.. yes  xtouch mini is seen as midi device and i am able to setup a connection

2.. all outputs in control pref are set properly

3.. Yes . i see changes in last midi event..as i said earlier, i open the plug in,

turn on ACT, wiggle a knob, turn off ACT and it  confirms my movement

by asking if i want to keep the change,of course i say yes..

but then it does not respond and long press on "B" brings up

the AZcontrol window and it say "no  mapping" but everything upto this point looks correct.

4.. No because it is connected and recognized and afaik is working properly (except for this issue)

5..Not sure what you mean ..i have an  xtouch control surface which i would like to use together with the mini

but regardless of wether together or not ,the mini still does the same thing

ive tried countless experiments/variations

5.. i dont think the device is ever disconnected because i can still control the transport functions

6..No its coonected directly to USB on the M/B

6.. i have been to device manager and removed all the "ghost " x mini entries ..so not that

7.. ive tried using az actfix  in all the ways suggested in the link .

Nothing..

anything else i can try?

thanks

Share this post


Link to post
Share on other sites

Do you see "No mapping" also during learning?

"No mapping" means plug-in is "not detected". Check plug-in selection buttons (and indication) in the documentation of X-Touch Mini preset, but normally clicking on plug-in GUI with mouse should focus that plug-in (also for ACT operations).

I have not checked ACT in recent Cakewalk versions, may be something was checked.

BTW I assume that is the only hardware controller you use and AZ Controller is the only Control Surface in the Cakewalk preferences list. Different controllers can influence each other when it comes to ACT mapping.

 

 

Share this post


Link to post
Share on other sites

I see "no mapping " during learning as well.

 and as i stated earlier i also have a big 8 channel x touch control surface as well as xtouch mini.

regardless of wether i use them together or separate ..same issue

Share this post


Link to post
Share on other sites

I have updated Bandlab (2020.05) and everything works as expected.

Switch to plug-in mode (A and B lit). On the current track enable ProChannel EQ (for now with mouse). Switch to ProChannel Mode (long press "<<", "<<" lit, ">>" does not). Use "<<" and ">>" to switch between modules, do you see "Track-EQ" instead of "No mapping" at some point?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...