Jump to content
SynthManDan

Anyone still having sustain problem with some VST’s?

Recommended Posts

Posted (edited)

Anyone else still having the sustain issue with Cakewalk?  We’ve discussed it in the past, and still couldn’t really pin it down.

I’ve had the issue on several computers from various makers.  Out of my VST’s it seems to affect AIR VST’s, and I’m even seeing it with SampleTank.

Sustained notes “via a pedal input” just continue on when you toggle start/stop.  When you look at the controller data, the sustain off message is recorded, but for whatever reason the VST’s don’t respond to it.

SMD

Edited by SynthManDan

Share this post


Link to post
Share on other sites

Check your keyboard shortcuts to see you've not got MIDI Controller 64 mapped as SHIFT:

image.png.1229db49d8250e5b9df51257de20613a.png


 

Share this post


Link to post
Share on other sites
Posted (edited)

Mine had KEY set to C-0, and CONTROLLER set to 64.  I set the CONTROLLER to 0, and it automatically reverted back to 64 after a recording test.  I also set it to what your screen shot was and it still reverted back to 64 for CONTROLLER, and that was even after clicking APPLY to keep the change.  It’s not saving the change, even after I close and reopen CW.

SMD

Edited by SynthManDan

Share this post


Link to post
Share on other sites
3 hours ago, SynthManDan said:

Mine had KEY set to C-0, and CONTROLLER set to 64.  I set the CONTROLLER to 0, and it automatically reverted back to 64 after a recording test.  I also set it to what your screen shot was and it still reverted back to 64 for CONTROLLER, and that was even after clicking APPLY to keep the change.  It’s not saving the change, even after I close and reopen CW.

SMD

I think you have to check the MIDI radio box first with the Enabled checked , then save, disable the checkbox then change it back to Computer.

Share this post


Link to post
Share on other sites
Posted (edited)

Thx.., that helped getting the setting to save, but the sustain issue is still present.  Not sure if you guys have Xpand2 or SampleTank to test with, but I’ve got both showing the issue, and Acoustica’s Pianissimo as well.

Again not all of us are experiencing it either.  I talked with Simeon over on YouTube, who did his SampleTank 4 videos using Cakewalk.  He didn’t have the issue.  I do remember a few others on the forum responding they had the issue.  My workaround was usually just use another VST, but SampleTank and Xpand2 get used a lot in my work.  

SMD.

Edited by SynthManDan

Share this post


Link to post
Share on other sites

Ok - other things that can cause this:

1. Cheap USB MIDI  "cables" can cause this because their internal buffer size is tiny.
2. Check your MIDI settings within cakewalk ( MIDI Playback & Recording)

  • Make sure "controller" is checked
  • Make sure your MIDI Prepare Buffers aren't set to some crazy value - the default of 200 should be fine for the vast majority of projects. If your project is particularly large (e.g. 75+ MIDI tracks, maybe try 250 or 300 )
  • Some older MIDI interfaces have problems with UWP - try MME (you need to have no projects loaded to change this)

Share this post


Link to post
Share on other sites

I checked the settings and made adjustments to your suggestions, still hangs.  I don’t think it’s my USB cable.  I have quite a few, I tried 5 different cables and the same with all (they’re not cheap cables either).

SMD

Share this post


Link to post
Share on other sites
29 minutes ago, Blogospherianman said:

I was just experiencing this today with Vienna Synchron Pianos.

I’m willing to bet if you check the controller data for the track, you’ll see pedal off messages.  It’s an odd bug.  

SMD

Share this post


Link to post
Share on other sites

I have that too.  I get stuck noted all the time in Kontakt 4,5,6 Might be even older versions, I can't remember.

My work around has been to put a volume envelope at the front of the track. Then I drop the volume to 0 for a measure. Most of the notes will be gone by then.  I've tried setting this and that, nothing seems to help.

 

Your saying just set it to 120 and all is good?

If not please put me on the list to be notified if someone finds the cure.

Max Arwood

Share this post


Link to post
Share on other sites

Is there some way to key bind the sustain pedal up globally to the space bar.  That way with I press space to stop to pedal will lift on all channels will stop ringing.  I know when I use space to start a song it might make the 1st few notes different. This will only till a pedal press is encountered.

Max Arwood

Share this post


Link to post
Share on other sites

Just for giggles, what happens if you bounce or freeze the affected track? Does the sustain play correctly in the bounced/frozen track?

Share this post


Link to post
Share on other sites

Plays correctly while listening all the way through and when bouncing.  Gets stuck in sustaining when hitting stop (spacebar) during playback of a sustain.  Stops if you press and release the pedal.

Share this post


Link to post
Share on other sites
19 minutes ago, Blogospherianman said:

Plays correctly while listening all the way through and when bouncing.  Gets stuck in sustaining when hitting stop (spacebar) during playback of a sustain.  Stops if you press and release the pedal.

That’s exactly what I’ve been experiencing, but only with a few VST’s.  People have said in the past “just press the space bar on a non-sustained part of that track”.., and honestly I wonder how many of those people are actually pianists or keyboardists because that’s an unbelievably frustrating approach to it.  Especially when mixing.  Seriously, try mixing a 15-20 track composition, and keeping tabs on all the sustain locations on ALL of your tracks .

SMD

Share this post


Link to post
Share on other sites
3 hours ago, SynthManDan said:

That’s exactly what I’ve been experiencing, but only with a few VST’s.  People have said in the past “just press the space bar on a non-sustained part of that track”.., and honestly I wonder how many of those people are actually pianists or keyboardists because that’s an unbelievably frustrating approach to it.  Especially when mixing.  Seriously, try mixing a 15-20 track composition, and keeping tabs on all the sustain locations on ALL of your tracks .

SMD

Ever since my early days of using sequencers back in the 80's,  I've always been acutely aware of how the sustain controller works. I remember watching a friend cutting and pasting my piano parts in Pro 24 and grimacing thinking "you can't just do that - what about the sustain pedal events!!!"

For the most part, the sustain controller is just a switch. Unless you've got reset all controllers set as default, if you stop playback when the switch is on, it'll stay on until the synth / piano receives an off switch. 

Similarly, if you crop a clip so it hides the sustain off event, the sustain will continue to the next part.

Like it or not, this is just how MIDI works.

I got into the habit a long time ago of inserting a CC#64 : 0   (sustain off)  at the beginning of every clip in piano parts to minimise unwanted sustains.

IMHO you should treat your CC sustain events as being as important as the notes, and be aware of where they are.

Share this post


Link to post
Share on other sites

57Gregy: If you freeze with stuck notes on they are still stuck.

 

msmcleod:  Is there a way to add global pedal off to space bar stop as an option?? Or some way I can program it?

Thanks,

Max Arwood

 

Share this post


Link to post
Share on other sites

Msmcleod.., I understand your points, but what would explain the VST specific sustain issues?  I can record a piano track using one VST that isn’t affected by this (SoniVox 88 Ensemble for example), then record the same thing using a piano from SampleTank or Air Mini Grand, and the problem is present.  All would be recorded identical.  Controller data for all included VST’s would show “pedal off” information, but only one of those three actually responds to the pedal off when pressing start/stop.

SMD

Share this post


Link to post
Share on other sites
Posted (edited)
5 hours ago, msmcleod said:

Unless you've got reset all controllers set as default, if you stop playback when the switch is on, it'll stay on until the synth / piano receives an off switch. 

This is the problem, I’ve got ‘on stop reset all controllers’ enabled and still have the sustained notes.  One would expect the controllers to actually reset thus ending the  sustain.  I know the controller reset midi is being sent (8 times when the spacebar is pressed), but it’s just not working with Synchron Pianos. It makes it hard to edit the piano parts.  It’s not for not understanding how midi works.   I too have been using midi since the 80s. 
I always bounce to track once I’m done editing and disconnect the synth in the synth rack so all is good after that.  
Would be really nice to figure out a good solution such as the above mentioned pedal off with spacebar. Or maybe we should  contact VSL to see how it can be resolved. 
 

Edited by Blogospherianman

Share this post


Link to post
Share on other sites

It not just   VSL its Kontakt (some libraries), Omnisphere and others.

Reset controllers on stop could have check boxes and allow us to pick which controllers to be reset.  That would enhance the reset to be more functional.  (Just be sure they [sustain-lol] reset) 

Max Arwood

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...