Jump to content
Kenneth Doerbecker

Recorded Track cut short

Recommended Posts

I don't offhand.

Normally, recording continues until you hit stop.

Do you have loop engaged? Punch? These things can have a controlled recording window.

Share this post


Link to post
Share on other sites

Both loop and punch are turned off.

The recording continues until you hit stop. But, once you return to the start, the end of the clip is truncated. And you can't grab the end and pull it out, its blank behind it.

Weird. I tried creating a new track in a new project but get the same thing.

Share this post


Link to post
Share on other sites

I've never had or heard of this problem before. 

Does the waveform show for the whole length of your recording before you go back to start?  Is there a corresponding *.wav file in the project audio folder which is the original length of your recording?   If so, you might try importing that file directly into another audio track to see (or open it in another waveform editor).

Another thought, but it seems it may not apply if its happening in new projects (unless you are using a template for your new projects):   there is an option under Options in Track View to "Stop at Project End."   See if that is enabled and uncheck/disable it to see if it makes a difference.

Finally, a diagnostic step and possible workaround until you or one of the geniuses here figure this out - create a dummy track and import a MIDI track or audio file that is longer than your expected project, mute (don't archive) it, and then record your track to see if that makes a difference.

Good luck,  Bill

 

Edited by BRainbow

Share this post


Link to post
Share on other sites

When you say the last part, how long are you recording for? Are you missing the last chord, note, or beat of a song, or are you missing a complete bar or phrase? Not that this makes too much difference, but I'm interested to know just how much is missing.

Share this post


Link to post
Share on other sites

Finally got to circle back and spend some time on this. New info;

1 - Stop at Project end is not selected

2 - The underlying wav file is complete right up to the end, its just the view of it in the track that is missing the end.

3 - If you then import the wav file to a new track, it does show completely.

4 - I created a new project from scrap, same behavior.

5 - My old copy of Sonar x1 is working correctly. 

Share this post


Link to post
Share on other sites

Sonar X1 had Layers but I believe used Overwrite mode as the default for recording.

What it sound like to me is you are you using Take lanes and the take might be hidden by previous takes (just a guess).

What REC mode are you in ? Sound on Sound, Overwrite or Comping ?

Share this post


Link to post
Share on other sites
Posted (edited)

I'm experiencing the same issue.  The majority of my settings were the same as Kenneth's, save these:

  • Stop at Project end is  selected
  • Record mode was set to Comp (I have changed that to Overwrite since reading this thread)

I rushed and deleted the tracks, not thinking to check the underlying wav file, I'll be doing that next.

 

EDIT for additional information

  • Still experiencing the issue, after making the change to the Record mode.
  • I was able to import the underlying wav file, and while it wasn't as truncated as the original track, it did have the very end clipped off.
Edited by Jim Goodrich
additional information

Share this post


Link to post
Share on other sites

I came back to this today and I can no longer recover the full recording by importing the underlying wav file. I've opened a ticket and I'm waiting to hear back.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×