Jump to content

Intel SpeedStep and my Dells (turning it on resulted in better performance)

Recommended Posts

It is commonly counseled that for best DAW performance, we should go into our computers' BIOS settings and enable Intel Turbo Boost and disable Intel SpeedStep.

This is because while the stated purpose of TurboBoost is to increase the clock speed of the CPU cores under load in the name of performance, the more vague purpose of SpeedStep is to adjust clock speeds for the sake of performance and power saving.

Since power saving schemes are usually the bane of DAW performance, it would follow that disabling this SpeedStep is the way to go.

Well, short form, not on my Dells, not at ALL. If you have a Dell, at least try enabling SpeedStep (making sure your Power Plan calls for minimum processor state of 100%).

My main system is an Optiplex with an i7 3770, base clock of 3.4 G that Task Manager always reported as running at 3.39 with my power scheme that nailed the clock to 100%. It's a retired business desktop that was probably designed to sit next to a project manager's desk and be really fast at doing PowerPoint presentations in 2013.

Dell is notorious for locking their motherboards down so that there is no possibility of overclocking. They sell business machines. Lots and lots of them, and they work. They have a reputation for working and lasting forever, they don't want to blow that. They're sort of the Volvos of the PC industry.

But I read that even in Dell's original sales literature, they said that my Optiplex could go up to 3.6 GHz in Turbo, so I wondered how. Turns out the magic button is enabling SpeedStep, along with having a Power Plan that nails your maximum and minimum processor states to 100%. My processor now cruises along at a steady 3.67 GHz, and I noticed the difference immediately on first reboot, before I even checked to see if it changed the clock. Maybe it affects other things, since I use the onboard HD4000 graphics. 280Hz doesn't seem like it should be a big difference, but maybe when it's spread across 8 virtual cores? Whatever, I figure why not get every bit of performance I can?

I've been monitoring the clock speeds, and SpeedStep has not caused it to drop at any point, it just sits there idling at 3.7(ish).

My other Dell is a Latitude 6410 (the LatitudeWithAttitude), the model with the i5 and separate nVidia Quadro chip. It also never got up past its rated clock speed, but I enabled SpeedStep and the results were even more dramatic, probably since the system is even more challenged running DAW software. There is little you can do to stop a Latitude from throttling its CPU anyway, even if you set your Power Plan to nail the CPU to 100% it will override that. I had been planning on dropping an i7 in the Latitude, but now that the i5 is clocking higher, I'm going to wait a bit.

As for how this applies to other proprietary or generic motherboards, I don't know. I'm just here to say that reflexively turning off SpeedStep may be robbing your system of performance.

Link to comment
Share on other sites

I will try this on my Dell XPS. I have always just turned it off because "you're supposed to". Also, there is a setting for Intel SpeedShift. Any idea if that should be enabled, as well. I have it disabled.

Edited by Rod L. Short
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...