Jump to content
Paul DeRocco

MIDI sequence playback speed is wrong

Recommended Posts

This problem keeps cropping up, and then going away. I've successfully used Cakewalk (always current version) to create MIDI sequences, play them on an external instrument, and record the audio that comes back in order to create a final audio file. But frequently, the MIDI sequence plays at the wrong speed. At the moment, I have a sequence that reliably plays about 2.8% slow, so the 128-bar 4/4 112bpm song which should take about 4:34.3 ends up taking about 4:42. While capturing the audio, it displays nicely in the audio track directly below the MIDI, and I can see the amplitude bumps lining up with the MIDI above it. When I stop recording, it redraws the audio at its real size, which is substantially longer than the MIDI. But since it only allocated enough space in the track for 128 beats, the end of the song is lost.

I've also had the MIDI suddenly start to play reallllly slow, like 40% to 60% of nominal speed, at a particular point in the sequence. And no, there is no tempo track data on this sequence, this is 112bpm from start to finish. And this has happened in other sequences, too.

So what the heck is Cakewalk using for its timing reference when it spits out MIDI to an external instrument? Since I record 48K digital audio from the instrument, I would think that would make a perfectly good timebase. And why would it do this intermittently? Is there some option I have to set somewhere?

BTW, I'm using the standard Windows USB MIDI driver to communicate with the instrument. I've also tried forcing it to use another driver, from Korg, even though it's not a Korg instrument, and that produces identical results. So it doesn't appear that it's an issue with the specific MIDI driver. Internally, it's using MME to talk to the driver, since that's the only choice.

Added info: I've verified that when only playing (or recording) MIDI, it runs at the correct speed, and when playing MIDI and recording the digital audio that comes back, it runs slow. I found an option under Audio Driver Settings for Playback Timing Master and Record Timing Master, and they are both set to the only choice, which is my digital audio input. I know for certain that my instrument input is exactly 48KHz, because its analog output is in tune, and when the digital output is properly recorded and played back through the analog output on my desktop machine, it is still in tune and takes the exact amount of time it should. It's behaving as though when merely playing the MIDI sequence, it uses some internal timebase despite the Audio Driver Settings, but then when playing MIDI and recording the digital audio that comes back, it is trying to sync to the audio sample rate and simply getting it wrong, which would mean it's a bug in Cakewalk.

Edited by Paul DeRocco
added info

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...