Jump to content
  • 0
LNovik@aol.com

set up for keyboard controlled

Question

I will reword my question in a (hopefully) simpler form. I have an ALesis Vortex Keytar, which is basically a MIDI keyboard controller with no internal sounds. I simply want to hook it up in my system so that I can record MIDI. I need help with the track settings.

I have a MIDI cable going from the MIDI out of the Vortex to the MIDI in of a Korg Triton. The Triton is set to channel 8.

On the MIDI track I'm trying to record on, for the "IN" field, I've tried "vortex" and I've tried Omni ( or sometimes "none.")

On the Output setting, I've tried Vortex and other times have just listed the Triton, channel 8, since that is the instrument which is supplying the sounds.

I am usually able to get the sound of my Triton when I play the Vortex, but I cannot get it to record MIDI. I can record MIDI from any of my other synths, just not the Vortex. I do have the Vortex plugged into a  USB on my Dell computer, though only for power. Perhaps that is interfering?

Does anyone know what the ____ I am doing wrong. I have been able to do this in the past, but I'm just not able to do it now.

I do have a MIDI Sport 4x4 MIDI interface for my Triton and other synths, but, as I said, the Vortex is plugged into the MIDI IN of the Triton.

Thanks.

LNovik

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

This really looks like a communication issue between the Keytar and the Triton.

What MIDI Channel is ALesis Vortex Keytar transmitting on?  For this to work as described above, The Keytar would have to be transmitting on Channel 8 (Unless the Triton is set to Omni - but you stated "The Triton is set to channel 8").  I don't know enough about the Triton to advise what to do to get it to receive MIDI in data.

Personally, I would just plug the Keytar directly into the PC via the MIDI Sport 4x4 - then you can record directly from the Keytar into Cakewalk (of course, into a MIDI track with input Echo on).

Note:  If the PC's USB is only providing power for the Keytar, not data, then it should not interfere.

Share this post


Link to post
Share on other sites
  • 0

Thanks very much for the quick reply. And who better to answer my question than Promidi.  I was just able to find a good link explaining how to check and change the midi channel for my Vortex keyboard. I'll do that when I get home tonite. I'm just not sure how  I would do what you say. If I plug the Keytar directly into my PC, I don't know if I'll hear anything, since the Keytar has no internal sounds.

Would you be able to just tell me what the Input and output settings would be if I just continued to plug the MIDI out of my Vortex into the MIDI in of my Triton.

THat is, assuming I made sure the Vortex was set to MIDI channel 1 (and the Triton stays on 8) 

If not, I'll try to plug directly into the  computer, though I actually am plugged in already. My USB goes from the Vortex right into the USB of the computer. THe MIDI Sport 4/x 4 has an output that goes into the USB of the computer as well. But, I can't connect my Vortex directly into the 4x4. It only has the 8, 1/4 " ports, and the 1 USB port that goes from the interface to the computer. I don't have a 1/4 plug on my Vortex--it doesn't have its own sound.

Thanks again for your time. Hope that's clear. I do realize there may be things I'm not understanding correctly, so thanks for your patience.

LNovik

Share this post


Link to post
Share on other sites
  • 0
5 hours ago, LNovik@aol.com said:

. I'm just not sure how  I would do what you say. If I plug the Keytar directly into my PC, I don't know if I'll hear anything, since the Keytar has no internal sounds.

Would you be able to just tell me what the Input and output settings would be if I just continued to plug the MIDI out of my Vortex into the MIDI in of my Triton.

Are you connecting the Keytar via it's wireless USB box? Which version of Windows are you using) Does the USB box come with drivers for your version of Windows?

You could set up a single MIDI track - with its input being the Keytar and it's output being the Triton (I am assuming the Triton is set to the appropriate MIDI Channel)

Alternatively , you could set up what is called a track as a "simple instrument".  A component of this is a MIDI track.  This is what you would set as the 4x4 in.  Setting this to Omni would mean that it would not matter what channel the Vortex was on - and "omni" means that it responds to all channels.  This would be the quickest way to make sure that the Keytar is generating MIDI.   Of course, make sure "Input Echo" is on.

5 hours ago, LNovik@aol.com said:

THat is, assuming I made sure the Vortex was set to MIDI channel 1 (and the Triton stays on 😎

Remember, if you want to plug the Keytar dirrectly into the Triton and the Triton is on Channel 8, then you would want the Keytar set to Channel 8. 

Personally, I would find a way to plug the Keytar's MIDI cable directly into Cakewalk (Via the 4*4 MIDI Sport) to allow Cakewalk to do the recording.  The MIDI track I mentioned above has another setting whick determines that MIDI channel that that track transmits on.  It's just under the "FX" and by default , this is set to "none".  I would set this to Channel 8 to match the Triton.

5 hours ago, LNovik@aol.com said:

If not, I'll try to plug directly into the  computer, though I actually am plugged in already. My USB goes from the Vortex right into the USB of the computer.

 

Does the Keytar come with any USB drivers for your version of WIndows?

5 hours ago, LNovik@aol.com said:

But, I can't connect my Vortex directly into the 4x4. It only has the 8, 1/4 " ports, and the 1 USB port that goes from the interface to the computer. I don't have a 1/4 plug on my Vortex--it doesn't have its own sound.

Are you saying you do not have a standard MIDI cable with 5 pin din connectors at each end?

Share this post


Link to post
Share on other sites
  • 0

I should say that I finally got it to work. However, since you were kind enough to explore my problem, I'll answer each point.

1)I don't have the wireless  Vortex (just the wired one.). There is a USB port which I connect to my computer USB.

2)I'm using  Windows 10

3)I have been setting up a single track in CbB, but  HAD not been having any luck. My Triton has been on the MIDI channel 8 for years. However, I had not been able to figure out how to change the MIDI channel of my VOrtex. It hadn't seemed to matter, since I  had been able to hear my Triton sounds while playing the Vortex. But, I was having trouble recording these MIDI notes (when played from the Vortex.)

4)Though I have looked  for hours, I have not found any satisfactory  explanation of what the "input"  and "output" mean on the  tracks parameters. I had always assumed that the input parameter should not be on Vortex, since I didn't want any info going to the Vortex---since it has not sound. But thru reading these comments, I guess the input parameter should be set for the Vortex, since I am inputting data from that instrument.  I finally managed to change the  MIDI channel for the Vortex to ch 8, to match my Triton. I did put the output on channel 8, though I don't even think that mattered. That is because the MIDI out cable from the Vortex is going into the   MIDI in for the Triton. SO, when I then  play the data I just was able to record, I hear nothing--because there is no MIDI info getting into the Triton's MIDI in port. But that's OK---I just change the parameters after I successfully recorded, so I can hear it.

5) I did search and only found one hit saying no drivers for the Vortex are necess. I'm not sure how valid it was, but it seemed accurate. There were none on the Alesis site either.

6)Yes,  I  am using regular MIDI cables. I was just saying that my MIDI Sport 4x4 ......Ah yes, a flash: of course, it  has lots of MIDI ports, both in and out. However, they are taken since I have several MIDI instruments. I now realize  I could have just taken one out and gone right into one of the MIDI ins from the MIDI out of my Vortex.

In summary, I think the key was 1)realizing that the input parameter should be the Vortex, and 2)changing the MIDI channel on the  vortex to 8. I guess since  I'm attached thru MIDI to my  Triton, by choosing the same MIDI channel, it now seems to be going thru the Triton into Cakewalk.

Thanks again for your assistance.

LNovik

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...