Jump to content
MorganT

timing error

Recommended Posts

HELP! I have one song with the following problem, all my other files play normally (so this issue is isolated to the particular song in question and not to my overall Cakewalk settings.)

When playing back (or freezing) an audio track, the playback holds some notes too long and jumps through other ones - almost like a clock is not running consistently.  It does NOT happen to tracks already frozen, but if I un-freeze them then it does occur, and the problem persists when I freeze a normal track.  I have turned off all Fx; the resources seem to be fine (all meters in Performance are very low); there is no popping/etc like when resources are strained.  When playing back all tracks at once, the frozen tracks play properly but the non-frozen tracks simultaneously play with the varied-tempo problem.   When solo-ing any of the affected audio tracks, the glitchy timing seems to be consistent in when/how it occurs - each time I re-play the track, the timing jumps seem to occur identically (not occurring randomly different each time it's played.)

I have NO idea how to correct this.  Any thoughts would be appreciated! 

Share this post


Link to post
Share on other sites

Added detail:  I've sorted out that the offending clips were edited with Audiosnap; if I disable Audiosnap in the clip inspector (reverting to the original pre-edited clip, if I understand correctly), then the problem goes away for that clip... but recurs when I re-enable to the Audiosnap edited clip

Share this post


Link to post
Share on other sites

Tried that, it does not resolve it, actually seems to exaggerate the error a bit.  I thought it might be the beat map in AudioSnap, but those all look correct.

I'm 99% certain I'd bounced each clip previously after editing, but multiple are showing up as AudioSnap clips.  I had a DAW crash while working on this file, I'm wondering if somehow that caused this issue, although I'm not sure how.

Share this post


Link to post
Share on other sites

So I decided to Revert to a previous version of the file before this issue arose - and even when I revert, the same issue is occurring.  I KNOW it was not happening at the time of the older file version, because I also have WAV files that were exported from that version (time stamp right after that file version's time stamp) that do NOT have the error in them.  So loading the data that is stored as the old file version is re-introducing the error.

(1) Does Reverting to a prior version of the file NOT actually revert everything?  Shouldn't I be getting a clean start from that point in time when it WAS working properly?

(2) Is it possible some plug-in is no longer playing nicely with the Cakewalk project/data?  (This is an older file that I'm finally ready to put on a project release, and it was last edited before upgrading to Windows 10, if that's possibly related.) 

Share this post


Link to post
Share on other sites

Had to do a little digging, but my audio interface was fairly new then but has not changed since.  I have not intentionally changed project bit depth or sampling rate; I have Focusrite Scarlett 18i8, it shows the same sampling rate and bit depth as my project.

Share this post


Link to post
Share on other sites

What changes did you make using Audiosnap?If you're using it to have the overall clip tempo follow changes in the project tempo, make sure the Follow  Project mode is 'Autostrech'. (drop-down to the right of the option in the Audiosnap palette) If it's anything else, transient markers will get snapped to the grid with a probable bad result unless they've been carefully 'massaged' into the correct positions for that purpose.

Share this post


Link to post
Share on other sites

Is this happening on all projects or only this one?

If it's only this project, you could try creating a new project and dragging the old project on to the track view from the media browser.

I find this is a great way of "cleaning up" projects that are misbehaving.

Share this post


Link to post
Share on other sites

This was minor tuning of timing - a couple rhythm guitar parts where the strum pattern is key and stands out, and I was tightening the timing at these key points between the selected tracks.  But when it hits a transient, it sometimes immediately jumps to the next one, other times will hold that one out for most of the rest of the clip and then resume normal operation momentarily when the next clip starts.

It is only happening in this one project (although I have rarely used Audiosnap so it wouldn't affect most of my projects.)  

I think at this point I will try either moving the offending clips into a new project as suggested, or go back to scratch on the original clips and try re-adjusting them.  I've decided at this point it's just haunted clips...

Share this post


Link to post
Share on other sites

I noticed a similar error sometimes when I use the time/stretch tool. There is a bug there somewhere. Sometimes also cakewalk will crash when you try to bounce to clips after using the time/stretch tool. Recently I had to bounce a track part by part util I found the tiny part that was corrupted. Then I just re-stretched it and bang! it was fine again. I do not know if that is the problem with your project though. And I should probably report this bug to Bandlab

Share this post


Link to post
Share on other sites

It just occured to me that a recent change to AS is that the default stretching algorithm is now Elastique instead Groove  Clip. In my experimentation with this algorithm when it was first released, I found that it could produce weird timing in some cases. Try switching to Groove Clip or one of the Izotope algorithms.

  • Like 1
  • Great Idea 1

Share this post


Link to post
Share on other sites

Dude, you're a genius!  I changed the stretching algorithm to Groove on-line, Radius off-line (not sure which it's using when) for several clips, and they all worked smoothly.  Must've been the change in the default to Elastique.

Thanks!!!!

Share this post


Link to post
Share on other sites

Is there a way to change the stretch algorithm to all clips simultaneously?  So far I've had to go clip by clip and change it for each one.

Share this post


Link to post
Share on other sites

Have not double-checked, but usually if you have multiple clips selected, any change to properties will affect all of them. If they start out with different values, the property show '(multi)'.

Share this post


Link to post
Share on other sites
On 2/22/2019 at 11:58 AM, MorganT said:

Dude, you're a genius!  I changed the stretching algorithm to Groove on-line, Radius off-line (not sure which it's using when) for several clips, and they all worked smoothly.  Must've been the change in the default to Elastique.

Thanks!!!!

Cool. Glad to help. 'Online' means real-time processing during playback. 'Offline' is what's used when you Bounce to Clip(s) to destructively apply the stretching , creating a new audio file. In general, the offline algorithms are more sophisticated, and will sound better. But in some cases, Groove Clip yields the most transparent results.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...