Jump to content
  • 0
Canino78

BSoD when going lower than 512 Buffer Size

Question

My System:
Windows 7 Home 64-bit, 2.4GHz i7, 6GB DDR4 RAM.
Cakewalk  v2020.04

My Interface:
Line 6 TonePort UX8 (Newest ASIO drivers from Line 6 website, 2019 I believe)

 

Hello,
So, I've experienced the Blue Screen of Death twice now - every time I try to go lower than 512 samples, which was giving me a 11.6s latency. 512 is the default buffer size for my interface in the ASIO Driver Control Panel. The interface is a Line 6 UX8 which connects via USB 2. Normally this latency wouldn't be too bad but the music I plan to record is quite fast fusiony type stuff so even the slightest slap-back is quite disturbing for the performers.

Screenshots of the Preferences Menu below:
1209890372_DriverSettings.thumb.jpg.f4dec6e8fab5b4dcc35fc5b4565248d9.jpg
Sync.thumb.jpg.9ba7ec54e31ea7d00b9e4cd186dc1b00.jpg

It first happened when I tried to change the buffer size (Preferences > Device Settings > Mixing Latency) with the slider all the way to the left, I think this was 128 samples. But stupidly, I had channels armed and monitoring at the time, so when the BSoD happened I figured that was my mistake and probably what caused it.

After the first attempt, this time I unarmed every track and did a global FX bypass in the mix module too in-case any plugins were causing the problem. I attempted to change the Buffer Size down to 256 samples (not all the way to the left "fast" but second notch to the left) and after a few seconds loading - BAM, I got the Blue Screen again.

The Blue Screen was as follows:
886560829_bluescreen.jpg.39779696f7370dfe0d6823774dafb79b.jpg

Aside from this I have to say the program runs beautifully, even with this interface albiet at 512 samples. I haven't tried increasing the buffer size to see what affect that has, but before I put my system through another blue screen I figured I'd ask on here first. I also haven't tried a different interface yet and I understand that it could very well be the interface that's causing the problem. Would really appreciate some input!

Does anyone know of a fix for this? Thanks Everyone!

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0
17 minutes ago, msmcleod said:

Have you tried disabling the High Definition Audio Controller driver on your video card?
 

Hey thanks for the quick reply!

Is this a standard driver that can be disabled in device manager or does it require deeper intervention? I'm really sorry but all that technical language goes right over my head.
I have two graphics cards in my laptop:
An Nvidia GeForce GT 650M and an Intel HD 4000 which is integrated with the processor. Both of these have audio drivers too (see below). I think Cakewalk runs using the Nvidia driver, not the intel.

Here's a screenshot of my device manager with the audio and video drivers:

826653357_Devicemanager.jpg.41995bdb80fd806d1493de714ed01260.jpg

Should I try simply disabling all the audio drivers I'm not using? Or is it something more complicated that that?

Thanks again!

Share this post


Link to post
Share on other sites
  • 0

If you're using the Line 6 in Cakewalk, it shouldn't be using any of the other audio devices.

I'd recommend disabling the Intel Display Audio & the NVIDIA ones first.

If you still get problems, then disable the Realtek.

 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
10 minutes ago, msmcleod said:

I'd recommend disabling the Intel Display Audio & the NVIDIA ones first.

It worked, a Revelation!

Got it down to 256 I have only 5ms latency which is absolutely fine.
No Blue screen this time. And recording works! I cannot thank you enough, such a weight off my shoulders!

Just to clarify to anyone else having this issue, I did the following steps:
1. Device Manager > Disable all video card audio drivers (see screenshot of device manager above)
2. Cakewalk > Preferences > (Audio) Driver Settings > ASIO Panel (your interfaces driver control panel) > set buffer size to 256.

Note: For some reason I couldn't change the buffer size in Cakewalk itself as it just kept reverting back to 512, so I changed it in the Line 6 ASIO control panel itself and Cakewalk followed accordingly. Hopefully this solves everything. Will keep this forum updated if I run into anything else related.

Cheers for all the help!

Share this post


Link to post
Share on other sites
  • 0
10 minutes ago, Canino78 said:

Note: For some reason I couldn't change the buffer size in Cakewalk itself as it just kept reverting back to 512, so I changed it in the Line 6 ASIO control panel itself and Cakewalk followed accordingly.

Not all manufacturers allow the DAW to change ASIO buffer size. In those cases, the buffer size must be set using the manufacturer supplied utility.

  • Thanks 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...