Jump to content
Morten Saether

[CLOSED] Cakewalk 2020.05 Early Access 2

Recommended Posts

[CLOSED] 2020.05 Early Access 2 (EA2) installer now available!

Please note: EA2 is a release candidate that will be released early next week, pending any last minute critical issues reported by testers.

Our sincerest thanks to those of you who have provided feedback on Early Access 1 - your support this week has been fantastic! We've addressed all issues reported by Early Access 1 testers and found opportunities for additional refinements as well. We invite you to try out the latest updates in EA2.

Please note that Early Access installers are update installers, which only update from a specific version. To install the 2020.05 EA2 build, you must be on the latest public release of 2020.04 or 2020.05 Early Access 1.

Cakewalk 2020.05 EA2 installer

Should you need to revert from the 2020.05 EA2 build to the public 2020.04 release, you can download the Cakewalk 2020.05 EA2 to 2020.04 Rollback installer.

If you haven't already done so, please read about the Early Access Program before participating.

Thanks again for your participation!
The Bakers

 


 

New in Early Access 2 

Misc:

  • Major UI improvements to prevent screen flickering when loading projects or switching between open documents
  • Exporting with Thread Scheduling model 3 can fail when plug-in load balancing is enabled
  • Playback glitches with Thread Scheduling model 3 and plug-in load balancing enabled
  • With console open in larger projects UI scrolling can be sluggish
  • Under high system load, UI is unresponsive and playback cannot be stopped
  • Using Clip Gain on some Groove Clips causes unexpected drawing when clipping
  • Null Pointer crash after reordering automation lanes in attached project
  • Committing an arrangement containing clips set to absolute time moves data past the end of the original project
  • Deleting "n" folders only deletes one folder
  • Make Rename Clip available in key bindings
  • Synth and bus automation is not selected after duplicating clips
  • Early Access toast notifications added
  • Dragging ARA clips out of the Clips pane can impact VocAlign clips to lose timing
  • Allow .midi as a supported MIDI File extension for reading
  • Host reports incorrect path for VST2 plug-ins via audioMasterGetDirectory

View list of updates in Early Access 1

 

  • Like 6
  • Thanks 6

Share this post


Link to post
Share on other sites

Nice work Morten!

Kudos to you, the team and all the users who pitched in!

 

Downloading in a moment...

Share this post


Link to post
Share on other sites

Using 2020.05 build 030 (EA2) as expected it’s now possible to see *.midi files in the Media browser, but when I try to drag such a file into the Track Pane, I get a “Cannot find or open file” error message. And that’s despite the file just being a copy of a successfully opened *.mid file where I have just changed the extension.

The same happens when I select File > Import > MIDI... As expected the extension filter has been modified here as well, but the same error message appears when trying to import a *.midi file. I've tried it with two different *.midi files with the same result. It's hard for me to believe this wouldn't have been tested so might this be a problem only on my PC?

PclpRZk.png

  • Like 1

Share this post


Link to post
Share on other sites
15 minutes ago, Canopus said:

Using 2020.05 build 030 (EA2) as expected it’s now possible to see *.midi files in the Media browser, but when I try to drag such a file into the Track Pane, I get a “Cannot find or open file” error message. And that’s despite the file just being a copy of a successfully opened *.mid file where I have just changed the extension.

The same happens when I select File > Import > MIDI... As expected the extension filter has been modified here as well, but the same error message appears when trying to import a *.midi file. I've tried it with two different *.midi files with the same result. It's hard for me to believe this wouldn't have been tested so might this be a problem only on my PC?

PclpRZk.png

I can confirm that this happens to myself as well. I can load it from Explorer however easily enough.

  • Like 1

Share this post


Link to post
Share on other sites

It appears the only operation that works with .midi files is File > Open.

All of the import methods fail with the "Cannot fine or open file" error.

 

Share this post


Link to post
Share on other sites
Posted (edited)

O'man! Only see now where I'd drop this thread. 

Please read the thread in the link. I have posted this in the wrong Category of discussion. Here's the link though.

Be responsible. Don't drink and discuss issues kids.✌

W.

 

 

Edited by Will_Kaydo

Share this post


Link to post
Share on other sites
1 hour ago, Will_Kaydo said:

Please read the thread in the link. I have posted this in the wrong Category of discussion. Here's the link though.

You should send a minidump to staff.

Although Morten wrote above that the final 2020.05 would drop early next week, so any potential fix for your problems will probably not make it for this release...

  • Like 1

Share this post


Link to post
Share on other sites

Not certain this is only this update and it's intermittent, but not older than 2020.4

 

I've been unable to pinpoint or replicate on demand. I've been (suddenly) having some trouble with moving clips with/without select envelopes. Sometimes, when I try to move a clip grabbing the top of the clip with shift (constrain), it is changing to clip gain envelope. If I click lower, it works as expected. Has this been reversed?

 

Related. I just had a situation where selecting and deleting clips (select envelopes with clips is Not selected), it repeatedly deleted volume envelopes. Selecting them one at a time did not do ths.

 

Is it me?

Share this post


Link to post
Share on other sites
Posted (edited)

moot details deleted; footprint reduced since fix will be fixed in final release

 

 

Edited by User 905133
to remove moot details

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/29/2020 at 5:35 PM, GreenLight said:

You should send a minidump to staff.

Although Morten wrote above that the final 2020.05 would drop early next week, so any potential fix for your problems will probably not make it for this release...

Yeah. Dont know where my dumb butt were at when I created that thread. It seems as if my mind was MIA. 😞

 

Edited by Will_Kaydo
  • Haha 1

Share this post


Link to post
Share on other sites
15 hours ago, Canopus said:

Using 2020.05 build 030 (EA2) as expected it’s now possible to see *.midi files in the Media browser, but when I try to drag such a file into the Track Pane, I get a “Cannot find or open file” error message. And that’s despite the file just being a copy of a successfully opened *.mid file where I have just changed the extension.

The same happens when I select File > Import > MIDI... As expected the extension filter has been modified here as well, but the same error message appears when trying to import a *.midi file. I've tried it with two different *.midi files with the same result. It's hard for me to believe this wouldn't have been tested so might this be a problem only on my PC?

PclpRZk.png

Just hit that as well.  Freaked me out but I think the message is in error.

Share this post


Link to post
Share on other sites

I am love, love, loving the visual clip gain stuff. That, and the new Melodyne 5 update with leveling features has made leveling vocals so easy. What used to take me 20 minutes is now a five minute (tops) job. Thank you!!

  • Like 4

Share this post


Link to post
Share on other sites
Posted (edited)

I can not believe how well my system is running with EA2! Noel did some magic programming on this version.  I have not run without glitched and crashes since I upgraded to windows 10.  I was also having an issue with Lexicon PCM reverbs,  All that is gone now.  All the rough playback - smooth now.  I will have to say that these projects were loaded! Ball park of 55+ tracks with 64 plugins on the busses , 100 on tracks -all active and another 45 frozen VSTs.  5 soft synths -  B4 II, CFX Grand, Superior 3, Kontakt 5 and Omnishpere (Some frozen)  Unbelievable!

Noel - I don't know how you sorted through all that code so fast and fixed all this - GREAT JOB!!

Many Thanks To a Great Team!!!!!

Max Arwood

Edited by Max Arwood
can't spell can't type
  • Like 2

Share this post


Link to post
Share on other sites
1 hour ago, Max Arwood said:

I was also having an issue with Lexicon PCM reverbs,  All that is gone now.  All the rough playback - smooth now.  I will have to say that these projects were loaded! Ball park of 55+ tracks with 64 plugins on the busses , 100 on tracks -all active and another 45 frozen VSTs.  5 soft synths -  B4 II, CFX Grand, Superior 3, Kontakt 5 and Omnishpere (Some frozen)  Unbelievable!

Do you use sidechaining in your project? I started getting crashes if I try to load T-Racks 5 suite into project, it started right after I created few sidechain sends with sonitus comp. Cakewalk 2020.04. I would hope for a progress but will wait until finish the project.

Share this post


Link to post
Share on other sites
On 5/29/2020 at 11:00 AM, Canopus said:

Using 2020.05 build 030 (EA2) as expected it’s now possible to see *.midi files in the Media browser, but when I try to drag such a file into the Track Pane, I get a “Cannot find or open file” error message. And that’s despite the file just being a copy of a successfully opened *.mid file where I have just changed the extension.

The same happens when I select File > Import > MIDI... As expected the extension filter has been modified here as well, but the same error message appears when trying to import a *.midi file. I've tried it with two different *.midi files with the same result. It's hard for me to believe this wouldn't have been tested so might this be a problem only on my PC?

PclpRZk.png

This has been fixed and will be in the full release.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
2 hours ago, msmcleod said:

This has been fixed and will be in the full release.

Will *.midi and *.smf be treated the same way under all circumstances? Just curious.

Share this post


Link to post
Share on other sites
4 minutes ago, User 905133 said:

Will *.midi and *.smf be treated the same way under all circumstances? Just curious.

*.smf isn't supported at all.

*.midi is treated the same as *.mff

Share this post


Link to post
Share on other sites
14 minutes ago, msmcleod said:

*.smf isn't supported at all.

*.midi is treated the same as *.mff

Good to know; thanks for the clarification.

Share this post


Link to post
Share on other sites
4 hours ago, Max Arwood said:

I can not believe how well my system is running with EA2! Noel did some magic programming on this version.  I have not run without glitched and crashes since I upgraded to windows 10.  I was also having an issue with Lexicon PCM reverbs,  All that is gone now.  All the rough playback - smooth now.  I will have to say that these projects were loaded! Ball park of 55+ tracks with 64 plugins on the busses , 100 on tracks -all active and another 45 frozen VSTs.  5 soft synths -  B4 II, CFX Grand, Superior 3, Kontakt 5 and Omnishpere (Some frozen)  Unbelievable!

Noel - I don't know how you sorted through all that code so fast and fixed all this - GREAT JOB!!

Many Thanks To a Great Team!!!!!

Max Arwood

Agreed Max! I don't use midi very often and was having latency issues a few months ago, tried it this afternoon and worked like a champ! These guys are awesome!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...