Jump to content
Josh Wolfer

Bug-ish: Control Surface assignment is unpredictable and annoying

Recommended Posts

This has been happening for a loooooong time. At least since x1, but probably even longer. 

Cakewalk acts like a drunk when managing midi input assignments. Meaning, I will regularly start working on a project and my s88 keyboard no longer works as midi input, even though the midi / instrument track has "midi omni" or the s88 selected as input still AND in preferences the midi inputs are still enabled. 

After scratching my head, I'll go into the control surfaces config and Cakewalk reassigned my s88 into the midi input for my Tranzport control surface. When I still used the vstudio 700, it would happen on the vstudio control surface config as well. And vice versa. There would be times that the vstudio would start triggering midi note input on my VSTi tracks, and I'd go and check the control surface config and there it is, assignments are scrambled. 

And I have no idea what causes this. I have about 5 or so midi controllers that I use and I don't keep them all on all the time. but they all get scrambled. it's gotten to the point that I've removed the tranzport from the control surfaces config (when I'm not using it). And the issue NEVER happens. So there is something about control surface configs that make Cakewalk act drunk. 

I think I've suggested it before, but I'll suggest it again, if there is a way to flag a midi device as "ONLY a control surface" or "ONLY a standard midi input controller", this would probably alleviate the issue. I pretty much never want an MCU control surface triggering Kontakt notes (although sometimes the results can be pretty funny). And I NEVER want my hand playable controllers to attempt to control transport functions, unless I've specified "Learned" it to do so. 

Make Cakewalk less drunk when handling control surfaces please :D.

Share this post


Link to post
Share on other sites

Just in case someone goes there, USB power saving is off on all hubs and in general I have ZERO issues with my midi devices. They stay connected and everything is great. But probably 5-6 times a month, Cakewalk just goes nuts and scrambles the control surface in/outs

Share this post


Link to post
Share on other sites

Also, I've gotten in the habit of NEVER connecting or disconnecting a midi device while cakewalk is running, just to try and alleviate this issue. And if I ever do add or remove a midi device, the answer is always "NO" when cakewalk prompts if it wants me to let it reassign the midi in/outs due to the change.

Share this post


Link to post
Share on other sites

This is a known bug, the devs are aware of it, and it is in their queue to be addressed. I, too suffer from this one, and all I have is a Korg nanoKONTROL beside the MIDI port on my audio interface. If you download the Reference Guide and study the section pertaining to control surfaces, you'll see that Cakewalk is supposed to keep track of this stuff.

I'm sure they'll get it sorted soon enough.

  • Like 2

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...