Jump to content
  • 0
Alun Crewe

Newbie question on importing MIDI files into Cakewalk

Question

Hi Guys, 

Apologies for what is obviously a very basic question but I'm having trouble with importing a MIDI file and actually hearing it on a virtual instrument. Just for reference I'm using an iRig Duo for my audio in/out

I load a MIDI file and I can see that it's loaded correctly as I can see the note events in the MIDI track I've loaded but when I play it there's no sound, presumably because it's trying to use the MIDI port on the iRig Duo. 

I can see my VSTs including the ones that came with the iRig Pro and the TTS1 but I can't figure out how to connect each track with a VST and assign channels to each of the multiple MIDI channels. I managed to connect to the TTS1 at some point but then it played all the tracks on the drum channel and now I seem to be going around in circles.

I've read all of the documents and YouTube videos on MIDI but they all seem to discuss recording MIDI and playing it back. I can't find anything on importing a MIDI file and getting the correct track assignments.

I'm sure this has been covered before soemwhere somehow so if you could point me in the direction of the right article or video I'd be grateful.

Thanks for your help!

Alun

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Make sure that you put the MIDI file into a track with a VST on it, and that the VST is routed to an appropriate bus or master output.  It won't make a noise if on a channel with no VST.  I hope I read your question correctly.

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
2 hours ago, Alun Crewe said:

. . . but I can't figure out how to connect each track with a VST and assign channels to each of the multiple MIDI channels.

There are often multiple methods for doing things. My personal work flow for some projects is to use split instrument tracks--where the combined instrument track is split (separated) into an audio track and a midi track.  Sometimes I will leave the instrument track with both audio and midi together and will create a separate midi track and point it to the soft synth.

Below you can see that the output of several midi tracks are all pointed to the same instance of TTS-1 [O = 3-TTS-1 1]. However, the midi data for tracks 10 and 11 are forced to different midi channels [C=14CkwlkT...] and [C=15CkwlkT...].

These are just some personal options, but I hope it shows one of the missing pieces to understanding midi routing.  

If you don't have the I, O, C, B, and P track control widgets visible, switch the track control preset to "All." 

Hope this helps.

[UPDATE:  The presets for the track control widgets can be selected from the little arrow next to where it says "All" in the following image.  You can also create your own widget configurations by choosing "Track Control Manager..." from the drop down menu.  Apologies for not putting a box around it; I grabbed a picture from a few months ago.]

image.png

Edited by User 905133
To point out the location of the track control widget presets ["All"]

Share this post


Link to post
Share on other sites
  • 0
28 minutes ago, User 905133 said:

'If you don't have the I, O, C, B, and P track control widgets visible, switch the track control preset to "All." '

Thanks for your answer, just one question (as I don't see the I,O,C and P trakc control widgets) where do I switch the track control preset?

Thanks, Alun

Share this post


Link to post
Share on other sites
  • 0

With no MIDI output device selected in preferences, CbB automatically adds TTS-1 and sets it up to play the MIDI file

Share this post


Link to post
Share on other sites
  • 0

If you open the midi file by double-clicking in  File Explorer, then Cakewalk will create a track per midi channel, add a TTS-1 and do all the midi channel routing and patch changes for you.

If you want to use other VSTs instead of TTS-1 you must load them into the synth rack. Select the correct midi track for that instrument and open the Inspector view.

You will see this:

Inspector.thumb.jpg.22842e0387c6f863e1331f2087838ecf.jpg

Right at the bottom, just above 2, and MIDI, click on Output and select the instrument you have just added. 

 

Share this post


Link to post
Share on other sites
  • 0
36 minutes ago, Lynn said:

Make sure that you put the MIDI file into a track with a VST on it, and that the VST is routed to an appropriate bus or master output.  It won't make a noise if on a channel with no VST.  I hope I read your question correctly.

Hi Lynn,

Thanks for your answer. That actually worked even though I created only one instrument track and the MIDI file contained 10 tracks it seemed to assign all of the tracks to the TTS-1 and assign instruments from the TTS-1 appropriately but then it seems that track 1 is some kind of master since if I solo track 10 it turns on the solo control for track 1. How do I get them to act independently? Can I assign one of the track now to a different VST?

Thanks for your help!

Alun

Share this post


Link to post
Share on other sites
  • 0
8 minutes ago, scook said:

With no MIDI output device selected in preferences, CbB automatically adds TTS-1 and sets it up to play the MIDI file

Yes I think the problem is that my iRig Duo has MIDI I/O so it automatically selected that and I can't find hoe to override it.

Thanks, Alun

Share this post


Link to post
Share on other sites
  • 0
19 minutes ago, Nigel Mackay said:

Hi Nigel,

OK, that helps. Thank you. I can now set up a different VST but as I've discovered, the way I've loaded the MIDI file seems to have made track 1 of the ten tracks in the file as some kind of master and I'm not getting any sound out of my VST (Sample tank) which probably means I still have a mismatch in the MIDI messaging. I'll spend a bit more time debugging that.

Thanks, Alun

 

 

Share this post


Link to post
Share on other sites
  • 0
18 minutes ago, Alun Crewe said:

Yes I think the problem is that my iRig Duo has MIDI I/O so it automatically selected that and I can't find hoe to override it.

Thanks, Alun

Deselect the outputs in preferences, the link I provided above shows the screen

Even if just temporarily, then open the MIDI file and it will show you how TTS-1 gets setup.

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, scook said:

Deselect the outputs in preference, the link I provided above shows the screen

OK, sorry I missed the link. That should fix that problem.

Thanks, Alun

Share this post


Link to post
Share on other sites
  • 0
15 hours ago, User 905133 said:

There are often multiple methods for doing things. My personal work flow for some projects is to use split instrument tracks--where the combined instrument track is split (separated) into an audio track and a midi track.  Sometimes I will leave the instrument track with both audio and midi together and will create a separate midi track and point it to the soft synth.

Below you can see that the output of several midi tracks are all pointed to the same instance of TTS-1 [O = 3-TTS-1 1]. However, the midi data for tracks 10 and 11 are forced to different midi channels [C=14CkwlkT...] and [C=15CkwlkT...].

These are just some personal options, but I hope it shows one of the missing pieces to understanding midi routing.  

If you don't have the I, O, C, B, and P track control widgets visible, switch the track control preset to "All." 

Hope this helps.

[UPDATE:  The presets for the track control widgets can be selected from the little arrow next to where it says "All" in the following image.  You can also create your own widget configurations by choosing "Track Control Manager..." from the drop down menu.  Apologies for not putting a box around it; I grabbed a picture from a few months ago.]

image.png

Thank, that's the bit I was missing, plus expanding this part of the screen from the default width. Still learning the nuances of this fantastic program. Thanks for your help!

Alun

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...