Jump to content
Morten Saether

[CLOSED] Cakewalk 2020.05 Early Access 1

Recommended Posts

@Billy Buck That stack was captured from the 04 release not 05.

However the crash is in the plugin itself. There is nothing in the stack that shows the cause to be from Cakewalk.
Please forward the dump file to the plugin vendor since only they can fix it.

-------------------------------

Unhandled exception at 0x00007FFA1DE909A0 (BBC Symphony Orchestra (64 Bit).vst3) in Untitled_05262020_100755.dmp: 0xC0000005: Access violation reading location 0x0000000000000000.

APPLICATION_FAULT_NULL_POINTER_READ_INVALID_POINTER_READ_

STACK_TEXT:  
00000000`0014ca10 00000000`3f1ca828 : 00000000`3f1ca4e0 00000000`3f1ca9d8 00000000`3f94ba60 00000000`0000e104 : BBC_Symphony_Orchestra__64_Bit_+0x7109a0
00000000`0014ca18 00000000`3f1ca4e0 : 00000000`3f1ca9d8 00000000`3f94ba60 00000000`0000e104 00007ffa`1de90641 : 0x3f1ca828
00000000`0014ca20 00000000`3f1ca9d8 : 00000000`3f94ba60 00000000`0000e104 00007ffa`1de90641 00000000`3f1ca828 : 0x3f1ca4e0
00000000`0014ca28 00000000`3f94ba60 : 00000000`0000e104 00007ffa`1de90641 00000000`3f1ca828 00000000`3f1ca4e0 : 0x3f1ca9d8
00000000`0014ca30 00000000`0000e104 : 00007ffa`1de90641 00000000`3f1ca828 00000000`3f1ca4e0 00000000`3f1ca9d8 : 0x3f94ba60
00000000`0014ca38 00007ffa`1de90641 : 00000000`3f1ca828 00000000`3f1ca4e0 00000000`3f1ca9d8 00000000`3f1ca4e0 : 0xe104
00000000`0014ca40 00000000`3f1ca828 : 00000000`3f1ca4e0 00000000`3f1ca9d8 00000000`3f1ca4e0 00000000`0014cb20 : BBC_Symphony_Orchestra__64_Bit_+0x710641
00000000`0014ca48 00000000`3f1ca4e0 : 00000000`3f1ca9d8 00000000`3f1ca4e0 00000000`0014cb20 00007ffa`1e1fbd3d : 0x3f1ca828
00000000`0014ca50 00000000`3f1ca9d8 : 00000000`3f1ca4e0 00000000`0014cb20 00007ffa`1e1fbd3d 00000000`00006000 : 0x3f1ca4e0
00000000`0014ca58 00000000`3f1ca4e0 : 00000000`0014cb20 00007ffa`1e1fbd3d 00000000`00006000 00000000`3f1ca9d8 : 0x3f1ca9d8
00000000`0014ca60 00000000`0014cb20 : 00007ffa`1e1fbd3d 00000000`00006000 00000000`3f1ca9d8 00000000`3f1caa18 : 0x3f1ca4e0
00000000`0014ca68 00007ffa`1e1fbd3d : 00000000`00006000 00000000`3f1ca9d8 00000000`3f1caa18 00000000`00006000 : 0x14cb20
00000000`0014ca70 00000000`00006000 : 00000000`3f1ca9d8 00000000`3f1caa18 00000000`00006000 ffffffff`fffffffe : BBC_Symphony_Orchestra__64_Bit_+0xa7bd3d
00000000`0014ca78 00000000`3f1ca9d8 : 00000000`3f1caa18 00000000`00006000 ffffffff`fffffffe 00000000`ffffffff : 0x6000
00000000`0014ca80 00000000`3f1caa18 : 00000000`00006000 ffffffff`fffffffe 00000000`ffffffff 00000000`4859ba40 : 0x3f1ca9d8
00000000`0014ca88 00000000`00006000 : ffffffff`fffffffe 00000000`ffffffff 00000000`4859ba40 00007ffa`1e10e50c : 0x3f1caa18
00000000`0014ca90 ffffffff`fffffffe : 00000000`ffffffff 00000000`4859ba40 00007ffa`1e10e50c 00000000`00006000 : 0x6000
00000000`0014ca98 00000000`ffffffff : 00000000`4859ba40 00007ffa`1e10e50c 00000000`00006000 00000000`ffffffff : 0xffffffff`fffffffe
00000000`0014caa0 00000000`4859ba40 : 00007ffa`1e10e50c 00000000`00006000 00000000`ffffffff 00000000`ffffffff : 0xffffffff
00000000`0014caa8 00007ffa`1e10e50c : 00000000`00006000 00000000`ffffffff 00000000`ffffffff 00000000`2c7ba010 : 0x4859ba40
00000000`0014cab0 00000000`00006000 : 00000000`ffffffff 00000000`ffffffff 00000000`2c7ba010 00000000`00003841 : BBC_Symphony_Orchestra__64_Bit_+0x98e50c
00000000`0014cab8 00000000`ffffffff : 00000000`ffffffff 00000000`2c7ba010 00000000`00003841 00000000`00000000 : 0x6000
00000000`0014cac0 00000000`ffffffff : 00000000`2c7ba010 00000000`00003841 00000000`00000000 00000000`00000000 : 0xffffffff
00000000`0014cac8 00000000`2c7ba010 : 00000000`00003841 00000000`00000000 00000000`00000000 00000000`00000000 : 0xffffffff
00000000`0014cad0 00000000`00003841 : 00000000`00000000 00000000`00000000 00000000`00000000 ffffffff`fffffffe : 0x2c7ba010
00000000`0014cad8 00000000`00000000 : 00000000`00000000 00000000`00000000 ffffffff`fffffffe 00000000`00000000 : 0x3841

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, Noel Borthwick said:

@Billy Buck That stack was captured from the 04 release not 05.

However the crash is in the plugin itself. There is nothing in the stack that shows the cause to be from Cakewalk.
Please forward the dump file to the plugin vendor since only they can fix it.

 

Thanks Noel, I've sent a bug report to Spitfire about this  issue along with the .dmp file.

Edited by Billy Buck
  • Thanks 1

Share this post


Link to post
Share on other sites

This is one of the best update ever...

I finished 3 songs from scratch to master in 2 consecutive days since installing this EA...

I guess the update brings some positive hocus pocus good energy to my mental state to work faster and better... Yay!

WTG team!

  • Like 4
  • Thanks 2

Share this post


Link to post
Share on other sites

Did anyone notice that the install of this EA release deletes the CbB icon in the start menu? Also it won't allow me to put it back.

I go to C:\Program Files\Cakewalk\Cakewalk Core and right click on the Cakewalk.exe and select "Pin To Start" but nothing happens.

Share this post


Link to post
Share on other sites
20 hours ago, Billy Buck said:

Thanks Noel, I've sent a bug report to Spitfire about this  issue along with the .dmp file.

We've also contacted them but have not heard back yet.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
4 hours ago, James Argo said:

This is one of the best update ever...

I finished 3 songs from scratch to master in 2 consecutive days since installing this EA...

I guess the update brings some positive hocus pocus good energy to my mental state to work faster and better... Yay!

WTG team!

Awesome! (I can't believe you work that fast!)

I believe Morten had it listed under "Misc" actually:

Quote

Misc.
Moving mono Waves plug-in forces track into mono unexpectedly
Eventide VST3 plug-ins hang when changing interleave
Added positive hocus pocus energy to work faster and better

😉

Share this post


Link to post
Share on other sites

Hi, 

This was my first post, put in in Q&A but I suddenly remembered that the problem described below also happened a few weeks ago (I forgot with which plugins) after I had CbB 2020.04  installed. Before that update I never had this kind of problem, so maybe it is related to the last official release.

I made a standard project template with many plugins pre-inserted (all deactivated, not consuming CPU at the start) and busses. So far, each time I opened the template all worked well. Since I've updated CbB the template worked well most of the time except for the following error that I got after a few days and also again last week: 

The following plugins are referred to by this project but could not be found:

FabFilter Pro-R (Bus: 'R-ambie')
FabFilter Pro-R (Bus: 'R-plate')
FabFilter Pro-R (Bus: 'R-hall')
Expurgate (Bus: 'FX-gate')
FabFilter Pro-C 2 (Bus: 'DR-SQSH')

The plugins are greyed out and when clicked upon I get the following text:

Cakewalk Missing Plug-In Stand-In
This plug-in is missing or improperly installed on your system.
The original plug-in state is saved by this stand-in, and will be restored if you save the project and subsequently load it on a system where the plug-in is properly installed.
Plug-In data (bytes): 456


However,...I can find the Fabfilter plugins in the plug-in manager and in the Audio FX menu and insert them on the same bus where the greyed out instance of the same plugin sits. That works well, but then I've got one not working instance greyed out (with my favorite plugin settings...) and a new one working but without my predefined favorite start settings...
The Expurgate plugin seems to have vanished? So, I guess I'll need to reinstall.

For the rest all seems to work as expected.

I have the following questions:

  1. Does anybody have an idea what happened, is this possibly related to the latest CbB update or is there another idea what could be at the root of this problem?
  2. Is there a way to redirect the new instance of the same plugin to the settings of the greyed out plugin?
  3. Is there a way to backup plugin settings in a template (or project file) so that I don't have to redo the settings each time this kind of problem happens
  4. I also noticed in the past that when you update certain plugins, they are not always recognised as an update of an existing plugin that is used in a project, so all settings are lost. Is there a way to prevent this?
  5. Can I move a topic posted in the wrong place from one forum part e.g. Q&A to another e.g. Feedback? I tried to find guide lines how the forum works but didn't find it (probably overlooked)

For the rest, it's impressive how CbB has improved over time, I hope that the audio magazines and websites will start including it in tests with the main paid DAWs like Pro Tools and Cubase. I'm convinced it should come out at least as good... Thanks for developing such great flexible, professional and free DAW!


System specs:
Windows 10 64bit with all latest updates (incl. runtime redistributables etc.) except for the big Win 10 May 2020 update (according to Will_Kaydo that seems to introduce new problems)
AMD Threadripper 1950X
32Gb 3200 MHz
RME HDSPe AIO
GeForce GTX 1050 Ti (audio, telemetry etc disabled)
Separate SSDs for programs and sound libraries
Thread scheduling model 2
Optimised all possible audio workstation settings I could find (processor throttling and dynamic frequency scaling, high performance, wireless connections, wake up timers and so on)
All software and drivers up to date

Share this post


Link to post
Share on other sites
On 5/23/2020 at 1:06 AM, Max Arwood said:

Well thread scheduling #3 is great for me now on play back ,  but now cakewalk freezes up on export audio.  I guess for  now I will just swap back and forth.  We might need thread scheduling for mixing and another for bouncing tracks.  It will only be a minor annoyance for  now. 

It will be just a minor annoyance.

 

I am still having lockups with Lexicon PCM Reverbs.  It

keeps locking up  saying cakewalk does  not have permission to speak to the Lexicon pcm reverb in “  “ ilok.

Any help would be appreciated. 

Thanks Again,

Max Arwood       

This has been fixed for final release thanks to @Max Arwood assistance.

  • Like 4

Share this post


Link to post
Share on other sites

Wow! More fixes!!  Great Job on a great piece of software. Now - More time to work on music! The waves and this one - can't believe you found these.  I can't imagine how deep some of this stuff is in the code! Oh yes, how much coffee is required for this type work?

Thanks,

Max Arwood

  • Like 3

Share this post


Link to post
Share on other sites

Teegarden

1)One time I have seen these messages I had moved some plugins to organize them.  2)The other time was when I updated some plugins and did not choose the same directory it was originally installed in. 

*2 would show the plugin in the plugin manager as correct, but in the project it would be pointing to the invalid older version.

 

Max Arwood

 

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites
6 hours ago, Max Arwood said:

Wow! More fixes!!  Great Job on a great piece of software. Now - More time to work on music! The waves and this one - can't believe you found these.  I can't imagine how deep some of this stuff is in the code! Oh yes, how much coffee is required for this type work?

Thanks,

Max Arwood

I was referring to your export audio issue. Ilok issues would have to be addressed by the plugin manufacturer or ilok itself since that is out of our control.

  • Like 1

Share this post


Link to post
Share on other sites
On 5/21/2020 at 6:36 AM, Matthew Sorrels said:

Aggressive thread scheduling model still doesn't seem viable with this version.  When I enable it and playback a project I just finished the output constantly studders.  Switching back to model 2 and everything plays perfectly smoothly.  This is with a 16 core/32 thread i9-9960X.

This also has been addressed for the upcoming release.

  • Like 5

Share this post


Link to post
Share on other sites
Posted (edited)

 Melodyne 5  just released,  Why did they use such an early version?🥵

melodyne 5.png

Edited by Leones

Share this post


Link to post
Share on other sites

That is the first version with ARA2 support. It appears they do not update the site with every release since the first supported version.

 

  • Thanks 1

Share this post


Link to post
Share on other sites
15 hours ago, Max Arwood said:

Teegarden

1)One time I have seen these messages I had moved some plugins to organize them.  2)The other time was when I updated some plugins and did not choose the same directory it was originally installed in. 

*2 would show the plugin in the plugin manager as correct, but in the project it would be pointing to the invalid older version.

 

Max Arwood

 

Thanks. It could be that I've updated the plugins and it happened afterwards, I also organised the plugins in different directories. 
I would expect CbB to be able to keep referring to the right plugin when moved or updated (in case of small updates). Maybe something that can be improved?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...