Jump to content
casio3000

Cake walk midi quantize ruins the song

Recommended Posts

Hello 

I am trying to quantize a multi track song  I played on my keyboard and recorded in midi format in cakewalk. I usually quanize my tracks on keyboard but since this song was recorded in cake wake I cant edit it on my keyboard. Quantizing by keyboard is pretty straightforward and works fine.

However I ve spent hours quantizing tracks on cakewalk and the result is awful. Even quzntizing the accompaniment that was created by keyboard makes the accompaniment out of beat and deletes some notes. Most of my tracks need to be quantizes to 1/32.

I ve read the manual and also played with settings in quantize menue but still get the same results. Can you please advise how to get a nice and clean quantize in cake walk ? 

Share this post


Link to post
Share on other sites

Midi quantize is an art in itself. It is simpler quantize audio. With Midi you have to try many times until you find what you like.

  • Like 1

Share this post


Link to post
Share on other sites

When quantizing smaller note values (1/32) you have to be sparse in using quantize correction. No DAW has the ability to read the mind of the user and with this comes many bumps and bruises. I try to quantize small sections at a time and check for correctness. 

Triplet values, Note values all have to be considered because sometimes within the same measure there are many different values of notes. Also take note of the quantize options. taking special note to things like "Midi start time. Note duration, exc

EditingMIDI.38.2.png

  • Like 2

Share this post


Link to post
Share on other sites
On 5/18/2020 at 7:56 AM, casio3000 said:

Even quzntizing the accompaniment that was created by keyboard makes the accompaniment out of beat and deletes some notes.

So you recorded live performance input as well as sequenced playback from a workstation-type keyboard simultaneously? I assume you had some sort of sync set up with matching tempos between the workstation and Cakewalk...? Were you playing to Cakewalk's audio metronome, or just playing along with the keyboard accompaniment? And how are MIDI and audio being routed and monitored while recording?

If MIDI is all late relative to the grid due to audio latency and/or MIDI transmission delay, you might have  a lot of notes getting quantized the wrong direction, but  I know of no circumstance that will cause notes to be deleted. Possibly you have early and late notes on the same note number getting quantized to the same gridline so one gets masked by the other...?

In any case, zoom in a bit and check the average discrepancy between the MIDI and the grid. And watch how it moves when you alternately quantize and undo. If everything is typically late  (or early)  you can start by nudging the whole clip to minimize the average discrepancy before quantizing. If there's a strong average offset one way or the other, you'll want to see what can be changed in your setup to minimize it.

Quantizing isn't rocket science, so long as you have a good handle on what resolution is needed, and everything is within half of that resolution of the M:B:T grid line where it was intended to land, it should give a good result.

  • Like 1

Share this post


Link to post
Share on other sites

I am not sure, but I would agree with @David Baay that this looks like a sync problem. Are you sending midi clock to the keyboard while you play? How are you recording the backing tracks from the keyboard into Cakewalk?

Share this post


Link to post
Share on other sites

If you were slightly rushing the Click track (if you used one) you may need to use a Negative Offset value in the Quantize options to account for rushing . Or nudge the actual notes over till quantize is working good.  If it averages to ahead of the beat I might set the Offset at -33 or -45 -55 If Quantize gets off due to  Rushing a drum fill the I might just Nudge till It just crosses the threshold to good.   Turn the strength down and Dial in how much rush to use.  Or Play with the Offset.

I like to insert midi quantize on a Clip So as to split the clip and change the Quantize settings for Each Clip when Various Quantize values are needed (1/32, 1/8 T 1/4 T or less strength (or none at all) in the drum fill,!or Rush Or drag a  Chorus or part of a song with a Negative or Positive Offset.

Side note:  I would like  to see  Automatable Quantizing to automate all of the various values without the need to split clip or process separately.  

You really have to think about note divisions and appropriate strength, Swing and Offset values.  (Usually  not just one setting) Also don’t be afraid to just Nudge the specific midi notes in PRV to retain more of a Live feel.
 

Groove Quantizing can be very useful as well. 
 

Just have Fun with it!!

 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
22 hours ago, JoseC said:

I am not sure, but I would agree with @David Baay that this looks like a sync problem. Are you sending midi clock to the keyboard while you play? How are you recording the backing tracks from the keyboard into Cakewalk?

Hi Jose 

No i did not setup midi clock and as i checked now the clock is set to Audio. Change it to midi sync ? how does this affect the quantize process ? what i do is i add midi tracks and set different channels for each track and then record each track changing the track number from keyboard

 

Edited by casio3000

Share this post


Link to post
Share on other sites
1 hour ago, casio3000 said:

Hi Jose 

No i did not setup midi clock and as i checked now the clock is set to Audio. Change it to midi sync ? how does this affect the quantize process ? what i do is i add midi tracks and set different channels for each track and then record each track changing the track number from keyboard

 

Maybe I misunderstood, but I thought that you are using tracks in an internal sequencer in your keyboard. If you do, you need to sync them with CbB:

- Set your keyboard to receive external midi clock. Most midi equipment with integrated sequencers will allow to do that.

- Set CbB to send Midi Clock/Start/Stop to the midi port where your keyboard is connected in Preferences/Project/MIdi

That way, both are using the same tempo and grid, and the keyboard's transport is slaved to Cakewalk's.  Depending on your tempo, 1/32 note is short enough to have troubles if both are not in sync and your backing tracks and CbB drift away in time. If they drift too much quantizing will not fix that easily.

That should be the first thing that you check, because it is what will mess your timing completely.  Once you are sure that everything is using the same tempo and grid, and is starting with a single transport, you can check if you somehow need to set a fixed offset for any reason, hardware latency, or whatever, like @Blogospherianman was saying above.

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Another thing: in case that your keyboard is not able to sync to external gear, like some home keyboards, next best option is looking if it is possible to download your sequencer midi data to the computer, and load your midi backing tracks in CbB. 

  • Like 1

Share this post


Link to post
Share on other sites

Also if you weren’t syncd up and don’t feel like redumping you can always sync up what you’ve record by mapping the grid (tempo) using Set Measure Beat at Now, since your project is midi.  If it was audio, you could map the tempo a different way.  Then quantizing should work fine.  If the grid is off, it only quantizes off.

  • Like 1

Share this post


Link to post
Share on other sites
8 hours ago, Blogospherianman said:

Also if you weren’t syncd up and don’t feel like redumping you can always sync up what you’ve record by mapping the grid (tempo) using Set Measure Beat at Now, since your project is midi.  If it was audio, you could map the tempo a different way.  Then quantizing should work fine.  If the grid is off, it only quantizes off.

Hi again

Just checked and there is no sync option on my keyboard. So got to drag all notes manually.  Still works but takes ages !! the issue is that for some rhythm, the drum track that is created on keyboard ( supposed to be 100% accurate in trams of beats) initially fits the grid but becomes out of grids for the rest of song.  Not sure if this is due to latency or something else ? 

if this issue is resolved then I can adjust all other tracks to the drum track

Share this post


Link to post
Share on other sites
On 5/20/2020 at 1:54 AM, David Baay said:

So you recorded live performance input as well as sequenced playback from a workstation-type keyboard simultaneously? I assume you had some sort of sync set up with matching tempos between the workstation and Cakewalk...? Were you playing to Cakewalk's audio metronome, or just playing along with the keyboard accompaniment? And how are MIDI and audio being routed and monitored while recording?

If MIDI is all late relative to the grid due to audio latency and/or MIDI transmission delay, you might have  a lot of notes getting quantized the wrong direction, but  I know of no circumstance that will cause notes to be deleted. Possibly you have early and late notes on the same note number getting quantized to the same gridline so one gets masked by the other...?

In any case, zoom in a bit and check the average discrepancy between the MIDI and the grid. And watch how it moves when you alternately quantize and undo. If everything is typically late  (or early)  you can start by nudging the whole clip to minimize the average discrepancy before quantizing. If there's a strong average offset one way or the other, you'll want to see what can be changed in your setup to minimize it.

Quantizing isn't rocket science, so long as you have a good handle on what resolution is needed, and everything is within half of that resolution of the M:B:T grid line where it was intended to land, it should give a good result.

Hi David 

you are right. my beats are out of grids. This is why the quantize does not work. can be due to latency. what is the solution to this ? can you explain a bit more regarding nudging the clip ? thanks 

Share this post


Link to post
Share on other sites
Posted (edited)

The problem is that, without some kind of sync, your pre-fab keyboard accompaniment is running oblivious to the clock/tempo/measures/beats of CW.    Maybe you can sync CW to the keyboard which must have some kind of internal MIDI sync that  can send out with its MIDI data.  However, if you are just recording the audio of the accompaniment, that wont work.

In other words, some folks above were suggesting you sync your keyboard to CW.  Instead maybe you can sync CW to your keyboard's internal clock.  Its obviously got one if it can sync to itself.  The question is whether it can output its clock info with MIDI from the accompaniment.

Maybe tell us the type and model of keyboard you are using (I assume its a Casio 3000 - but which model?) and the other details of your setup.

Edited by William W. Saunders, Jr.
  • Like 1

Share this post


Link to post
Share on other sites
11 hours ago, casio3000 said:

Hi David 

you are right. my beats are out of grids. This is why the quantize does not work. can be due to latency. what is the solution to this ? can you explain a bit more regarding nudging the clip ? thanks 

As I said above, if both things are not synced, they drift apart over time. This has nothing to do with latency. And nudging the clip will not help, either, because you do not have a fixed offset. The solution that @William W. Saunders, Jr. suggests above is good, but I do not think that your keyboard is able to send clock if it cannot not  receive it. I had a look at a Casio CT-X3000 midi implementation chart, just to get an idea, not knowing of course whether it is your keyboard or not, and it does not send nor receive clock. If yours is this model, or something alike, you are out of luck. 

You could still try to fix it manually, but it is probably too time consuming. I would do what I said above, just transfer your midi tracks to CbB (it seems that you could need a Casio utility to do it), and record them back from there using your keyboard as external sound module. 

  • Like 1

Share this post


Link to post
Share on other sites

We are talking about a $200 Home Keyboard. I would doubt very much if it has a midi sync option. 

Midi sync works by sending the DAW's clock out and driving the clock of the drums in the outboard midi device be it a drum machine or a keyboard. This way the midi output of the keyboard will be in perfect sync with the DAW. But that device needs to have a midi sync/ internal clock  toggle. 

Otherwise all you can do is set both the keyboard and Cakewalk to the same tempo and hope it stays close without drifting. 

You might get further in your music creating progress by using Cakewalk to directly make your drum loops. Without midi sync, as you have already discovered, the created tracks are unusable. There are thousands of drum loops available. Even SI drums has a bunch. Time would be better spent learning how to use the software the way it was designed to work.  There's plenty of tutorials. I cover using a drum loop in my videos- see signature.

 

  • Like 1

Share this post


Link to post
Share on other sites

No Sync, No prob! 
All you have to do is record the audio then adjust the tempo map to follow your audio.  You can use set Measure Beat at now or try dragging to the timeline and let melodyne map the tempo (although I’ve never had good results with Dragging to the timeline. 
I personally like turning on the click, opening the Tempo View, hit play and redraw the tempo map so that the Click (metronome) stays right with the music. Once done with any of those steps you can Quantize if needed.  
If you need help, just PM me the project file and I can make a Tempo map for ya.

  • Like 1

Share this post


Link to post
Share on other sites
On 5/23/2020 at 3:30 PM, Blogospherianman said:

No Sync, No prob! 
All you have to do is record the audio then adjust the tempo map to follow your audio.  You can use set Measure Beat at now

I agree, but would still record MIDI rather than audio, and use Set Measure/Beat At Now to sync Cakewalk's timeline to it.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Hi again 

Thanks everyone for your comments. I learned a lot from the comments. Just to update you: I am using a Casio CTX 3000 keyboard for recording midi on Cakewalk. There is no sync option on my keyboard.  However I figured out that the problem is not with syncing as I can drag all notes to grids at once manually. As Jose said latency is not a problem here either. 

Thank you John for your advise regarding setting correct tempo and time signature. This helped a lot with finding the problem. So what i did was i ran an isolation test by setting up everything 100% correct. 

The problem was a 1/64 Timba note in my accompaniment t. So this probably confused the software and made every beat of drum out of grid. I took the Timba note off my rhythm and the issue was fixed. I notice this for every rhythm that contains 1/64 fraction of notes. 

Not sure if this is due to my laptop CPU being unable to handle this or Cakewalk itself or maybe my keyboard.  

 

 

Edited by casio3000

Share this post


Link to post
Share on other sites

You can do a lot of midi on a computer from 1984. So it's not your CPU. And the software can only do so much to second guess what it is you are after. Think about Auto fill on cell phones. Does it ever second guess what your typing 100%? I find that quantizing works fine for putting anything from 1/16th note and bigger in place. It gets tricky if there are triplets involved. Over the years I have developed a few things that I will do to keep quantizing from moving notes to the wrong place. 

If I have a pre made drum beat or midi track I will try different grids in PRV until it matches up with the notes. With drums the Hi Hats are the place to look. You'll soon find out if it's 16th or 8th note triplets etc. I then use that as my setting for other parts. It will still require some editing and you get good at "seeing" the wrong note placements. 

I find real piano parts should be left alone And even snare parts I play on my digital drum kit I will have to manually edit. Sometimes playing a bit ahead of the beat is a good thing. If I was a super good player I would not need to quantize but I'm a guitar player, not a drummer or keyboardist.  An example is I always play real bass on my songs and if I convert it to midi it's right on the money. 

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...