Jump to content
  • 0
Nigel Mackay

MIDI tracks play faster than audio tracks

Question

Remixing 60s standards.

What I did:
Opened a MIDI file.
Saved it as a project.
Added an audio track.
Imported the reference mp3.
Adjusted the start point and tempo so MIDI and reference match exactly.

Initially all my timing seemed ok.

Started bouncing the MIDI to audio tracks.
The bounced audio tracks play at the correct speed.
The MIDI tracks not yet bounced now (suddenly) play too fast.
The events list keeps up, but the sound overtakes the PRV. It is as if the MIDI tracks are busy playing in their own lookahead buffer.
The MIDI tracks finish the piece before the audio tracks and the reference track.

If I bounce a track to audio, the audio track is in perfect sync with the reference (and the PRV). But the MIDI still plays faster and finishes the piece earlier than the audio.

If it helps, here are my settings.


 

Read ahead problem - driver settings.jpg

Read ahead problem - playback and recording.jpg

Read ahead problem - sync and chaching.jpg

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Hi Nigel,

I suggest importing your MIDI after you set your desired tempo. 

Kind regards,

tecknot

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Different piece of music, but similar problem.

Project has 17 instruments, 8 of which are Kontakt. Only midi in the project. When I bounce to audio the resulting audio lags behind real time. The lag varies over the length of the piece. No two tracks have the same lag - they go in and out of sync while playing.

No FX on any channel.

Split project up into 3 sub-projects, paring the instruments down. Bounced audio is 100% ok.

I have Realtek on my motherboard. Normally use WASAPI shared, but tried WASAPI exclusive. Doesn't help.

Tried archiving all midi and instruments except the one being bounced, doesn't help.

i3 at 3GHz. While bouncing using 50% of CPU, 7.3GB out of 20GB RAM. Idle CPU is 12%.

In a 4m18s piece the end lag is a 1/16th note at 120bpm.

Driver/audio settings as above.

 

Edited by Nigel Mackay

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...