Jump to content
winkpain

MIDI keyboard suddenly no longer works in CW

Recommended Posts

Just now, msmcleod said:

No, I think it's been like this for a while.

We've been looking at some control surface issues which has put more focus on it.

Interesting! It is definitely a new thing for me and my set-up which has remained unchanged for years, besides updates of course.

But thanks again for chiming in on it. It's always a relief to know an issue is in capable hands.

Share this post


Link to post
Share on other sites
2 hours ago, msmcleod said:

We've been looking at some control surface issues which has put more focus on it.

Which control surface, if you can tell?

Share this post


Link to post
Share on other sites
Just now, chris.r said:

Which control surface, if you can tell?

lol - none in particular, just general handling

  • Haha 1

Share this post


Link to post
Share on other sites
On 6/14/2020 at 9:41 PM, msmcleod said:

We're currently looking into these issues.

From what I've noticed so far there's a few issues:

  1. Cakewalk isn't always getting connection/disconnection notifications from Windows. Interestingly though, if Windows Device Manager is running at the time, the notifications are received instantly. Not all users are seeing this issue though.
  2. If you re-connect a MIDI devices while Cakewalk is running (and Cakewalk does actually get notified about it). Cakewalk doesn't enable it- it leaves it unchecked.
  3. Related to (2) - if you go into preferences and change anything. in any page, the MIDI preferences are overwritten meaning that your unchecked devices are saved as unchecked.

Until we sort the issues out, there are a few things you can do in the meantime:

  1. Always use the same USB ports for MIDI devices, and always plug in your devices before you start Cakewalk
  2. If possible, make sure they're plugged in before starting your PC so they're always assigned same device ID by Windows.
  3. If you have a stable MIDI setup you want to keep, consider making TTSSEQ.INI read-only. This will prevent Cakewalk from overwriting it.
  4. Make sure USB sleep is disabled in your power options.

The problem I am seeing  does not fit exactly into any of the three issues listed above. 

When I start Cakewalk my controller is showing up in the list of MIDI devices and is enabled (checked) but, it does not work.  If I unplug the USB cable Cakewalk notifies me that the controller has been disconnected. If I plug it back in Cakewalk notifies me that a new device has been connected and asks if I want to use it. It will be listed and enabled  but it will still not work.

The only way the controller will work is if  Cakewalk is started with the controller disabled (unchecked). Once Cakewalk starts I can  then enable the  controller and it works. 

This is only affecting Cakewalk, the controller works normally in other software.

  • Like 1

Share this post


Link to post
Share on other sites

@Alastair Cardwell - a couple of questions:

1. Is your MIDI mode set to UWP or MME  (I've found MME to be far more reliable with some devices, especially older ones) ?

2. Have you tried disabling "Zero Controllers When Play Stops" ?  Maybe Cakewalk is flooding your control surface on startup with reset messages, causing it to hang up.

Share this post


Link to post
Share on other sites
22 hours ago, msmcleod said:

@Alastair Cardwell - a couple of questions:

1. Is your MIDI mode set to UWP or MME  (I've found MME to be far more reliable with some devices, especially older ones) ?

2. Have you tried disabling "Zero Controllers When Play Stops" ?  Maybe Cakewalk is flooding your control surface on startup with reset messages, causing it to hang up.

Midi   mode was set to MME. I tried changing it to UWP and it  appears to fix the problem. I have closed and restarted Cakewalk several times with Midi mode set to UWP and the controller works every time. If I switch back to MME the controller the does not work if Cakewalk is started with it enabled. I have not done any other testing yet to see if there are any issues running in UWP mode.

Thanks for the help

  • Like 1

Share this post


Link to post
Share on other sites
On 6/17/2020 at 10:08 PM, Alastair Cardwell said:

Midi   mode was set to MME. I tried changing it to UWP and it  appears to fix the problem. I have closed and restarted Cakewalk several times with Midi mode set to UWP and the controller works every time. If I switch back to MME the controller the does not work if Cakewalk is started with it enabled. I have not done any other testing yet to see if there are any issues running in UWP mode.

 

I have discovered that UWP is not problem free either. The sustain pedal connected to the MIDI controller does not work after Cakewalk is started. The only workaround I have found so far is to temporarily change back to MME mode then back to UWP mode again. After this the sustain pedal works again. 

Share this post


Link to post
Share on other sites

Got exact the same problem except after my M-audio stops working I get zero midi signals coming in even when I shut down cakewalk. Read some useful and plausible causes and solutions here so I'll be checking em tomorrow.

On 6/17/2020 at 12:40 AM, msmcleod said:

@Alastair Cardwell - a couple of questions:

1. Is your MIDI mode set to UWP or MME  (I've found MME to be far more reliable with some devices, especially older ones) ?

2. Have you tried disabling "Zero Controllers When Play Stops" ?  Maybe Cakewalk is flooding your control surface on startup with reset messages, causing it to hang up.

Does 2 also effect an M-audio Oxygen 49 ? This seems  to me the most plausible answer. The keyboard works at first and after playing some parts or replaying recorded parts I get zero input. Disconnecting and restarting cakewalk usually does the trick.

Share this post


Link to post
Share on other sites
47 minutes ago, Jan Venken said:

Got exact the same problem except after my M-audio stops working I get zero midi signals coming in even when I shut down cakewalk. Read some useful and plausible causes and solutions here so I'll be checking em tomorrow.

Does 2 also effect an M-audio Oxygen 49 ? This seems  to me the most plausible answer. The keyboard works at first and after playing some parts or replaying recorded parts I get zero input. Disconnecting and restarting cakewalk usually does the trick.

It could be, but it could also be your USB sleep settings. Make sure USB sleep is disabled for all your Audio & MIDI devices.

It may be easier just to disable USB sleep altogether in your Windows power config.

Share this post


Link to post
Share on other sites

Since updating cakewalk I have the same midi issues connecting an alesis dm10 drum brain midi via USB audio interface. This used to work fine but now cakewalk isn't recognising the midi even though the sys tray icon shows activity and the midi works when opening EZDrummer standalone but I can't get it to work in cakewalk using anything suggested in this thread (I've yet to try the chicken sacrifice 😃). So frustrating!

Share this post


Link to post
Share on other sites

This is happening to me now. Only since I updated too. But I have NI S61 Controller. I have been working on Midi Maps for certain plugins of late and seems to work sporadically now. Additionally though in the last month I have added to my setup my 'old' M-Audio Midisport 4x4. As I have my old Roland Drum kit running into it for recording purposes. I've found that if I exit cakewalk and start it. I can get the VSTi plugins and midi maps to work. But the moment I load another of the same VSTi's it stops working. Saving doesn't help, or at least is inconsistent and varied results. In other words when it starts to go wrong is stays in the save state. But I've too few tests to see a pattern or single examples that are consistent. Could work for most of the day and then just stops. I see midi signal but to where it goes I have no idea. I'll keep an eye on it. remove the MidiSport 4x4. Just interesting to see some of this being M-Audio devices. I'll let you know what I find out as I go.

Share this post


Link to post
Share on other sites

I had similar problems with an M-Audio Oxygen49 Gen 2 keyboard. The unit would disconnect, usually when I was doing something important, or else it would be sending midi messages which I had not instigated, such as putting VST synths out of tune. The midi events would appear in Cakewalks event manager. The little red LED screen on the M-Audio was also flickering. In my case they were caused by a failing USB port on the rear of the unit and Win 10 not using the unsigned drivers which originally came with the machine.

So I ordered some new midi ports as they are cheap and there are similar ones on many midi devices I use (printers and scanners etc.) so now I have some spares. Take the midi keyboard apart and unsolder the port from the board. Solder in the new one. Reassemble the unit.

This step was important also, mainly to avoid using the generic driver which comes with Win 10. Set Win 10 to allow unsigned drivers to be installed. I used the method shown here https://www.howtogeek.com/167723/how-to-disable-driver-signature-verification-on-64-bit-windows-8.1-so-that-you-can-install-unsigned-drivers/.  Reboot and then install the last M-Audio driver released for that unit, following the instructions as to when to plug in the M-Audio unit so the system will recognise it from now on.  Turn back on driver signing and reboot with the M-Audio plugged in. Started Cakewalk and all has worked fine since.

Dodgy/worn USB ports on the rear of the M-Audio are known to cause problems. There are some good instructional videos on You Tube on how to swap them out. The fading LED screen on the M-Audio unit is still a problem with me (but at least it is brighter now) but if I can find a replacement part I will have a go at replacing that also.

Share this post


Link to post
Share on other sites

Ok done more tests and am now finding that I have a more stable layout. I've moved my M-Audio 4x4 out of my setup. Things are much better. I was not getting signal even on Omni before... so its great. Also keeping better track of my Midi Channel assignments. As I have a Maschine Mk3 too. So I manage plugins and their parameters from both my Maschine and S61 each in Midi mode. Sometimes both managing the same plugin. I've it all working well now. I just find with the odd plugin you need to track those channel assignments carefully. Arturia Labs Lite is one. Its so easy to forget you assign channel in the plugin and on the track in Cakewalk. So when loading a new instrument track with the same plugin it will load with that channel number.  Unlike Kontakt which loads back to A ... ie Channel 1.  Analog Labs Lite loads assigned in the plugin with the last setting you set it. So just something to note. I'm sure most of knew that. I've been more used to the hardware assigned channels and just have one channel on each piece of hardware and that was it. But with plugins you've the same 'hardware' loaded several times you need to check those again depending on the plugin. Anyway from the Midi side it's stable. Before I'd not get any signal to the plugins... But the M-Audio is out of the loop. Then again it is very old.  But right now I cannot conclude that was my stability issue. I can say that after several reboots and opening and closing Cakewalk, it's been all good without it. I did too have updates for my Waves plugins some I've managed and for Arturia Analog Labs. Also my Spitfire Labs. All 3 of those were having issues last weekend when I did the Cakewalk update. With a few others that did not get subsequent updates. The fact they each have updates  may also have added stability. No idea. Just really happy its good and working. Going back to making music and less time stuffing with Midi signal. My workflow is coming together nicely. 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...