Jump to content
Paul Johnson

Can hear both audio and MIDI in my output

Recommended Posts

Yes, I'm a complete newbie when it comes to working with MIDI keyboards and DAWs.  So, please have patience for a question that is probably in one of the manuals somewhere, but to my frustration must be glossing by it.

My setup is a Roland RD700 hooked through a Focusrite 4i4 (3rd Gen).  I do have both the MIDI and the audio hooked up to the keyboard.

I created a MIDI track in Cakewalk by dragging over the Cakewalk TTS-1 plugin and can even record the track using the selected sound - in this case a simple piano.  The other day, I selected "something" (that is the mystery - how I got there) where my Roland was not playing any other sound than what I had selected in my MIDI track.  Even the LED screen on my Roland showed that it was under control of the Cakewalk software.  I didn't touch anything on the keyboard to do that, it was something in the Cakewalk software.  Well, I come back two days later and I cannot get back to that state.  When I play, I hear both the MIDI sound AND the audio being generated from the Roland.

I saved everything after my first session, but it didn't come back to the same place.  I just want to get back to my position where I was recording MIDI and not hearing my Roland's output as well.

Any pointers to documentation or help is appreciated.

Thanks!

 

Share this post


Link to post
Share on other sites

First, on the RD-700, go to Menu > Utility > Rec Setting , and set 'Local Switch' to OFF.  This stops the Roland's sound module from responding to 'Local' input coming directly from the keyboard.  Now you'll only hear the Roland responding ot your live input if the MIDI track controlling it has Input Echo enabled. turning of Local Control is standard operating procedure for using any keyboard synth synth (i.e. combined MIDI controller keyboard and sound module) with a DAW.

Another setting you'll  want to make it is to go  to Menu > System, page right a couple times, and change 'Part Mode' at the bottom of that page from 16PART+PERF to just 16PART . This is needed to get the piano to play back using the same sound you have selected in the front panel (or via patch change commands from Cakewalk if you get to that point) as you hear when playing under Local Control.

Share this post


Link to post
Share on other sites
9 hours ago, David Baay said:

First, on the RD-700, go to Menu > Utility > Rec Setting , and set 'Local Switch' to OFF.  This stops the Roland's sound module from responding to 'Local' input coming directly from the keyboard.  Now you'll only hear the Roland responding ot your live input if the MIDI track controlling it has Input Echo enabled. turning of Local Control is standard operating procedure for using any keyboard synth synth (i.e. combined MIDI controller keyboard and sound module) with a DAW.

Another setting you'll  want to make it is to go  to Menu > System, page right a couple times, and change 'Part Mode' at the bottom of that page from 16PART+PERF to just 16PART . This is needed to get the piano to play back using the same sound you have selected in the front panel (or via patch change commands from Cakewalk if you get to that point) as you hear when playing under Local Control.

Howdy, David - just curious here.  What sound would someone get, if they did not change the Part Mode parameter?  I have not encountered that sort of parameter before (I also do not own the RD-700), I am just wondering what that parameter does.

Thanks - sorry for the sideways questions, as it does not apply to the thread, I am just trying to understand what that does.

Bob Bone

Share this post


Link to post
Share on other sites

It's complicated, and I have not revisited the issue for quite a while so my recall is fuzzy, but...

the 16PART+PERF mode in the RD-700 (NX in my case) allows for an external sequencer/DAW to use the sound module as a 16-part multitimbral  instrument at the same time that a performer has access to an additional 5 parts by Local Control (i.e. live 'PERFormance' parts), and the patches assigned to those parts can be different from the other 16 MIDI-driven parts.  To ensure the sound from playback of recorded MIDI is the same as what you heard while recording, you want to make sure your playing the MIDI driven parts from the keyboard.  And there are some additional complications related to selecting patches from the DAW vs. selecting them from the front panel which get simplified by disabling the PERF mode.

 

Share this post


Link to post
Share on other sites

I make sure the audio track inputs are set to 'none' until I want to record audio.

Share this post


Link to post
Share on other sites

Ahhhh....changing the Local Switch to "Off" did the trick. I don't, however, have a "Part Mode" setting.  This RD-700 is almost 20 years old.  Still works great, but may not have that option in the same verbiage as you mentioned.  Regardless, you have definitely helped me get to the next step.

I seem to learn new things by the "Ready-Fire-Aim" principle.  I get in and try to figure it out as much as I can and then, when I'm a little bit dangerous I get the manuals out and dive deeper.  I'm still in the phase of trying to get dangerous.  

Once again, thanks a lot!!

Share this post


Link to post
Share on other sites

Cool. Glad to help. I got the 700NX a few years ago, replacing an RD-300s that I bought new in 1988! It was still going strong; I gave it to my son-in-law. I just had the itch for something new with more state-of-the-art touch and acoustic piano sounds. Apart from using it as my main controller all those years, I mostly used the E.P. on the 300s; the acoustic piano was pretty sad by modern standards, but the E.P was great, and I haven't found a plugin to equal the built-in chorus on that board.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...