Jump to content
Geoff Childers

Presonus Faderport V2 not working in Cakewalk

Recommended Posts

I've been using a Presonus Faderport 8 for ages in Cakewalk by Bandlab and it works well enough. I decided to downgrade to the Faderport V2 to save desktop real estate, and was surprised to discover that the FPV2 seems to be less compatible with Cakewalk than the FP8. On the FPV2 the RTZ function doesn't work, the (<<) and (>>) buttons don't skip between markers properly, and the Undo and Redo functions don't work. None of these are problems on the FP8. Has anyone had success using the FPV2 in Cakewalk?

I'm running the FPV2 in MCU Logic mode with the most recent firmware. Under Cakewalk's MIDI Devices, I have Presonus FP2 checked under inputs and outputs. Under Control Surfaces, I added it as a Mackie Control, with Presonus FP2 enabled as both the input and output. WAI is checked. I'm not sure what else to try.  After several back and forth messages with Presonus' support, they sent me here.

Share this post


Link to post
Share on other sites

The person to respond to this would be AZSlow3. He has written a plugin controller that is much more flexible than the build in ones that come with cakewalk. In addition he might know how to help you.  I don't have a faderport so don't know how to help you.

Here are a couple of semi-related threads.

 

Share this post


Link to post
Share on other sites

Classic had specialized plug-in for Cakewalk. V2 does not have such plug-in and it can not mimic Classic.

There is no published preset for V2 (at least I have not seen it), but in case you put V2 into some "native" mode (so its controls just send what user is doing, without attempt to be "smart"), you can MIDI re-learn the preset for Classic using V2. That should work, except feedback (Classic designers have made a... mistake... so feedback to buttons does not match commands from these buttons. I think "Use Ctrl" instead of exact MIDI messages in the Feedback section should work for V2.)

So, definitively manageable (with device in hands) but a bit of DIY. If you have no time nor willing to invest it, I can not help.

Share this post


Link to post
Share on other sites

I appreciate the suggestion, azslow3, though to be perfectly honest with you, pretty much everything you said went over my head. I've been using MIDI gear forever, but when basic functionality fails, I revert to noob status.

I did try putting the FaderPort into its native StudioOne mode (not sure if that's what you meant), but having it in this mode crashed Cakewalk when I went into the MIDI settings.

I'm tired of fighting with the FaderPort V2. I'm going to return it and stick with my FP8.

Share this post


Link to post
Share on other sites

Crashed DAW just because of some MIDI device internal mode is not expected result. It can be you have some "MIDI loop" inside your project, during surface (and other MIDI devices) setup it is better have black project loaded (without any MIDI tracks). Other reason can be some Control Surfaces in Cakewalk preferences (Cakewalk tend to mess with MIDI IO assignments when new devices are added). Finally "starting from scratch" is also an option, after cleaning all MIDI devices in Windows Device Manager and removing Cakewalk MIDI related INI files.

But in case you prefer out of the box solutions, I agree that FaderPort V2 is not the device to use with Cakewalk. At least till someone make working preset and write/record installation instructions.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...