Jump to content

Recommended Posts

Posted (edited)

I hope someday the arranger preview will work "seamlessly" at high buffer counts.

Years ago, being weary of bumping buffers as a song progressed I set my system up to use 2048 buffers and hardware and midi direct monitoring to I could forget about the storage medium and just be free. Naturally, arranger preview exhibits huge gaps if I rearrange sections. I had been able to mouse-to-markers while the transport ran to hop around the arrangement with little more than a tick or two even with a dense, done, song at 2048 asio buffers. Wondering why if I can do that with my mouse, why can't cake make an arranger track?¬† I'll wait. Things will get better. I'm not moving my buffers. I like it this way. ūüôā

Edited by bitman

Share this post


Link to post
Share on other sites
14 hours ago, Noel Borthwick said:

@mikannohakoWe have fixed this for the next update. Can you share your project so we can verify that it's the same issue?

@Noel Borthwick That's great to hear! I sent a message!

Also I found another issue on the same project.  When I really zoomed further and hit play, it won't stop.

The stop button gets grayed out and space key won't work either.

9XCHKo762o.gif

 

 

Share this post


Link to post
Share on other sites
10 hours ago, mikannohako said:

@Noel Borthwick That's great to hear! I sent a message!

Also I found another issue on the same project.  When I really zoomed further and hit play, it won't stop.

The stop button gets grayed out and space key won't work either.

 

Do you see this in any other project? If it's specific to that one, it'd be helpful if you could upload it. 

  • Like 1

Share this post


Link to post
Share on other sites
11 hours ago, Jonathan Sasor said:

Do you see this in any other project? If it's specific to that one, it'd be helpful if you could upload it. 

@Jonathan Sasor

I tried it on newly created project file, and it wasn't reproducible in that new file.

So probably it's the problem related to that specific project file.

The original project file was actually created a long ago with older version of sonar. It might be X1, X2, or maybe X3.

I am kind re-working on that.

So it might have something to do with that.

The issue was seen on the same project file that I sent to Noel.

I'll send it to you in case.

Thanks!

 

Share this post


Link to post
Share on other sites
On 5/11/2020 at 4:14 AM, mikannohako said:

@Noel Borthwick That's great to hear! I sent a message!

Also I found another issue on the same project.  When I really zoomed further and hit play, it won't stop.

The stop button gets grayed out and space key won't work either.

9XCHKo762o.gif

 

 

I too have had this issue on many projects (from before this latest CW version), randomly yet often enough. Going to Task Manager and closing out CW is the only way out.

I will try and reproduce next time it happens.

Share this post


Link to post
Share on other sites
33 minutes ago, winkpain said:

I too have had this issue on many projects (from before this latest CW version), randomly yet often enough. Going to Task Manager and closing out CW is the only way out.

I will try and reproduce next time it happens.

Clicking CbB icon on your windows Task Bar 

might stop it even without closing the application.

I could stop it by doing that when that issue occurred.

Share this post


Link to post
Share on other sites
8 minutes ago, mikannohako said:

Clicking CbB icon on your windows Task Bar 

might stop it even without closing the application.

I could stop it by doing that when that issue occurred.

Interesting. Simply clicking on the icon?  I will try next time...

Share this post


Link to post
Share on other sites
Just now, winkpain said:

Interesting. Simply clicking on the icon?  I will try next time...

Yeah, like that.

I don't remember how exactly it worked but I believe it minimized the application as you would expect and then I could somehow retrieve the control after clicking the icon again.

I actually did that while screen recording for a gif but discarded the file as I didn't want to show my cluttered desktop.

Share this post


Link to post
Share on other sites
1 minute ago, mikannohako said:

Yeah, like that.

I don't remember how exactly it worked but I believe it minimized the application as you would expect and then I could somehow retrieve the control after clicking the icon again.

I actually did that while screen recording for a gif but discarded the file as I didn't want to show my cluttered desktop.

Gotcha.

What screen recorder do you use? I'm actually trying to figure some out right now. I have Captura and LICEcap recording to GIF, but the files are still so large. I can't figure out how to reduce the size without actually just choosing a smaller area of screen to record..... (sorry for off-topic request)

Share this post


Link to post
Share on other sites
5 minutes ago, winkpain said:

Gotcha.

What screen recorder do you use? I'm actually trying to figure some out right now. I have Captura and LICEcap recording to GIF, but the files are still so large. I can't figure out how to reduce the size without actually just choosing a smaller area of screen to record..... (sorry for off-topic request)

I used this one called recordit.

https://recordit.co/

It automatically uploads the file to the server and you can get the URL for the file after pressing stop button. As it uploads to the server, I have to be careful about what to record though.

(I could delete it later thought)

  • Thanks 1

Share this post


Link to post
Share on other sites
22 hours ago, mikannohako said:

Clicking CbB icon on your windows Task Bar 

might stop it even without closing the application.

I could stop it by doing that when that issue occurred.

When my zoom gets ‚Äėhung‚Äô I use the WIN key to get enough control to Right Click¬†the Task bar then click ‚ÄėShow Desktop‚Äô. ¬†If I Zoomed After hitting play this works to regain control. ¬†If I Zoom first then hit play, I have to close Cakewalk via the Task manager.

Share this post


Link to post
Share on other sites

Dropdown Annoyance

It is so frustrating and irritating. Every time I click a clickable downpointing triangle drop down menu, I instinctively click the triangle again when I want to dismiss the menu, BUT THE MENU DOES'T GO AWAY!!! It's so annoying! I have to click somewhere else to get rid of the menu. I don't like that at all. I think it would be cleaner operation if you have to click on the same triangle to collapse it. Is that designed with intention???

  • Like 1

Share this post


Link to post
Share on other sites
On 5/10/2020 at 9:59 PM, bitman said:

I hope someday the arranger preview will work "seamlessly" at high buffer counts.

Years ago, being weary of bumping buffers as a song progressed I set my system up to use 2048 buffers and hardware and midi direct monitoring to I could forget about the storage medium and just be free. Naturally, arranger preview exhibits huge gaps if I rearrange sections. I had been able to mouse-to-markers while the transport ran to hop around the arrangement with little more than a tick or two even with a dense, done, song at 2048 asio buffers. Wondering why if I can do that with my mouse, why can't cake make an arranger track?¬† I'll wait. Things will get better. I'm not moving my buffers. I like it this way. ūüôā

2048 is excessively high. Most drivers won't even allow that. When you click with the mouse the same thing occurs except that it continues to play the old audio until the seek occurs. This fools your ear into thinking that it happens within a tick.  We can't do that with the arranger or we'll "leak" data from outside a section boundary. Hence silence is streamed until the seek is realized.

Running at lower buffer sizes greatly improves this.

Share this post


Link to post
Share on other sites

K. I'll take it down to 1024, but you'll have to meet me half way then. ūüėÉ

Share this post


Link to post
Share on other sites

Hi! I found a cosmetic bug. After splitting an Instrument Track, the Audio and Midi tab buttons are not removed in the inspector section, although they should be hidden. I have to click to one of them to hide them as expected.

000030.png.86970b73bf13a275512ac053f7cc0a11.png000031.png.2d4e40ac9abcd109ca745d0b20103dcd.png

 

And vica versa, after making an Instrument Track (by combining a Midi and an attached Audio track), the Audio and Midi tab buttons are not visible. I have to select an other track and then select again this track to force Cakewalk to display these tab buttons.

000032.png.c1eace0af957fbdf539a104bac2ff178.png

000033.png.d0a60914e0b9937563909846b58a67a1.png

Share this post


Link to post
Share on other sites

Mislocalization to Japanese

[Global menu]
File > Import > BandLab Project...

[Preferences] MIDI - Playback and Recording
Always Echo Current MIDI Track

[Preferences] Customization - Keyboard Shortcuts
Input Echo
Unfreeze Track

And...  most of assigned Keys are not displayed with BOLD font even if it is bound as default.

FYI: If you need correct Japanese phrases, I can provide them.

Share this post


Link to post
Share on other sites

Hello!

I'm just hobbyist in music and try different free DAWs. What I say. Cakewalk by BandLab is cool! Especially sound engine fast enough on my old system.

But why there is no MIDI routing without "third leg" in the?

MIDI modifiers plugins cannot be routed by simple way. That feature is in REAPER, Tracktion Waveform and others, but not in Cakewalk. Why? I want to use not only Cakewalk's arpeggiator, but, for example, BlueArp too. Of course, I can do it by not usual way. And what about to do it without excessive things?

Any plans to implement this feature in future?

  • Like 1

Share this post


Link to post
Share on other sites

Another behavior change?
When I split a clip, it automatically includes the last control change event with the same value, which is very annoying.
No option to bring it back to the old behavior?

Share this post


Link to post
Share on other sites
2 hours ago, Tomoko Mikami said:

Another behavior change?
When I split a clip, it automatically includes the last control change event with the same value, which is very annoying.
No option to bring it back to the old behavior?

Go to Preferences->Customization->Editing and un-check "Split MIDI Notes".

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

√ó
√ó
  • Create New...