Jump to content
larrymcg

Recording I/F Rejected by my 3 Audio Apps

Recommended Posts

Running Win 10 Pro (v1803 with latest updates) on HP PC/Desktop HP ENVY 750xt, CPU: Intel Core i7-4790 quad core  Memory: 8GB, Graphics Card(s): Nvidia GeForce GTX 745, Sound Card: Integrated -  Realtek High Definition Audio.

I have used 3 apps for music recording and midi over the years:  Cakewalk by Bandlab  v25.01.0.27  latest update 2/2/19, Sonar X3 Studio (x64)  v20.0 (and previous versions going back to Pro Audio 9), and Cool Edit 2000  no version - very old.  I haven't done any audio recordings for about a year and now Cakewalk, Sonar and Cool Edit will/can't deal with the recording side on my audio interface (but audio playback is fine).  For example, Cakewalk and Sonar put up an error box when trying to enable recording which says:

"Unable to open audio record device. Device may not support the current project's audio format or may be in use."

Cool Edit just throws up an "External Error" message.

I have done audio recordings on this PC with Sonar and Cool Edit but likely not Cakewalk.  The Realtek interface is the only recording device that the 3 apps show for audio recording.  The Windows system information shows 3 audio devices (besides the midi interface): Realtek High Definition Audio - on-board - This has been my sound input device;
NVIDIA High Definition Audio - don't know what this is; NVIDIA Virtual Audio Device (Wave Extensible) (WDM) - don't know what this is.

I've tried lots of settings changes without success.  Don't know where to look next. I figure that some Win10 update over the last year or so created the issue with the driver.

-- Larry

Share this post


Link to post
Share on other sites

It is best to use a proper audio interface for any serious audio work, but if your only working with midi you can get by with on board sound chip.

Try WASAPI shared or exclusive. 

Share this post


Link to post
Share on other sites

Cactus Music,  I tried WASAPI (shared and exclusive).  Didn't help so I reverted to MME.  This got me a new issue - anything I play back (from Cakewalk or YouTube or FaceBook or my MP3s...)  has a very fast and strong reverb.  Totally obnoxious.  I can not find a setting to make it go away.   My PC line-out is connected to a mixer that has a headphone amp.  The mixer has no effects capabilities.  I've tried restarting the PC - no help. 

Don't know where to look next.  While looking for some relevant setting I have run into a lot of "sound" related interfaces. Seems like too many to me.

-- Larry

Share this post


Link to post
Share on other sites
48 minutes ago, larrymcg said:

Didn't help so I reverted to MME.  This got me a new issue - anything I play back (from Cakewalk or YouTube or FaceBook or my MP3s...)  has a very fast and strong reverb.  Totally obnoxious.  I can not find a setting to make it go away.   My PC line-out is connected to a mixer that has a headphone amp.  The mixer has no effects capabilities.  I've tried restarting the PC - no help. 

To avoid any problems, such as the ones you are having, its in your best interest to use a audio interface made for music production and not use the on-board sound chip. 

The line out of your on-board  sound-chip, is prob stereo. a dedicated audio interface will have 2 main outs that can connect to a mixer. But the question is why are you connecting a mixer to line outs? Studio monitors go to line outs of your sound card in most cases..

Share this post


Link to post
Share on other sites

CJ Jacobson,  My setup is a bit complicated.  I will try to provide an attachment (PDF) that shows the audio paths without the MIDI paths.  I'm a trumpet/flugelhorn player and use a microphone that has an XLR connection which the mixer supports (supports 4 mics with individual mic level controls, 4 sends with level controls, and a headphone amp with left/right level controls - it's a midiman Fineline).  There are also two synths (Roland JV-30 keyboard/synth and Yamaha TG-55 synth module). Besides the headphones, I have a JVC Home receiver powering a 3.1 speaker system. I have an audio switch that allows me to independently switch the mic, JV-30 and TG-55 audio OFF, or Listen, or Record.  The output of the audio switch goes to the PC audio input.  All audio paths are stereo.  The PC audio output goes to the mixer so I can use the headphones or the receiver to hear the speaker system.  There are jillions of audio cables involved in addition to a lot of midi cables.

I think I attached a pdf of the audio paths.  As you can see the mixer and the audio switch have central roles in how the system works.

-- Larry

Tape Switch - Mixer - Sound Card Wiring v3.pdf

Share this post


Link to post
Share on other sites

I would get a dedicate audio interface.  Always keep your signal chains simple stupid. Also, you need an audio interface from what im reading...

2 hours ago, larrymcg said:

All audio paths are stereo. 

This is bad! Trumpet /flugelhorn are mono and mics are mono, with a few exceptions. You need mono paths.

Listen, your weakest link is that you are using a Realteck integrated sound chip. There good for listening to Youtube and and other apps, but for audio production, they are not built for that. so you will always run into problems using it. Even if you solve this one, you'll run into another one very soon..

Share this post


Link to post
Share on other sites

+1 on the dedicated audio interface.

Integrated audio was never built for use with DAWs.

The drivers are not robust... and don't provide low-latency.

The audio inputs/outputs are also unbalanced (resulting in more noise).

Share this post


Link to post
Share on other sites
8 hours ago, larrymcg said:

Cactus Music,  I tried WASAPI (shared and exclusive).  Didn't help so I reverted to MME.  This got me a new issue - anything I play back (from Cakewalk or YouTube or FaceBook or my MP3s...)  has a very fast and strong reverb.  Totally obnoxious.  I can not find a setting to make it go away.

That means there's a feedback loop somewhere. Check your PC's mixer. It's probably set to Record What You Hear or something similar. Sorry I can't be more specific, the computer I'm using doesn't have an internal sound chip. 

  • Like 1

Share this post


Link to post
Share on other sites

"Unable to open audio record device. Device may not support the current project's audio format or may be in use."

In SONAR, and in CWbB as well I suppose, this message usually means that SONAR  and soundcard are set to different sample rates.

Share this post


Link to post
Share on other sites

For my first year or so with cakewalk I did not use an interface. It is possible.

The folks on this forum are mostly interface users because, well, it's better if you can afford it.

I think you can sort out your issue but it might take some fiddling.

Read Craig's post. I agree with him that you might have some routing situation that is causing two out of sync versions of the same sound to get routed to your outputs.

Share this post


Link to post
Share on other sites

I'm with the others here. Though for casual use an on board sound chip  can do just fine.  I would check what bit depth and sample Cakewalk is set to. Also you should run Wave Profiler,  its part of Cakewalk, to test your sound chip to see what it has to offer.  It may be that it can do 16 bit 48 kHz. Make sure that Cakewalk is set to what your sound card can handle.  They should be set the same. Normally on board sound chips will switch itself if it gets a signal change. If you also play videos those may be setting it to 24 48. 

A good interface like a USB with XLR inputs will set you back under $100 it will be very much worth it to you. Plus you wont need the mixer. 

I hope you can get this sorted out. 

 

 

Share this post


Link to post
Share on other sites

All of the audio paths are stereo - although the mic generates a mono signal, I have the mixer send the same signal to both channels but I typically record only one channel into the DAW.  The other sources (the synths) generate stereo signals. The audio card generates stereo and records stereo.

Craig's comment led me to finding that I had somehow enabled both the Line In and the Stereo Mix.  I turned off Stereo Mix and the reverb/loop effect disappeared.

The sampling rates for the sound card and Cakewalk are all 32 bit  44.1kH.  I've checked some of the projects and they are the same.

Wave Profiler shows two lists.  The first is MME Devices and shows a bunch of sampling rates as not available. That is followed by another list, also labeled MME Devices, with a bunch of sampling rates all being available.  For example: 44100 Hz: Channels 1,2 -- Bits 16,24,32 -- OK.  I have no idea what the first MME Devices list is for but the second one looks like I'd expect the sound card to handle.

I will check into an external interface.  I have never used one but on earlier PCs I have used an internal sound card (not built into MOBO). One advantage of an internal sound card is the ability to record whatever you are listening to - like something off the internet. Sometimes useful.

Thanks for all the help.  And I certainly got the message about a new sound card and appreciate the info provided by Cactus Music on the shopping list and Sweetwater audio interfaces.

Thanks,

Larry

Share this post


Link to post
Share on other sites

You can easily record material off the internet even with ASIO drivers. It just a matter of choosing a routing. 

And you can most certainly still use your on board sound for other apps. Most audio software lets you pick your sound source. 

I use Gold Wave to record sound from the internet webinars etc.  

I now subscribe to Google Play music and it lets you download in high quality any song on the planet.  I used to have to lift songs from the uTubes. 

The bottom line with on board sound is the chipset is worth about $6 including the little cheap jacks. 

It's a shame to put a lot of work into playing a part and run it through low quality gear. 

I still use WASAPI and an on board sound chip a lot with my laptop, but I'm only working with MIDI at that point. You can do a LOT with WASAPI, but you still require good quality connections and A/D convertors to record audio properly.

I would NEVER use MME mode. All modern on board chips support WDM and WASAPI. I'm not sure why it did not work for you. I used to use asio4all which is also a very good "on board sound" driver but WASAPI made it obsolete. Below is a screen shot of a loop back test. It clearly shows why ASIO works best for recording overdubs. Other mode will be out of sync and require manual offset adjustment. You can see that MME mode is the worst. 

1155408333_MainDAWloopback.jpg.dcff8fca6aca3a8f34c0aee010b2c8bb.jpg

Share this post


Link to post
Share on other sites

FWIW I don't disable my internal sound card because sometimes I need to run multiple programs (e.g., ASIO audio program, Vegas, and a screen capture program). It's difficult (and often impossible) to aggregate interfaces with ASIO, but Windows' native drivers can do so. This means I can run some programs with Windows drivers, and the main program with ASIO. The internal sound card output goes into two inputs of the PreSonus 192 interface, which I can then monitor via the interface's associated mixer software.

Here's an article with more info on aggregating interfaces.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...