Jump to content
Angelo DiBraccio

Kontakt Audio output Names Incorrect in Cakewalk

Recommended Posts

Posted (edited)

Hi

The kontakt output names appear correctly in Cakewalk for outputs 1 through 5. 

Then from  output 6 onward, the Kontakt output names appear incorrectly in Cakewalk

This anomaly occurs every time in all version of Kontakt and all versions of Sonar and Bandlab Cakewalk.

The actually outputs work correctly in Sonar, with the correct numbered output putting the correct sounds, just the output names are wrong.

The problem doesn't occur with some other multi timbral  synths  like Omnisphere or Cakewalk TTS-1. 

Attached is screen shot.

Can anyone help me troubleshoot this problem?

Thank You 

 

 

 

8 Track names CW from Template.jpg

Edited by MusicMan123

Share this post


Link to post
Share on other sites

I have experienced that for years and years, and for the past 10 years or so, I have just limited each Kontakt instance to having no more than 4-5 loaded instruments, and that way I don't trigger the weirdness.

Perhaps there are others that can offer a solution - I have never been able to figure it out, so the above limiting approach works every time.  I have so much memory on my computer that I have zero issues by running however many Kontakt instances I need....

Bob Bone

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Once you make the changes, you need to save the  Kontakt Out mapping as the "Default" (Either All or VST), then close the project and reopen the project...the outputs should then show properly.  I tested in K4, K5 and K6 (appears the issue does not occur in K6, but if it crops up, this should work).

I am assuming that due to the "Dynamic" nature of creating and naming outputs, that unless the changes are "Saved" so to speak, that they do not translate properly...One of the many weird Kontakt things...

 

Peace,

 

Blindeddie

Edited by Blindeddie
  • Like 1

Share this post


Link to post
Share on other sites
13 minutes ago, Blindeddie said:

Once you make the changes, you need to save the  Kontakt Out mapping as the "Default" (Either All or VST), then close the project and reopen the project...the outputs should then show properly.  I tested in K4, K5 and K6 (appears the issue does not occur in K6, but if it crops up, this should work).

I am assuming that due to the "Dynamic" nature of creating and naming outputs, that unless the changes are "Saved" so to speak, that they do not translate properly...One of the many weird Kontakt things...

 

Peace,

 

Blindeddie

Thanks - I will check this out, though every instance is almost certainly going to have different loaded instruments,  so not sure how saving as the default would work, but I will find out when I get a chance to test it all out.

Bob Bone 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

It looks like you just have to have a default Saved (once) and you can change it per instance/project and the (without setting any changes as the default).

for example I opened an instance of K4 created 8 stereo outs and renamed them Out 1-8. Without saving that as a default, the out list in CbB looked wonky like the one shown above.  I saved as the default then reloaded the project and all was good.  I opened a new project, loaded K4 and the outputs were named as the default I had saved (out 1-8).  I   renamed the outs in the new project and everything looked perfect (without saving my changes as the default). saved the project and closed.  Reopened the first project and outs were still named out 1-8.  closed that project opened the second one (where I had renamed the outs) and the names I had changed for  the outs were reflected properly in CbB.

 

what I did not test was if any  out names in existing projects/instances were affected by  setting the default... I don't think they should as the default should only be applied to "New" instances of Kontakt... I think...🤔

I hope that makes sense.

 

Peace,

 

Blindeddie

Edited by Blindeddie
Additional Info
  • Like 2

Share this post


Link to post
Share on other sites

I got something similar in Addictive Drums 2 - which has mixed set of mono and stereo outs.

So made all outs mono first, then fixed up the interleave on those that are to be stereo, and removed leftovers.

Routed to a bus.

Saved it all as track template and never have to redo again.

You can load other kit presets, and maybe rename the Flex1-3 - and save that again.

Amazing timesaver Tracktemplates.

  • Like 1

Share this post


Link to post
Share on other sites
6 hours ago, Blindeddie said:

It looks like you just have to have a default Saved (once) and you can change it per instance/project and the (without setting any changes as the default).

for example I opened an instance of K4 created 8 stereo outs and renamed them Out 1-8. Without saving that as a default, the out list in CbB looked wonky like the one shown above.  I saved as the default then reloaded the project and all was good.  I opened a new project, loaded K4 and the outputs were named as the default I had saved (out 1-8).  I   renamed the outs in the new project and everything looked perfect (without saving my changes as the default). saved the project and closed.  Reopened the first project and outs were still named out 1-8.  closed that project opened the second one (where I had renamed the outs) and the names I had changed for  the outs were reflected properly in CbB.

 

what I did not test was if any  out names in existing projects/instances were affected by  setting the default... I don't think they should as the default should only be applied to "New" instances of Kontakt... I think...🤔

I hope that makes sense.

 

Peace,

 

Blindeddie

BEAUTY! :)

I will give it a whirl.  I do have the Engine option, in Kontakt's settings, set to distribute its workload among 16 cores, which is the max the setting allows. My CPU is an AMD Ryzen 1950x Threadripper, which has 32 cores, so spreading workload also figures into it all, so looking forward to the outputs finally working right on the names shown as audio track Inputs in CbB.

Bob Bone

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
On 4/17/2020 at 11:38 AM, Blindeddie said:

It looks like you just have to have a default Saved (once) and you can change it per instance/project and the (without setting any changes as the default).

for example I opened an instance of K4 created 8 stereo outs and renamed them Out 1-8. Without saving that as a default, the out list in CbB looked wonky like the one shown above.  I saved as the default then reloaded the project and all was good.  I opened a new project, loaded K4 and the outputs were named as the default I had saved (out 1-8).  I   renamed the outs in the new project and everything looked perfect (without saving my changes as the default). saved the project and closed.  Reopened the first project and outs were still named out 1-8.  closed that project opened the second one (where I had renamed the outs) and the names I had changed for  the outs were reflected properly in CbB.

 

what I did not test was if any  out names in existing projects/instances were affected by  setting the default... I don't think they should as the default should only be applied to "New" instances of Kontakt... I think...🤔

I hope that makes sense.

 

Peace,

 

Blindeddie

Thank you. Saving an output setup as a default setup works perfectly.  The next time I open that output setup, all the output names are correct.

I looked into how to use Kontakt efficiently as far as resources (CPU and Ram usage) and many people recommend limiting the number of instruments (and thus outputs) per instance to between 4 and 8 and adding additional instances  as needed.

Considering how kontakt handles output names, the practice of saving a default output setups and Kontakt's resource  issues and also Bob  Bone's point that "every instance is almost certainly going to have different loaded instruments" which I feel the same way about, and that is that every project requires a different number of outputs. So I decided to use the following strategy in managing  outputs.

This is a middle ground strategy that is simple but has flexibility built into it .

I created an "8 output Cakewalk track Templates" in Cakewalk. I saved it as the default setup.  I loaded it after saving it as the default output setup and the output name are consistently correct.  This  seems like a good comprise as far as Kontakt resource use.  I can load the 8 output track template and then if I need more outputs I can simply load another 8 output track template.

If I need less outputs I can always load single instances of kontakt or my "4 output track track template". The "4 output track template" presents no output name problems because  the output name problems only occur with 6 or more outputs.  I simply need to follow the rule to never make these last two options, the single instances and the  "4 output track template" the default output setup in Kontakt's output section.

So from now on, after I install Kontakt, I will load my "8 output Cakewalk track Templates" and save it as the default and I'm all set.

Edited by Delta54321

Share this post


Link to post
Share on other sites

I had an issue which I thought was Cakewalk related but might be a Kontakt issue.  I say this because it happened in Studio One as well. In that DAW I had a template set up with all audio outputs in Kontakt addressed separately to individual instruments. I had like 14 instances of Kontakt in it with minimum of 8 instruments per instance.

Recording worked like a charm but when I attempted to freeze or unfreeze tracks the tracks seemingly changed places or relocated. A similar thing seems to have happened in the latest build of Cakewalk only I was running one instance of Kontakt per instrument for a total of maybe 5 instances. Unfreezing a track to work on the midi unfroze three tracks instead. Not only that but my audio had changed places too. I attributed this to the new Cake build since I haven't had a problem like this using Kontakt in individual per instrument instances in Cakewalk before. 

I really don't know what to make of it, but I suspect it might be related to the audio outputs in Kontakt. Delta I noticed the assigns in your example are not sequential on the problem tracks and you have auxes assigned. Not sure but maybe this is part of the problem? It seems easy to "double up" on outputs  IOW having two instruments sharing the same output so that when we freeze the tracks the audio gets misplaced or redirected.. not the kind of surprises I like.

  • Like 1

Share this post


Link to post
Share on other sites

There is a Kontakt setting under the Engine tab, that allows you to tell it how many CPU cores you have, it goes up to 16, though mine has 32, but it works fine set to 16.

Anyways, it helps Kontakt split up the workload among the multiple cores - and may help folks performance wise with large Kontakt instances.  I believe splitting things into multiple instances also splits work among the cores, but why not embrace both options?

Give it a whirl, and see if performance is improved.

Bob Bone

Share this post


Link to post
Share on other sites
2 hours ago, Robert Bone said:

There is a Kontakt setting under the Engine tab, that allows you to tell it how many CPU cores you have, it goes up to 16, though mine has 32, but it works fine set to 16.

Anyways, it helps Kontakt split up the workload among the multiple cores - and may help folks performance wise with large Kontakt instances.  I believe splitting things into multiple instances also splits work among the cores, but why not embrace both options?

Give it a whirl, and see if performance is improved.

Bob Bone

Yeah Bob. My engine setting in Kontakt  is set to the max,12, which sounds right.  I have a CoffeeLake six cores and 12 threads.  I didn't touch this setting. It selected 12 by default.

Share this post


Link to post
Share on other sites
Posted (edited)

Delta54321

Here a few screen shots to maybe help. The first shows the area you go into to change the audio outputs. The second shows an assigned instance of K6. You can even relabel the outputs.  When I made my instances I manually assigned them. There is a batch assign as well and I think the latest released build of Cakewalk made some nice changes for working with this. I plan to investigate those to see if it's easier to load and build multiple instances of Kontakt or any other multi.

k6.JPG

 

k5.JPG

Edited by Starise

Share this post


Link to post
Share on other sites
Posted (edited)

Which version of Cakewalk are you using?

When I attempt to duplicate your gif actions,

When first adding Kontakt as an instrument, on the left hand side I am offered Instrument Track per Output with Stereo Audio Outputs but on right hand side of same window I am not offered Number of Tracks to Create, and Limit Tracks to 

And I am not offered APPEND instrument track in Cakewalk dropdown after adding instrument in Kontakt.

Edited by Steve Harder
Correction

Share this post


Link to post
Share on other sites

And looks like you are on the early access 2020.04

So I think I answered my previous question.

Thanks for taking the time to put together the gif.

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...