Jump to content
Morten Saether

[CLOSED] Cakewalk 2020.04 Early Access 1

Recommended Posts

3 hours ago, Noel Borthwick said:

@Keith Lane you can save and load multiple arrangements within the same project. If you click the dropdown in the arrangements pane in the inspector you can create as many arrangements as you like. When you select one of them from the arrangements combo box it loads all the sections in that arrangement. Arrangements can duplicate or reference sections that exist in the section pool. 

arrangements.png

The coolest and most useful feature added in recent history! Cakewalk originally wasn't primarily recording software (though it's great it can now do that too! I'd to see VCA faders one day though :p) but music creation software . This feature honours Cakewalk's original purpose. And while it's primarily for composers and song writers, producers can also chop up songs or pieces for television and film!

Edited by Davydh
  • Like 1

Share this post


Link to post
Share on other sites

Hello.
I have a problem with the Repeater v.1.1.6 plugin. I have a version of the plugin from Slate Digital (maybe it does not differ from the original plugin from D16).
After loading this plug-in (or several plug-ins) after about 10 minutes, all parameters on the plug-in interface are frozen and cannot be changed. This happens in all Repeater plugins in the project. After rebooting Sonar and loading the project again, everything is fine, but after a short time the plug-in parameters freeze again.
In other DAWs, this is not a problem.
Has anyone had the same problem in Sonar?
I have Windows 10, Sonar version 2020.01.
Is version 2020.04 fixed this problem?

P.S.
I turned to the technical support D16. I was advised to clarify the plugin version (click the Options button while holding Ctrl key) and found that I have version 1.1.5!, although I installed version 1.1.6 on top of this version.
Now I uninstalled version 1.1.5, installed version 1.1.6 - everything works fine.
 

Edited by Maxim Vasilyev

Share this post


Link to post
Share on other sites

Just reporting in on the latest EA version - I worked on an existing project for around 4 hours yesterday doing lots of edits, Melodyne on vocals etc and it was rock solid.

Although the project was made before the Arranger was available it would have been much easier using the Arranger.
So, to test the functionality of the Arranger and improve my knowledge of it, I'm now making an "Arranger" version of the project.
If there are any issues I will report them here.  

  • Like 1

Share this post


Link to post
Share on other sites
17 minutes ago, Fabio said:

Bugs I found so far in the inspector view as attached.

That’s not a bug. You are using a User Theme that hasn’t yet been updated to CbB 2020.04. Switch to Mercury or Tungsten and the image will appear as expected.

Share this post


Link to post
Share on other sites
10 minutes ago, Canopus said:

That’s not a bug. You are using a User Theme that hasn’t yet been updated to CbB 2020.04. Switch to Mercury or Tungsten and the image will appear as expected.

You're right.

Share this post


Link to post
Share on other sites
14 hours ago, scook said:

I wonder if a separate "marker track" is in CbB's future.

This would be great!

I tested the Arranger a bit, but I am afraid to change something unexpectedly! Furthermore I have found out that there are some risks, so if you change the order of your song, you still have to manually handle "note overlaps", i.e. notes that start a tiny bit earlier then the section or those that do overlap the section a bit. Okay, you can do this with slip edit and cross-fades for audio tracks, but it is a lot of work if you have some of them. With MIDI tracks it is even worse, because some notes that were meant to be a part of the moved section stay at the old position, when their start is a tiny bit before the section's begin. If you have to set the beginning of the section earlier because of those reasons, then it gets much more complicated, too (and the manual audio clip fixing remains)!

Thus for me the Arranger is just a play tool in the early state of a song where all MIDI notes can be quantized and audio perfection is not yet the purpose. I think probably I prefer to use Ripple Edit for a "real" order change of an advanced song. Also I have not yet tested the Arranger with Vst instruments that need some "minus time" for their notes and it also comes to mind guitar/bass Vsti's where you define behaviour that must last over a section.

  • Like 4
  • Great Idea 1

Share this post


Link to post
Share on other sites
32 minutes ago, marled said:

 Furthermore I have found out that there are some risks, so if you change the order of your song, you still have to manually handle "note overlaps", i.e. notes that start a tiny bit earlier then the section or those that do overlap the section a bit.

I think probably I prefer to use Ripple Edit for a "real" order change of an advanced song.

When rearranging with Ripple Edit you have to manually handle overlaps as well... so the Arranger Track should be a quicker way to do more complex restructuring? Although it might be easier to be observant and "catch" all overlap problems if you do it as you go along while Ripple Editing...

Nevertheless, as you said it'll be an amazing "play tool", and probably not just in early stages but also in later stages if some alternative ideas happen to come up.

There'll be no more: "Imagine that the break here builds up and climaxes to this part over HERE instead... like THIS! *trying frenetically to click at another point in the timeline at the exact right moment, but failing as usual to demonstrate the full extent of the greatness of said idea*" 😜

Edited by GreenLight
Added stuff.
  • Like 2

Share this post


Link to post
Share on other sites
2 hours ago, Fabio said:

Bugs I found so far in the inspector view as attached.1908100937_prochannelbug.thumb.png.fb4d6a259a092c3722b2be9244523391.png

This looks like you're using a custom theme. User themes will need to be updated to work with 2020.04.

Share this post


Link to post
Share on other sites

hi cakewalk-team, 

thank you very much.

Unfortunately I'm experiencing an error.

All worked fine. Then I've tried something with drum maps - I'm learning that feature at the moment - and now cakewalk crashes on creating a new project.

I worked my life as a senior software develeloper, so I am willing to contribute with test cases or whatever will help.

Please find a dump attached.

EDIT: I reinstalled the previous version, started, created an empty project. closed. installes the pre release again. all okay.

Best regards

Peter

Untitled_04132020_131703.dmp

Edited by Peter Stiens
  • Like 1

Share this post


Link to post
Share on other sites
14 hours ago, Noel Borthwick said:

@Keith Lane you can save and load multiple arrangements within the same project. If you click the dropdown in the arrangements pane in the inspector you can create as many arrangements as you like. When you select one of them from the arrangements combo box it loads all the sections in that arrangement. Arrangements can duplicate or reference sections that exist in the section pool. 

Ahhh, ok yes, so I can build a genre template with a of pre existing arrangements, so I can do what I want, though the sections part will get very full !

Share this post


Link to post
Share on other sites
On 4/11/2020 at 11:54 AM, Jean-Philippe ROGER said:

Hello,
I have a problem with the arrangements. I created 3 sections with only Addictives Drums 2 like Vsti.
I organize the sections in one arrangement in ABCB.
In playback of the arrangement, the sound of the first section plays well and then cuts off just before the start of the second, playback continues but without sound even in normal playback mode.
I have to open the project again to find the sound.


Thanks for your help.

@Jean-Philippe ROGER I am unable to reproduce this even with the project you sent. i.e not seeing audio stop playing.

Can you report back on some of your settings?

  • Audio Driver mode
  • Audio buffer size (latency)
  • MIDI Playback buffer size
  • Playback I/O buffer size (Sync and caching)

Also if you start playback normally on the transport from the beginning of the project does it play normally? 

Share this post


Link to post
Share on other sites
3 hours ago, marled said:

This would be great!

I tested the Arranger a bit, but I am afraid to change something unexpectedly! Furthermore I have found out that there are some risks, so if you change the order of your song, you still have to manually handle "note overlaps", i.e. notes that start a tiny bit earlier then the section or those that do overlap the section a bit. Okay, you can do this with slip edit and cross-fades for audio tracks, but it is a lot of work if you have some of them. With MIDI tracks it is even worse, because some notes that were meant to be a part of the moved section stay at the old position, when their start is a tiny bit before the section's begin. If you have to set the beginning of the section earlier because of those reasons, then it gets much more complicated, too (and the manual audio clip fixing remains)!

Thus for me the Arranger is just a play tool in the early state of a song where all MIDI notes can be quantized and audio perfection is not yet the purpose. I think probably I prefer to use Ripple Edit for a "real" order change of an advanced song. Also I have not yet tested the Arranger with Vst instruments that need some "minus time" for their notes and it also comes to mind guitar/bass Vsti's where you define behaviour that must last over a section.

We are working on a solution for overlapped notes across sections. @msmcleod already has something that improves this a lot.

  • Like 5
  • Thanks 1

Share this post


Link to post
Share on other sites
3 hours ago, GreenLight said:

When rearranging with Ripple Edit you have to manually handle overlaps as well...

Yes, but in this case I can open a new space and then work/copy track by track. Like that all is under control and less risk to miss something! 😉

Share this post


Link to post
Share on other sites
53 minutes ago, Noel Borthwick said:

@Jean-Philippe ROGER I am unable to reproduce this even with the project you sent. i.e not seeing audio stop playing.

Can you report back on some of your settings?

  • Audio Driver mode
  • Audio buffer size (latency)
  • MIDI Playback buffer size
  • Playback I/O buffer size (Sync and caching)

Also if you start playback normally on the transport from the beginning of the project does it play normally? 

@Noel Borthwick

  • Audio Driver mode : ASIO (VS-700 R)
  • Audio buffer size : 5,8 msec (256 samples)
  • MIDI Playback buffer size : 200 msec
  • Playback I/O buffer size : 128 (read), 128 (rec)

Playback works normally if i don't use arrangement for the read.
After to use of the arrangement reader, the normal playback start but without sound

Share this post


Link to post
Share on other sites

I reinstalled the previous version but now it crashes, too.

This only happens when creating an empty project. I still can open existing projects or create projects other than "empty".

Is there an "empty" template? Maybe this is corrupted?

 

Edited by Peter Stiens

Share this post


Link to post
Share on other sites
19 minutes ago, Jean-Philippe ROGER said:

@Noel Borthwick

  • Audio Driver mode : ASIO (VS-700 R)
  • Audio buffer size : 5,8 msec (256 samples)
  • MIDI Playback buffer size : 200 msec
  • Playback I/O buffer size : 128 (read), 128 (rec)

Playback works normally if i don't use arrangement for the read.
After to use of the arrangement reader, the normal playback start but without sound

I see a negative value in the arrangement reader, maybe this is the problem?

image.thumb.png.797a22723e181ddaf9267f66c99c8037.png

Share this post


Link to post
Share on other sites
On 4/9/2020 at 2:38 PM, Morten Saether said:

Enable/Disable Enhanced Keyboard Editing Mode shortcut is unassigned by default.

  • The default keyboard shortcut (0 on the numeric keypad) to enable/disable Enhanced Keyboard Editing Mode has been removed. To enable/disable Enhanced Keyboard Editing Mode, go to Edit > Preferences > Customization - Keyboard Shortcuts and assign Enhanced Keyboard Editing to an unused keyboard shortcut.

Wow!  Thank you!! Can't help but feel I played a tiny part in this!

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
45 minutes ago, winkpain said:

Wow!  Thank you!! Can't help but feel I played a tiny part in this!

I just read your thread about it from last month, what a ruckus you had! 😱 What IS that Enhanced Keyboard Editing Mode anyway? (I read the manual but still don't really get it.)

If Cakewalk had had an on/off indicator for that mode, it would have been easier for you to troubleshoot.

(In fact, I believe Cakewalk needs more indicators for features that are a bit tucked away: when any track(s) are hidden, when auto preview and looping is enabled in the browser, for example.)

Edit: I just checked my own bindings: I've had "Solo all selected tracks" on Num 0 for years myself...

Edited by GreenLight
Added stuff.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...