Jump to content
Morten Saether

[CLOSED] Cakewalk 2020.04 Early Access 1

Recommended Posts

I have in this update display error when inserting synthesizer. (German Version).

CbB2020.04.jpg

Share this post


Link to post
Share on other sites
Posted (edited)
38 minutes ago, Harry C. said:

I have in this update display error when inserting synthesizer. (German Version).

CbB2020.04.jpg

Same problem with French Version.

Capture.PNG

Edited by Jean-Philippe ROGER

Share this post


Link to post
Share on other sites
46 minutes ago, Harry C. said:

I have in this update display error when inserting synthesizer. (German Version).

Localization is not complete in the Early Access build. This will be addressed before the final release.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Morten Saether said:

Localization is not complete in the Early Access build. This will be addressed before the final release.

I think you should put that disclaimer up front with every EA download link, to save you some time. :)

Share this post


Link to post
Share on other sites
On 4/13/2020 at 3:37 PM, RBH said:

Noel - I've done what I can to  update all video drivers. I can't seem to find any other way to witness a crash outside of the EA install. I've also performed a couple of restore points to see if anything recent could be causing this. It seems consistent that this crash only appears after the EA install. The prior versions utilizing both existing and new basic template projects doesn't produce this. The EA utilizing existing and new  basic template project loads produces the crash. Not sure what to try from this point.  I'm hoping that the official roll out will also allow rolling back to 2020-01 version if it doesn't work?  I've done probably 3 installs and 2 roll backs of the Early access install.

@RBH I tried to contact you today by PM but didn't get any response. To get further with this we need to do some diagnosis on your system since we cannot repro on any Windows 7 systems we have. It appears to be system specific. I was able to extract some further information from the minidump which appears to indicate that the crash is triggered by Intel IPP software that is used by Cakewalk. See the stack below. When does it crash for you -  On app startup itself, when opening a specific project or when opening a blank template?

This could be caused by incompatible components. Keep in mind that other vendors are also not testing Win7 so it could be something else indirectly triggering the crash. I realize that everyone has their own constraints but please stop using Win7 asap.

 X64_APPLICATION_FAULT_NULL_POINTER_READ_INVALID_POINTER_READ_d3d11!CCreateDeviceCache::CUMDAdapterCache::Load+bc

 

Quote

STACK_TEXT:  
00000000`0012cb10 000007fe`e973e053 : 00000000`00000003 000007fe`e973df07 00000000`0012d570 00000000`0012cde0 : d3d11!CCreateDeviceCache::CUMDAdapterCache::Load+0xbc
00000000`0012cd80 000007fe`e973f3fb : 00000000`00000000 00000000`0012cf70 00000000`00000000 00000000`00000005 : d3d11!CCreateDeviceCache::CAdapterCache::ResolveUMDAndVersion+0x127
00000000`0012ce10 000007fe`e974047b : 00000000`00000000 00000000`77cfd444 00000000`00000000 000007fe`00000000 : d3d11!D3D11CoreCreateDevice+0x54b
00000000`0012d670 000007fe`e97400ec : 00000000`00000000 000007fe`fde16c2c 00000000`00000000 00000000`0012da00 : d3d11!D3D11CreateDeviceAndSwapChain+0x383
00000000`0012d990 000007fe`e1fd2d90 : 00000000`00000007 000007fe`e9740090 00000000`00000000 00000000`00000000 : d3d11!D3D11CreateDevice+0x5c
00000000`0012da00 000007fe`e1ee17a5 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00250274 : d2d1!Displays::CreateDevice+0x17c
00000000`0012dab0 000007fe`e1ee0ce1 : 00000000`00000000 00000000`00000001 00000000`00000000 00000000`00000030 : d2d1!CD3DDeviceManager::CreateNewDevice+0xfd
00000000`0012dc90 000007fe`e1ee0fe3 : 00000000`00000000 00000000`00000000 00000000`004b20d0 00000000`00000001 : d2d1!CD3DDeviceManager::GetDeviceFromParameters+0x79
00000000`0012dd00 000007fe`e1ec6cb4 : 00000000`00000000 00000000`0012dda0 00000000`0012deb8 00000000`000716b8 : d2d1!CD3DDeviceManager::GetD3DDevice+0x77
00000000`0012dd50 000007fe`e1ec70e4 : 00000000`004b2080 00000000`1efa0cf8 00000000`00000000 000007fe`e1fa76b5 : d2d1!CDefaultRenderTargetFactory::GetInitialD2DDevice+0x58
00000000`0012dde0 000007fe`e1ec6bf4 : 00000000`00000000 00000000`004b2080 00000000`00000001 00000000`00000000 : d2d1!CDCRenderTargetFactory::CreateHardwareTarget+0x48
00000000`0012de70 000007fe`e1eac172 : 00000000`004cc9e0 00000000`004cc8d8 00000000`004cc968 000007fe`e9fc70ee : d2d1!CDefaultRenderTargetFactory::Create+0x17c
00000000`0012df30 00000001`4031bf44 : 00000000`004b2080 00000000`00001f01 00000000`1cf454f8 00000000`00000000 : d2d1!D2DFactory::CreateDCRenderTarget+0x166
00000000`0012e050 00000001`412dc356 : 00000000`1d0d00d0 00000000`1d0d00d0 00000000`ffffffff 00000000`00000013 : Cakewalk!l9_ippsCos_64f_A53+0x1a2a14
00000000`0012e130 00000001`412dc893 : 00000000`1d0d00d0 00000000`0012e1e0 00000000`00000030 00000000`1cf454e0 : Cakewalk!l9_ippsCos_64f_A53+0x1162e26
00000000`0012e1b0 00000001`41384ef8 : 00000000`1d0d00d0 00000000`77ce7b14 00000000`0012e2e8 00000000`1d0d00d0 : Cakewalk!l9_ippsCos_64f_A53+0x1163363
00000000`0012e210 00000001`413856b8 : 00000000`0012e458 00000000`0db83040 00000000`00001944 00000000`0012e2e8 : Cakewalk!l9_ippsCos_64f_A53+0x120b9c8
00000000`0012e250 00000001`4031a259 : 00000000`1d05a5f0 00000000`1d05a5f0 00000000`0012e309 00000000`1d0d00d0 : Cakewalk!l9_ippsCos_64f_A53+0x120c188
00000000`0012e290 00000001`412e351a : ffffffff`ffffffe0 00000000`0012e3c0 00000000`0012e458 00000001`00000000 : Cakewalk!l9_ippsCos_64f_A53+0x1a0d29
00000000`0012e370 00000001`412e2cc5 : 00000000`41800000 00000000`00000000 00000000`0dfb7558 00000000`0012e458 : Cakewalk!l9_ippsCos_64f_A53+0x1169fea
00000000`0012e3c0 00000001`413314c9 : 00000000`0000000a 00000000`1d059b19 00000000`00000000 00000000`00000000 : Cakewalk!l9_ippsCos_64f_A53+0x1169795
00000000`0012e3f0 00000001`4022f3a1 : 00000000`0dfb6ff0 00000000`0dfb7558 00000000`ffffffff 00000000`0012e520 : Cakewalk!l9_ippsCos_64f_A53+0x11b7f99
00000000`0012e420 00000001`40216f81 : 00000000`00000001 00000000`0dfb6ff0 00000000`1d05a530 00000000`1d059f00 : Cakewalk!l9_ippsCos_64f_A53+0xb5e71
00000000`0012e570 00000001`40386313 : 00000000`0012e648 00000000`00000103 00000000`00000000 00000000`0000018d : Cakewalk!l9_ippsCos_64f_A53+0x9da51
00000000`0012e5d0 00000000`77d116b2 : 000002b2`000000e0 46000000`000000e0 00000000`c0000080 00000000`00000000 : Cakewalk!l9_ippsCos_64f_A53+0x20cde3
00000000`0012e660 00000000`77aa5bba : 00000000`1d12d2e0 00000000`ffffffff 00000000`0dfb70a0 00000000`00000000 : ntdll!RtlRunOnceExecuteOnce+0xa2
00000000`0012e6a0 000007fe`edc16d2f : ffffffff`fffffffe 00000000`77ce7b14 00000000`00000000 00000000`00000000 : kernel32!InitOnceExecuteOnce+0xa
00000000`0012e6d0 ffffffff`fffffffe : 00000000`77ce7b14 00000000`00000000 00000000`00000000 00000000`ffffffff : msvcp140!__crtInitOnceExecuteOnce+0x3f
00000000`0012e6d8 00000000`77ce7b14 : 00000000`00000000 00000000`00000000 00000000`ffffffff 00000000`00000000 : 0xffffffff`fffffffe
00000000`0012e6e0 00000000`0dfb6ff0 : 00000000`0012e898 00000001`402cebe1 00000000`1d198270 00000000`00000000 : ntdll!RtlAllocateHeap+0xe4
00000000`0012e7f0 00000000`0012e898 : 00000001`402cebe1 00000000`1d198270 00000000`00000000 ffffffff`fffffffe : 0xdfb6ff0
00000000`0012e7f8 00000001`402cebe1 : 00000000`1d198270 00000000`00000000 ffffffff`fffffffe 00000000`00000000 : 0x12e898
00000000`0012e800 00000000`00000000 : 00000000`00000000 00000000`00000000 00000001`40230050 00000000`0012ea60 : Cakewalk!l9_ippsCos_64f_A53+0x1556b1

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

I've been experimenting & there appear to be some serious issues with VST plugin parameter automation when the VST plugins are on a bus channel.

- Automation recorded via 'Automation Write  = enabled' & tweaking in the VST plugin UI, cannot be viewed in individual lanes by pressing the 'Automation Lanes = On' button.

- Automation recorded or entered manually is not played back (/sent) to the plugin, when the project is played.

 

Edited by foldaway

Share this post


Link to post
Share on other sites
Posted (edited)

I'm not sure if this is a consistent problem with all users, but I still have the issue with Ripple Edit  mentioned with the 2020.1 release as discussed here...

Additional details are that when using the full PRV view and attempting to copy/paste, drag/copy, or duplicate notes with Ripple Edit engaged that status does not take effect - i.e. existing notes just get pasted on top of rather than sliding over, "ripple-style".  Performing the same edit (on the exact same notes on the same track) in the inline PRV (or with clips), however, the behavior is as expected with Ripple Edit functioning accordingly with notes sliding over accommodating the copy function.

@msmcleod  we had exchanged over this a bit. I wonder if it's still on the radar...

Edited by winkpain

Share this post


Link to post
Share on other sites
On 4/14/2020 at 2:50 AM, Max Arwood said:

I have not noticed that with older projects. Are they edited with the track arranger? Or just opened and exported?

Max Arwood

No. I was working on two projects before updating to the new version, messed around with the arranger trying to find some good use for it, (which it has, If you do EDM. By the way, isn't the matrix similliar as the arranger?) but I haven't touch any of the settings. Just thrown some loops in and arrange it to my taste. A day later I'd open an old project (Week old.) and that happened. Tried about four times thinking I haven't selected any of the tracks, same story. Just the effects that you hear on the song -  Like all the channels were muted, that you only hear the effects on your bus channels . . . 😕. Luckily for me, the rollback setup came in handy.

Share this post


Link to post
Share on other sites
3 hours ago, Noel Borthwick said:

@RBH I tried to contact you today by PM but didn't get any response. To get further with this we need to do some diagnosis on your system since we cannot repro on any Windows 7 systems we have. It appears to be system specific. I was able to extract some further information from the minidump which appears to indicate that the crash is triggered by Intel IPP software that is used by Cakewalk. See the stack below. When does it crash for you -  On app startup itself, when opening a specific project or when opening a blank template?

This could be caused by incompatible components. Keep in mind that other vendors are also not testing Win7 so it could be something else indirectly triggering the crash. I realize that everyone has their own constraints but please stop using Win7 asap.

 X64_APPLICATION_FAULT_NULL_POINTER_READ_INVALID_POINTER_READ_d3d11!CCreateDeviceCache::CUMDAdapterCache::Load+bc

 

 

Hi Noel - Thanks for that - I did respond to your PM.  The crash occurs after project load - and the project appears to load normally. It also crashes at blank project load - after loading. I'm currently rolled back to 2020-01. Glad to make whatever arraignments I can for your inquiry.

Share this post


Link to post
Share on other sites

Is it possible that when you right click on the section bar in the arrangement track or the arrangement inspector that there can a "properties" entry at the bottom.

This can show things like duration (in H:M:S:F format)  Start and finish time (in H:M:S:F and M:B:T format). 

Share this post


Link to post
Share on other sites
Posted (edited)

Hi guys,

Another bug - although might not be specific to this release.

When I save track templates I experience a significant spike in both CPU  and memory utilisation (~4GB) and the save can take up-to a minute, locking up the PC.

Whilst the projects that i'm running are large - the individual tracks may only be a single audio track routed to a few busses and so shouldn't be that intensive.

I've seen the Kontakt module come up whilst doing this which leads me to believe that it's trying to preemptively save the VST's, which aren't related to the actual track.  It also is worsened within projects with a larger number of VST's.

Loading these tracks into a different project is quick and doesn't bring in anything it shouldn't.

Best wishes,
Matthew

 

Edited by Matthew Simon Fletcher

Share this post


Link to post
Share on other sites

Virus scanner maybe?

I add scanner exclusions for the DAW processes and where the DAW writes its data.

 

Share this post


Link to post
Share on other sites


Hi, thanks to the Bakers to 2020.04 Early Access update! It looks awesome!

I also would like to comment EA is avoiding me to watch streaming media on sites like Youtube and Soundcloud, where playback doesn't occur. To stop this issue I'll have to logout Windows (and login it again).
By the way I had a similar issue with Sony Vegas Studio, but I found out that changing Windows audio settings to 48 KHz before using it and going back to 44 KHz after that would do the trick. But I guess that was another scenario!

Best regards
 

Share this post


Link to post
Share on other sites

If Windows and CbB are sharing the same audio device make sure both are set to the sample rate.

 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, scook said:

Virus scanner maybe?

I add scanner exclusions for the DAW processes and where the DAW writes its data.

 

Should already be configured mate
 

Edited by Matthew Simon Fletcher

Share this post


Link to post
Share on other sites

Hi, scook! Yes, both are at the same sample rate. I had the impression this started with the new Early Acces update and I'll try to roll back to see if it works.

Thanks!

Share this post


Link to post
Share on other sites
On 4/15/2020 at 2:56 PM, Noel Borthwick said:

@RBH yes we plan on releasing rollback installers going forward with every release.

Will they rollback to the previous released version or the version that I had installed? For instance, I'm on 2019.09 ATM. If I install 2020.04 and decide to rollback will it rollback to 2020.01 (previous release) or 2019.09 (the one that I had)?

Share this post


Link to post
Share on other sites

@mgustavo please report back if this is new to EA. AFIK there are no changes to this.
Which release were you running prior to this?

Also what driver mode are you using?

Share this post


Link to post
Share on other sites
1 minute ago, Jan said:

Will they rollback to the previous released version or the version that I had installed? For instance, I'm on 2019.09 ATM. If I install 2020.04 and decide to rollback will it rollback to 2020.01 (previous release) or 2019.09 (the one that I had)?

Currently the rollback will only go to the immediately prior release.

Share this post


Link to post
Share on other sites

Congratulations Bakers, on this major feature update.

Would love to see a Chord Track / Pads / Assistant implemented.

  • Like 2

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...