Jump to content
  • 0
Sign in to follow this  
Michael McBroom

Changed from 16/44.1k to 24/48k then back. What a mess.

Question

I've been working on a project -- a 100% MIDI project, although I realize the synths have audio outs -- that started life set to 16 bits at 44.1k. Just a short while ago I decided that I'd like to bump up these settings, so I did -- to 24 bits at 48k. Well that made a hash of things. Totally distorted playback. So I went back in and looked around, found Utilities/Change Audio Format, and changed it to 24 bits. Checked my sound card, made sure it was reset to 48k. It was. Still  a heavily distorted playback. I've been using ASIO, not ASIO4ALL, by the way. I looked all over, through the Preferences settings and the drop down commands, couldn't find anything that might solve this problem. So I resigned myself to putting things back the way they were. Went back into Preferences and switched things back to 16/44.1k and then went to Utilities/Change Audio Format back to 16 bits. And I'm still getting the heavily distorted playback. I tried changing audio drivers. Tried all of them, didn't make any difference. So I shut down CbB, the rebooted and reloaded an earlier saved version of the file, where I'd been using it at 16/44.1k, and still I'm getting the distorted playback. So I decided to try another file that I'd worked on with the 16/44.1k setting and it too is playing back all distorted. Oh, and I double checked my sound card, made sure it was reset to 44.1k -- it was.

So obviously I have something set wonky somewhere, but I don't know where. Anybody want to tell me what I've over looked?

Also, for future reference -- I'm thinking there has to be a way to change the audio format to a piece of music without going through what I'm going through right now. What's the secret? How do I change a file's audio format from 16/44.1k to, say, 24/48k, without encountering the mess that I have? I can see how it might be more problematic if it were an audio file, but this is MIDI. Conversely, when it comes time to record to CD, can I reverse this procedure to get back to 16/44.1k?

Oh and by the way, I loaded the file up in SPlat and it plays back just fine at 16/44.1k. So at least I can continue to work on this and other pieces until I can fix the mess I made of CbB.

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

If a project contains no audio clips, the sample rate is read from preferences. Only when a project contains an audio clip does a project sample rate get set.

The Change Audio Format dialog modifies existing audio data in the project. As a rule this is not necessary. While all the audio in a project must be the same sample rate, projects can contain audio at different bit depths.

Changing the Record Bit Depth is all that is needed to change project bit depth. Record Bit Depth is a global setting that affects all future recordings in all projects. As a rule, this value should be set to the  audio driver bit depth.

Share this post


Link to post
Share on other sites
  • 0

The bit depth/width/sample size can be mixed for different tracks. If you recorded at a lower sample size, then increasing the sample size just adds zeros and gives you no more information. If you go from a higher sample size to a lower one, you will lose information, and additionally may introduce some quantization errors.

The sampling rate (sometimes incorrectly called the bit rate*) is not something that can be changed by a simple operation in Cakewalk, and has to be the same for all audio in the project. It is set in preferences but changed automatically when the first audio is imported or produced. Thereafter any new audio that is imported is automatically re-sampled to the project sample rate. The simplest option if you have a lot of audio that needs re-sampling is to close the project, then batch process all of the audio files for the project using an application like R8Brain, then re-open the project.

https://www.voxengo.com/product/r8brain/

* The bit rate is the rate at which bits are transferred in a process. The sampling rate is the rate at which samples, consisting of various numbers of bits each (the sample size) are recorded and obviously the same rate should be used to play back the samples to reconstruct the sound.

 

Edited by slartabartfast

Share this post


Link to post
Share on other sites
  • 0

Thanks for the feedback, guys. I had to stumble around a bit before I found the aud.ini file, but sure enough, getting rid of it cured my problem. Thanks for that tip, Jim!

Regarding the rest of your info, I've  been pretty much following the method of making sure all the bit rates are in agreement. I've always just figured that made for good practice. Only time I've run into issues has been when I've loaded up an old file from stuff I'd written years ago where the bit rate might not have been in agreement. But as I recall, it wasn't an issue once I had the bit rates set to the same value.

Slartabartfast, thanks for the link to r8brain. As I dimly recall, the CD burning utility I use contains a conversion routine that worked for me in the past. But I reckon it won't hurt any having that utility.

I recognize your name from somewhere -- kind of a hard one to forget. It would have been some forum from some years back. Do you build guitars? Maybe from a luthier forum? No wait -- were you on the old XS650 mailing list?

Edited by Michael McBroom

Share this post


Link to post
Share on other sites
  • 0

When changing sample rates, do not forget to change Windows audio properties to match the settings you have changed in CbB and your interface GUI. 

Share this post


Link to post
Share on other sites
  • 0

There's one problem with converting the sample rate of audio files outside of CbB that was pointed out to me when I suggested this solution in the past.  The  length of the audio clip in samples is stored in the project, so when it reads in data from a higher sample rate file, the clip will be truncated to the original number of samples, and there's no way to get the clip to reference the entire file, short of importing it at the new rate. 

Share this post


Link to post
Share on other sites
  • 0
3 minutes ago, David Baay said:

There's one problem with converting the sample rate of audio files outside of CbB that was pointed out to me when I suggested this solution in the past.  The  length of the audio clip in samples is stored in the project, so when it reads in data from a higher sample rate file, the clip will be truncated to the original number of samples, and there's no way to get the clip to reference the entire file, short of importing it at the new rate. 

If the wave file have exactly same name, Cakewalk should show a dialog box saying that the file has a different lenght now, and then you can accept the change or deny importing it. It's crucial to know exactly what you're doing in that situation or one can cause a mess in his project.

Share this post


Link to post
Share on other sites
  • 0
30 minutes ago, chris.r said:

If the wave file have exactly same name, Cakewalk should show a dialog box saying that the file has a different lenght now, and then you can accept the change or deny importing it. It's crucial to know exactly what you're doing in that situation or one can cause a mess in his project.

I think you must be thinking of a different DAW or different situation in CbB. I just double-checked, thinking something might have changed since I last tried it, but there was no prompt about the length. The project opened with no complaints, but the audio is truncated as described. The clip runs 4 measures, but audio is a flat line for about the last five 16ths  of the last measure (44.1/48 * 4:01:000 > 3:03:672).

Edited by David Baay

Share this post


Link to post
Share on other sites
  • 0
On 2/6/2019 at 9:16 PM, David Baay said:

I think you must be thinking of a different DAW or different situation in CbB...

True, looks like I was too quick with my response. Next time I'll make a coffee before answering and actually drink it first :D.

Just checked again, the situation I was talking about is when the wave file has same length but different name so... absolute opposite 🙃.

WcJq7qJ.jpg

I have then tried to expand the clip in project and save, but after changing length of the wave file in wavelab, Sonar imported it with previously saved length regardless the longer clip, you were right.

In my test, using wav files with the same sample and bit rate, if you change the length of a wav file outside cakewalk, then on re-opening the project, if the wav file is longer than previously, then it gets truncated, if it's shorter then cakewalk will fill gap with a silence. After changing the sample rate cakewalk truncated the length. Shame.

So looks like Cakewalk doesn't allow to simply change the sample rate of waves files, you have to create new project and import newly converted files into it. At least it only worked that way here.

Edited by chris.r

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...