Jump to content
  • 1
bgewin

Dropouts & stutters -- New problem after upgrade

Question

EDIT 2020, Mar 8. The setting changes below seem to be working. If you're having the same problem and reading this, see if these changes help you. 

I'd like to add my name to the list of those complaining about dropouts after recent cakewalk updates. I can take a cwp file and play it flawlessly over and over again in Sonar X3e. The same project hiccups, stutters and stops in Cakewalk Bandlab. 

When it happens, I notice that all 12 cores (my cpu has 6 cores that can handle 2 threads each) seem to max out for a second on the performance monitor. 

Flattening multiple takes and rendering Melodyne clips seems to help, but only modestly.

I did the following:
- raised my DropoutMSec from 250 to 750, but the immediate result was stuttering rather than dropping out entirely.
- raised ExtraPluginBufs to 4 (is there any negative consequence to this?).
- raised ThreadSchedulingModel from 0 to 2. I noticed that Buffers In Playback Queue  (Preferences==>Audio==>Driver Settings) is stuck at 2; I can't raise that value.
- raised my buffer size to 2048,
- checked the Safe Mode box under Preferences==>Audio==>Driver Settings==>ASIO Panel 
- I also changed Preferences==>Midi==>Playback & recording==>Playback==>Prepare Using ___ Ms Buffers to 500. 

I ran the last two Cakewalk updates pretty close together, so I can't say if it was the most recent update or the prior one. I updated my Beheringer X32r driver to the most recent (4.59) and I'm running CWB 2020.01, build 28. 

I also should mention that I removed a Session Drummer soft synth in an effort to clean up the project. I don't know if it helped or not as (unfortunately) I didn't try my experiments one-at-a-time. 

Thanks so much,

Billy

 

Edited by bgewin
Add'l information.

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0
4 hours ago, David Baay said:

Back up CbB's AUD.INI, and copy X3's over it. If it solves the problem, compare the files.

I don't have the X3e file and I'm suffering the same issue as bgewin. Do you have a copy of this file that you could attach to one of your post?

Share this post


Link to post
Share on other sites
  • 0

Malcom, you can click the Reset Configuration button under Preferences > Audio > Configuration File to get back to  default configuration that should work... if audio configuration is the issue. I specifically suggested it for the OP since he said his X3 config was working, and Platinum should be able to use that same config. But it may not be right for you, depending on the driver mode you're running. If you haven't already, you should start a dedicated thread for your particular case, and let us know what hardware you're running with what audio settings.

 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
On 3/2/2020 at 4:41 AM, Malcolm MacFarlane said:

I don't have the X3e file and I'm suffering the same issue as bgewin. Do you have a copy of this file that you could attach to one of your post?

Take a look at my original post -- I added some setting info there (including a midi playback buffer setting) that I think helped me -- it was the last setting I changed. I'm using Pianoteq in my project. 

Share this post


Link to post
Share on other sites
  • 0

FWIW, I recently discovered that my crummy dual-core laptop - which I use mostly just for referencing Cakewalk behavior and menus when posting to the forum  - does not perform well with the 'Agressive' ThreadSchedulingModel=3 set in AUD.INI (Preferences > Audio > Configuration File). I don't think this is the default (?), but the new  option 3 was just introduced in the last release, and some users may have deliberately changed from 1 or 2 to 3 and promptly forgotten about it rather than checking to see how it worked as suggested in the release notes:

"Experimental aggressive task scheduling model

We continue to work on improving our multi-threaded engine performance and have added a new "aggressive" task scheduling model. The aggressive task scheduler utilizes more efficient task management that can result in better multi-processing and fewer thread context switches. This feature is still experimental so report back if you notice any improvements or problems when using it."

Share this post


Link to post
Share on other sites
  • 0
On 3/17/2020 at 6:30 PM, David Baay said:

FWIW, I recently discovered that my crummy dual-core laptop - which I use mostly just for referencing Cakewalk behavior and menus when posting to the forum  - does not perform well with the 'Agressive' ThreadSchedulingModel=3 set in AUD.INI (Preferences > Audio > Configuration File). I don't think this is the default (?), but the new  option 3 was just introduced in the last release, and some users may have deliberately changed from 1 or 2 to 3 and promptly forgotten about it rather than checking to see how it worked as suggested in the release notes:

"Experimental aggressive task scheduling model

We continue to work on improving our multi-threaded engine performance and have added a new "aggressive" task scheduling model. The aggressive task scheduler utilizes more efficient task management that can result in better multi-processing and fewer thread context switches. This feature is still experimental so report back if you notice any improvements or problems when using it."

I have ThreadSchedulingModel=2, which is the middle value, and that works well, for me.

In Preferences > Audio> Sync and Caching, I also have both the Playback and the Record I/O Buffer sizes set to 512 KB.

@bgewin, have you evaluated performance with the loaded plugins temporarily bypassed? (hitting 'E' on your computer keyboard toggles effects bypassing On/Off)

Do you have your Cakewalk Projects folder and any sample library folders Excluded/Exempted from your antivirus software? (if not, I suggest you do that).

Bob Bone

 

Share this post


Link to post
Share on other sites
  • 0

I have just installed cakewalk. I've done all the setup but when i am opening a project it's giving an error of audio engine dropout and its showing a loading symbol all over i tried to change my ASIO buffer size but it's not changing. It's all grey out. I have just installed it so i don't know much about it. Anyone can help me with that? I have a laptop with specs 

Core i3 7th gen

1TB HDD

4 gb ram

Integrated graphics

Is that specs ok tu use cakewalk?

 

Edited by Akshay Rokade

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...