Jump to content
kevmsmith81

Audio dropouts making Cakewalk unusable.

Recommended Posts

39 minutes ago, Robert Bone said:

I am off to doc, wll check back in 3-4 hours

I won't be able to try until much later.  I won't be at my computer for at least another 6 hours or so.  :)

Share this post


Link to post
Share on other sites
1 hour ago, kevmsmith81 said:

it was working fine until the most recent Cakewalk updates. 

<begin lecture>

While it's possible something directly related to the update precipitated the problem, I feel compelled to point out that since Cakewalk is updated every month, the last update is pretty much always "recent".  And there have been numerous of users attibuting a problem to a Cakewalk update, and then eventually discovering something else changed in their system or Cakewalk or project configuration. Back when SONAR was updated anually, the incidence of 'was working fine until today' being reported randomly between updates was not significantly lower than it is now. Also, just because a performance issue isn't reproducible in another DAW doesn't rule out that the root of the problem is in the environment or a setting in Cakewalk that's been changed independently of an update. 

<end lecture>

Since dropouts are very often related to DPC spikes, I would start by running a DPC latency check:  https://www.resplendence.com/latencymon

If that checks out, try clicking the Reset Config button under Preferences > Audio > Configuration File. Cakewalk will archive a backup of the current AUD.INI, and replace it with a default. If performance improves, you can compare the default to the backup to see what changed.

  • Like 2

Share this post


Link to post
Share on other sites

the op did state that the same driver settings and similar project in another daw did not show these issues 🤔

Share this post


Link to post
Share on other sites
22 minutes ago, pwalpwal said:

the op did state that the same driver settings and similar project in another daw did not show these issues 🤔

That said, the link provided in David's post is something I was not aware of and could be a useful tool.

However, given I could import the same stems into Reaper, stick the same plugins on and would not get dropouts.  I've also done the same with Harrison Mixbus 32c, which has EQ's, compressors etc running by default all the time due to the way that is set up and also not get dropouts, so I can't help but think that the issue very much lies with Cakewalk.

I should also point out that I am not trying to claim Cakewalk is bad, seeing how some people have been very quick to leap to its defence and assume it must be user error.  I repeat, I want to use Cakewalk - I was a SONAR user for a good few years before Gibson binned it off and  have always been very happy with the workflow.  However, these issues are currently making Cakewalk unusable for me.  I cannot complete a 4 minute vocal take or guitar take without getting a dropout.

Share this post


Link to post
Share on other sites
1 minute ago, kevmsmith81 said:

some people have been very quick to leap to its defence and assume it must be user error

that's not unusual and should be taken with a pinch of salt

Share this post


Link to post
Share on other sites

If nothing has changed other than the executable's replacement, then it's perfectly reasonable to assume the problem lies there.

However, it's very common for users to assume nothing else has changed and be wrong about that. If you're recording a new project, then lots of things have changed. Do previous projects play without dropouts? Or does the problem only appear while recording new audio?

To answer the original question, no, I have not experienced any dropouts over the past 20 or so (including beta releases) updates. However, I keep my ASIO buffer size at 2048 and almost never change it, so I'm pretty much immune to buffer underruns under normal circumstances.

Share this post


Link to post
Share on other sites

 As I said, it may well be due to some incidental config change. But there can also be changes in the environment that affect a feature of Cakewalk that other DAWs don't have like plugin load balancing/upsampling, 64-bit double-precision engine , etc.

Or this, which I believe is not enabled by default; possibly you did this...?:

Experimental aggressive task scheduling model

We continue to work on improving our multi-threaded engine performance and have added a new "aggressive" task scheduling model. The aggressive task scheduler utilizes more efficient task management that can result in better multi-processing and fewer thread context switches. This feature is still experimental so report back if you notice any improvements or problems when using it.

The new scheduling model is activated by setting the ThreadSchedulingModel value to 3. This can be done via Edit > Preferences > Audio - Configuration File. 

 

Share this post


Link to post
Share on other sites

Cakewalk is consistently the worst at handling audio data flow amongst all my DAWs.  It clicks and pops and overloads consistently on mid-loaded projects that do just fine in Samplitude, Sequoia, Reaper, ProTools, FL Studio and Nuendo.  To have to adjust buffers over 128 asks for intolerable latency with soft-synths and direct monitoring.  I'm not saying that this isn't something in this particular case that will be figured out, but I am saying that Cakewalk and Sonar have always been the worst at handling audio flow.  I've been with Cakewalk since the eighties.

Share this post


Link to post
Share on other sites
17 minutes ago, Jon White said:

Cakewalk is consistently the worst at handling audio data flow amongst all my DAWs.  It clicks and pops and overloads consistently on mid-loaded projects that do just fine in Samplitude, Sequoia, Reaper, ProTools, FL Studio and Nuendo.  To have to adjust buffers over 128 asks for intolerable latency with soft-synths and direct monitoring.  I'm not saying that this isn't something in this particular case that will be figured out, but I am saying that Cakewalk and Sonar have always been the worst at handling audio flow.  I've been with Cakewalk since the eighties.

I'm just glad to have an alternative I can go to. I will try the suggestions people have provided when I'm at my computer but it is frustrating to deal with this issue. 

Share this post


Link to post
Share on other sites
13 hours ago, kevmsmith81 said:

EDIT:  Just for reference, my machine is a laptop running Windows 10 with a Ryzen 5 2500U CPU and 16GB RAM

Try checking that your Windows power scheme is set to "Performance".

That is a mobile processor and the default is probably balanced or something like that. If so that would be trying to conserve power at the expense of performance.

Share this post


Link to post
Share on other sites
4 minutes ago, abacab said:

Try checking that your Windows power scheme is set to "Performance".

That is a mobile processor and the default is probably balanced or something like that. If so that would be trying to conserve power at the expense of performance.

Thanks for tip - this is the first thing I do every time I power on a new laptop for the first time, as I always have it plugged in anyway. :)

Share this post


Link to post
Share on other sites

FWIW, I have been experiencing dropouts since the update before this last one.  If I shut off my wi fi and antivirus the dropouts are minimal (Just happen occasionally). I never used to have to shut wi fi or antivirus off. I have no problems with dropouts in Studio One 4. 

Share this post


Link to post
Share on other sites

I wonder what you guys have in common.

I presume all of you are passing in Latency Monitor 

Lots of us are working fine. I'm running with at 3.1 to 3.8 millisecond round trip without issues.

I can't help wondering if we don't need to get back to basics and do the traditional trouble shooting.

  • Great Idea 1

Share this post


Link to post
Share on other sites

I have an older I7 but still - I am having to freeze everything.   My latency set at  2048.  I have recently moved to Win10.  I fell like I lost some processing power in the upgrade.  I have turned off everything I could think of.   I wish we could have an "official" statement of tweaks. I wish it would have  a few levels - These will help, These will help more, and - If you are desperate for horsepower try these.

Also - we have had tons of great  bug fixes - but now it might be time to put some resources toward performance.

I can hardly play any projects with ThreadSchedulingModel value set to 3.

Thanks,

Max Arwood

 

  • Great Idea 1

Share this post


Link to post
Share on other sites

LatencyMon after 40 minutes of web browsing with ~30 tabs open in Chrome -  including watching Geoff's video about it -  while Cakewalk ran at 30-40% load in the background, looping the old 'These Arms' demo, which is pretty 'heavy', at 64 samples. Cakewalk Perf Monitor reported 1 buffer dropped... when I stopped playback. DPC latency typically runs under 100us on this machine if I disable WIFI. Off-the-shelf Dell i7 6700k with power management and CPU throttling disabled:

125169015_LatencyMonat40MinutesofBrowsingandLoopingTheseArmsat64Samples.thumb.png.82a6648affd67bb12eba815f69cd0ece.png

 

Edited by David Baay

Share this post


Link to post
Share on other sites
2 hours ago, Max Arwood said:

..... I wish we could have an "official" statement of tweaks. I wish it would have  a few levels - These will help, These will help more, and - If you are desperate for horsepower try these.....

Max Arwood

 

Great idea.  I'm not a deep geek when it comes to my PC so I don't feel confident going under the hood, even though I'm tempted when I see posts on forums setting out various tweaks.  For example here's one on the Studio One forum which tempted me but I left things alone in case I upset something by accident:  https://forums.presonus.com/viewtopic.php?f=151&t=37827

Noel, about Max's suggestion?

Share this post


Link to post
Share on other sites

What should the Recording Timing Master and Playback Timing Master be set to? I have Rec set to ASIO input 1 and PB set to ASIO Output 1. I use a Focusrite Scarlett 18i20 and Octopre. The 18i20 and Octopre are connected via ADAT. The Octopre is the master and the 18i20 is clocked to the Octopre. So, I'm wondering if my Rec and PB Timing need to be set to the ADAT inputs and outputs? Or, does any of this make any difference at all?    

Edited by Rod L. Short
add text

Share this post


Link to post
Share on other sites
17 hours ago, kevmsmith81 said:

Thanks for tip - this is the first thing I do every time I power on a new laptop for the first time, as I always have it plugged in anyway. :)

Did you give LatencyMon a try yet?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...