Jump to content
Misha

Touch Gui slowing on heavy project...question

Recommended Posts

Hi Folks.

Got this question for pros. I used touch screen function a lot when working on projects to zoom in / locate segments etc. in Cake.

When I have a "heavy" project. (30+tracks), touch / pinch zoom response  is laggy.  Is it possible to address this somehow inside Cakewalk settings  or perhaps in graphic card settings?

My card is ok: Geforce  GTX 1050...   Or this is the nature of heavy projects and this is how it is?  I do not want to try random things if there is a proper way to do this.

 

Thank you.

Share this post


Link to post
Share on other sites

Lots of audio takes+plugins+some midi. 

The project  touch/navigation/zoom lag is happening only with heavy projects. If I have 10-15 tracks or so, it is fine.

So the question is:  if it is a nature of big projects or it can be addressed  with settings in Cakewalk, Windows or GPU...?

 

Thanks.

Share this post


Link to post
Share on other sites

Midi can be an issue across lots of lanes. When i practice my guitar adding 100 midi lanes to a track, navigation performance falls apart. Archiving or deleting unused midi is the fix for me.

When i have issues it isn't touch specific. It holds up everything.

Share this post


Link to post
Share on other sites

Thanks, 

I am not interested in deleting, archiving or freezing options. 

I am interested to know if this can be resolved by other means like setting in Cakewalk, GPU or Windows...? 

 

 

Share this post


Link to post
Share on other sites

idk. It might be that hiding the midi tracks would make it easier to navigate and showing them when you need them.

It's hard to guess whether a better PC would make the problem go away for you. Obviously bigger better faster is better bigger and faster.

For me, I can't easily change my PC. I got my current computer around 2007, but it's a Studio Cat.

I do take steps like hiding tracks that are slowing up the daw if it helps the performance. I don't have problems often, but I do sometimes need to do something to simplify things if I'm bumping my head on a limitation.

Share this post


Link to post
Share on other sites

Gswitz, I do thank you for the input, but hiding, freezing is not something I want to include in the workflow. I rather have laggy touch response :)

However, if it is possible, to manage lagginess of touch response of big projects  with settings / resource adjustment, I would like to know the things I should try.

My computer is fairly new (2018) and GPU is also fast Geforce  GTX 1050. There maaaany... settings related to video performance scattered everywhere,  I really do not want to try "everything" approach.

Share this post


Link to post
Share on other sites

if you can repro the issue in a new project by just adding, say, 100 midi tracks, then it's worth letting the devs have a copy of the project file?

Share this post


Link to post
Share on other sites

This is happening on mixed projects Audio + midi, when they reach certain "weight" not specifically midi or specifically audio.

I believe in video games you adjust settings in GPU... (I am not a gamer, so guessing). So still unclear if GPU lagginess of large projects related to the project ="project dependent",  or the graphics/touch/zoom for Cakewalk interface can be adjusted somewhere?

 

Thanks.

Share this post


Link to post
Share on other sites

I think the problem is being driven by large amounts of stacked midi and the math required to resize it all.

What happens if you select the midi tracks and change the Time Base to Absolute rather than Musical?

Share this post


Link to post
Share on other sites

Are you showing PRV for the tracks? Are there tons of muted notes represented on the PRV for the muted takes?

Share this post


Link to post
Share on other sites

Gswitz.

It is not Midi specific. I do not run more than ~10 Midi tracks at once. Project is mainly audio.

For example the latest would be: 6 Midi tracks through Halion VST, about 30 audio tracks, with approximately 400 take lanes, mostly short (10-30 seconds).  95% of take lanes are muted, so about 30 active audio segments and of course VST FX. 

Most likely this question is for someone who knows how the touch transport / zoom works in relation to the Cake project/Windows/GPU and if it is "adjustable". Not really interested in "compacting" or "freezing" project parts, I rather live with graphics lag :)  But if it is possible to address without modifying actual tracks, would appreciate the info. 

 

Thanks.

Share this post


Link to post
Share on other sites

pwalpwal,

No doubts about it :) 

The question is, can it be addressed at graphics level? 

Share this post


Link to post
Share on other sites

there's some setting in the config (aud.ini?) to disable use of opengl - maybe help? (also make sure your graphics drivers are up to date)

/good luck!

Share this post


Link to post
Share on other sites

Misha, I've tried to repeat your case in an effort to help. I haven't been successful and I'm out of ideas. Sorry I couldn't help.

I did notice that when I made really complex projex with tons of tracks that the GPU was not pushed. I could get things to slow down a little once I had more than 100 take lanes of audio and midi spread across 20 tracks but while monitoring the CPU and GPU, they really weren't taxed. Things just moved slower.

Edited by Gswitz

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...