Jump to content
Paul Young

Upgrading from Windows 10 1809 to 1909

Recommended Posts

Any issues.   Odd on one system opening a DAW and my Steinberg UR22 tries to install the driver again.

Hasn't broke the network yet.

It's pretty sad these Windows updates take up a lot of drive space.  A 250GB OS drive is pushing the limits.

I decided to back up both systems with Acronis.  I've never had an issue with Windows restoring the previous version.

I wonder what other things they reset without me checking. They always reset the password protection sharing. 

 

 

Share this post


Link to post
Share on other sites

Worked fine here. All subsequent updates install correctly following the move to 1909

My PC is Windows now 1909 and fully patched , all drivers up to date (manually, not via Windows update). 

Internet connected 24/7, PC running as local administrator with updated Malwarebytes Premium 4.04.49

Using modified Windows 8.1 driver for PCR-800 on Windows 10 - no problems there.
 

Share this post


Link to post
Share on other sites

The 1909 update was forced on me last week. It re-enabled the WiFi adapter on my desktop PC and a few other things I had disabled. It also reset the power management on some of the USB hubs to allow Windows to shut them down. I had that disabled before the update. Those are the main things I've noticed so far. Haven't run into any real problems yet.

Share this post


Link to post
Share on other sites

I keep a handy shortcut to the download for the Yamaha ASIO driver for the UR22 now.  It (almost) always needs reinstalling  after Windows updates.

Share this post


Link to post
Share on other sites
2 hours ago, jerrydf said:

I keep a handy shortcut to the download for the Yamaha ASIO driver for the UR22 now.  It (almost) always needs reinstalling  after Windows updates.

The driver was also updated recently.  This is the only audio device with this behavior.

Share this post


Link to post
Share on other sites
On 2/11/2020 at 2:14 PM, kitekrazy said:

  This is the only audio device with this behavior.

With me too.

Share this post


Link to post
Share on other sites
On 11/02/2020 at 08:31, jerrydf said:

Eu mantenho um atalho útil para o download do driver Yamaha ASIO para o UR22 agora. Ele (quase) sempre precisa ser reinstalado após as atualizações do Windows.

I have a Tascam US-600 which is an interface discontinued by the manufacturer. For me it is the same, that is: always after each update of Windows 10 - Currently 1909, I can only use it with little latency after uninstalling and reinstalling the drives. For that I use Asio4All.

 

Share this post


Link to post
Share on other sites

Been using Cakewalk for decades. After the 1909 update CWbBL started crashing whenever I changed the Master from stereo to mono or back. I had to reinstall my Apollo Thunderbolt drivers (UAD2 driver) per the website instructions. But I recently installed Studio One and all hell broke loose with Cakewalk . Tracks were muted in Track Manager but don't show that state in Edit or Mix windows and even though the audio data showed in the edit window, there was no sound; I can't hide tracks that were hidden yesterday and I had to route all my audio tracks to subs via sends instead of using the track output. Things seem to get worse every day. I've reached out to whomever is working various tech support desks but haven't had an actual conversation with anyone yet. I guess my plan to migrate to Studio One is now forced upon me.

Share this post


Link to post
Share on other sites

Sorry to hear of these issues - I have Windows 10, and a Steinberg/Yamaha UR-22 as well, but have not had to reinstall its drivers since I built the computer - though I will indeed check to see if there are new drivers for it (sounds like there are).

Is it possible Windows Updates, like optional ones, have not been installed?  Those require explicit action in Windows Update, to get those installed - you can quickly check by going to Settings > Updates and Security, and looking right below the Check for Updates button.  If there are optional updates waiting for direction to download and install, they will be displayed there.

Perhaps that is contributing to these issues?

Bob Bone

 

Share this post


Link to post
Share on other sites

Updated from 1809  to 1909 a week ago. Not exercising it much over the last week, but everything appears to be working. Have some VST authorizations to check. XLN is the only one requiring action so far. 

Still trying to remember how to kill the Groundhog re-installation of the High Definition Audio Controller on every reboot. 

Share this post


Link to post
Share on other sites
2 hours ago, jackson white said:

Still trying to remember how to kill the Groundhog re-installation of the High Definition Audio Controller on every reboot. 

That happened to me too. I finally settled on leaving it installed but disabling it in the Device Manager. Most of the time this setting survives a Windows update.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...