Jump to content

Latest version of Cakewalk not working - now solved


Recommended Posts

HI all,
Has anyone else found that after the latest update, Cakewalk won't start? Any suggestions out there? I've been using it daily for a month but now it gets stuck on the opening logo.
I've updated both the Bandcamp app and Cakewalk. I'm able to log into Bandcamp (although yesterday I found my password wasn't recognised and had to carry out a password reset.
I then uninstalled Cakewalk and re-installed via the Bandcamp app but it still freezes during the logo stage when trying to run it.


I'm running Windows 8

Edited by Chazz
To edit Title marking problem as solved
Link to comment
Share on other sites

Karhide: What are you system specs and audio interface?
The Nvidea GeForce soundcard is not used for audio. Instead I use a Mackie Onyx Producer 2-2, but I don't think that would be a likely cause of the programme not being able to start up?
System specs are:

witch_wyzwurd -
No other programmes are hanging. I've tried running both the bandcamp app and Cakewalk as an administrator. I've just tried starting it with the Windows DEfender anti viurs off but it still won't get beyond the "Cakewalk by Bandlab" start up splash image.

Thanks for your suggestions.


Edited by Chazz
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...