Jump to content
Bob Savage

Loop Construction Tool not working

Recommended Posts

Any ideas out there on this problem?

I want to record along with a 4 bar drum beat that I have played. The drum loop is composed of 4 tracks and works great. I have Exported the looped tracks and then imported  the file into a single track.  The drum loop works fine there too.

Now,  I want to make this loop repeat over and over so I can record to it as opposed to using a metronome. I highlight the loop track, open the Loop Construction tool and click on the Loop button to enable looping. The Loop Construction tool remains open, and I can now stretch out the loop track to make it keep repeating.  Here's where the problem happens. I can't get the stretched track to play.

And, I don't know how to get rid of the Loop Construction tool and close it.  If I go to Groove Clip and turn off looping in the drop down, the stretched track area that I created using the Loop Tool disappears..

Any any advice is appreciated.

Share this post

Link to post
Share on other sites

MIDI or audio? I don't know if that makes a difference, though.

Once you have your 4-bar 4-track mixed-down clip in the track view, I don't think you need the loop construction tool. Just right-click on the clip and enable Groove Looping. The corners of the clip should become beveled. Just drag that clip out as far as you like. Assuming the clip starts and ends exactly on a measure.

Speaking from SONAR Home Studio 6. Newer versions may have some different methods to achieve the same result.

Share this post

Link to post
Share on other sites

I can't replicate the problem here with audio loops (which I assume is what you're talking about). When you click on the Loop Construction window loop button, do the clip corners become rounded? And when you stretch, does the waveform repeat, or is it section following the loop just a straight line?

Try saving the loop to see if that helps.

To close the Loop Construction window, click on the X in the tab that says "Loop Construction," below it loop construction window.

Share this post

Link to post
Share on other sites

I am guessing there is more than one way to accomplish what I was trying to do but this is what finally worked for me..

Here are my notes - 

 The  Loop Construction Tool –   Only is available in Recording and Advanced workspace .  Won't open in Basic.

  The Loop Construction tool is independent from the regular Cakewalk transport operations.

Here is the procedure I used for my first successful Groove Loop.

 Created the 4 track  loop.

Exported the loop.

Imported the loop to a new track

*Selected the new track –

I had tried going to  Views - drop down and selected Loop Construction to open the Loop Construction Tool, but this works best for me Select the Clip and hit alt+7 (this opens the Loop Construction Tool)

The Loop button turns looping on and off, and the remaining options all relate to editing the loop.

When Looping is turned off, the clip displayed in the Loop Construction Tool can be Slip edited for trimming , i tweaked it a bit.  After trimming, a shaded area shows the part of the clip that will be edited when looping is turn on. And, the remaining editing options can be also preformed. When editing, Cakewalk warns if data will be discarded.

If you change the number if Beats, the tempo will be changed, this came into play below.

There is a View Zoom Tool in the bottom right hand corner that adjusts horizontal zoom.

The audio scale can be changed by Clip Dragging on the scale at the left.

Once I was done editing,  I closed the Loop Construction Tool to return to the Track view where the loop can be rolled out as required.

The Loop Construction Tool can be reopened for further editing by double clicking. - Didn’t work,  I used Alt 7 instead.

Note - I left Loop enabled and closed the tool.

I could then now roll the loop track out but the playback speed  became way too slow.  I had to turn Loop Construction back on and left Loop button on, I played with the number of Beats and was able to adjust the tempo in the extended loop to correct the slow down that had occured.

Closed the Loop Construction Tool and I have my 4 minute drum loop to track my guitar and vocals to. When my guitar and vocals are completed, I will then record a full drum part. 

When that's done I will bring my collaborators in to create whatever parts they feel would enhance the tune.


Thanks everyone for you suggestions. I did a lot of research and testing on this simple thing but I think I now have a handle on it for future projects. 

Since I am a drummer, I prefer creating a part with the correct feel to it for the tune I am writing.  A standard metronome just doesn't project a "Feel" to the tune.



Edited by Bob Savage
  • Like 1

Share this post

Link to post
Share on other sites

Hello, i dont know if anyone get the picture. I had the same problem. Here, the solution i found:

- the 'basic' view do not have the construction view. Go to 'Manage Workspaces...' found in upper right corner, under 'basic' workspace, and check the box ' Loop Construction' in the 'View'. So now the 'Loop Construction' is in the 'View' menu in the 'basic' workspace.

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...