Jump to content
William Higgs

MIDI recording double notes

Recommended Posts

When I record a bass midi track the notes are getting recorded twice, that is there are two notes superimposed on each other when there should be just one.

I've been trying to figure it out, but so far no luck.

Any help/suggestions sure would be appreciated.

Thanks

Share this post


Link to post
Share on other sites

Assuming you mean recording MIDI from a keyboard  through a track driving a Bass synth as opposed to using some kind of pitch-to-MIDI on a real bass...

Two things to check would be that the keyboard might be sending on two channels or the track input is set to Omni and the keyboard is connected by both MIDI DIN and USB MIDI ports. The latter would probably result in truncated notes due to overlapping events being on the same channel. The former can be diagnosed by checking channels of events in the Event List view.

Share this post


Link to post
Share on other sites

One other thing to check: assuming you're using a keyboard of some sort to input notes, check the "MIDI echo" setting on the keyboard. If MIDI echo is enabled, all data streaming from the out port is being resent to the in port. I believe that, by default, Cakewalk turns the MIDI echo off on startup, but something could be different in your system.

Share this post


Link to post
Share on other sites

William welcome to the forum

by the time you fix your issue,on your recorded midi-track(if they there is 'double' notes)

there is a .CAL script name is undupe (i'v not try it,but you can give it a try...

[select the midi-track then go to [process]-run CAL-[select=undupe]

 

cheer

martin

 

Share this post


Link to post
Share on other sites

One correction to my previous post: on my synth (obviously a Kronos) the setting to avoid doubled notes is identified as "local control" in the global settings. If the local control is on, the keyboard plays notes entered from the clavier. This will, however, cause doubled notes to be recorded. If it is turned off, the clavier will not sound played notes, but sounds them as it echoes back through Cakewalk. The "cakewalk.ini" file can be edited to turn the local control on or off during startup. I believe the default setting turns local control off, but your system might not be doing this. Hope this helps.

Share this post


Link to post
Share on other sites
29 minutes ago, David Bachtell said:

This will, however, cause doubled notes to be recorded.

Leaving Local Control on while also echoing MIDI back to a keyboard synth's MIDI IN will cause double triggering  of the keyboard's sound module while playing in real time or if you record audio from the keyboard synth, but it won't affect soft synths or generate duplicate MIDI events because Local Control is from the keybed directly to the keyboard's sound module - usually not even using MIDI.

  • Like 1

Share this post


Link to post
Share on other sites

Another potential is that your keyboard is sending the notes twice because the notes are contained in  overlapping "layers." It would be useful to have more information about the MIDI messages that are being received, in particular the channel numbers. The overlapping layer issue will typically send the same note on two different channels. 

Share this post


Link to post
Share on other sites
Posted (edited)

in my case, I have double notes on the same track. Tried undup cal - doesn't work. So the reason this happens is that I had local control on by accident (cakewalk automatically shuts it off but I may have turned it on to practice on the controller)?

How do you get rid of them outside of re-recording? In my case (edit) I opened the track lane and there was only one track so I thought it was ok. But I deleted it as a test and one remained. So I possibly copied over somehow? Interesting it doesn't go to another lane but doubles the lane that is there. One would never know.  Anyway, I am good here but would love to avoid it happening in the future. 

Edited by Michael Fogarty

Share this post


Link to post
Share on other sites

I have a similar issue with TD25 midi capture... but I'm also trying to go the route of just clean up (because i don't want to record). Dedup.cal is the way I want to go, but sometimes it misses dupes, and other times, it is deleting notes that aren't dupes, killing my track. Any one know why it doesn't work? (sorry, hopefully not hijacking the thread - just trying to solve the same issue post capture).

Share this post


Link to post
Share on other sites

As I just found out don’t use the input quantization as this also creates double notes. Just in case other read this 

Share this post


Link to post
Share on other sites
On 1/21/2020 at 7:28 PM, William Higgs said:

When I record a bass midi track the notes are getting recorded twice, that is there are two notes superimposed on each other when there should be just one.

I've been trying to figure it out, but so far no luck.

Any help/suggestions sure would be appreciated.

Thanks

Interesting.

As a longtime MIDI user, I’m very familiar with this type of issue and don't often have such a problem.

But as it happens, I've experienced this a couple of times now since the EA.

I'm still examining the situation in case I overlooked something but....

Share this post


Link to post
Share on other sites
14 hours ago, Scott Kendrick said:

I have a similar issue with TD25 midi capture... but I'm also trying to go the route of just clean up (because i don't want to record). Dedup.cal is the way I want to go, but sometimes it misses dupes, and other times, it is deleting notes that aren't dupes, killing my track. Any one know why it doesn't work? (sorry, hopefully not hijacking the thread - just trying to solve the same issue post capture).

assuming you checked under the VST properties that it is not sending enable midi out. Also, did you try what I mentioned above. The place where there are double notes, try deleting the data and see if there were indeed two performances - this worked for me every time. How it got the two performances I don't know. Linking the tracks when copying wouldn't do that would it? After trying dedup, I looked up if there wer issues and it seems it doesn't work for most people.

 

Edited by Michael Fogarty

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...