Jump to content
King Burton

Download / install doesn't work

Recommended Posts

Advertised as not affecting any other product installed.  NOT TRUE.  Corrupted Sonar x3.  Tried 4 different times.  Meticulously gone thru registry to try to get as clean an install as possible three times. All support says is that they don't support Sonar x3 and sales blurb about how wonderful this product is. To me if it won't install, it's not that wonderful.    Always the same failures:

Install Errors

GroovePlayer.dll

CW130Auto.dll

MackieControl.dll

Arpeggiator.dll

ChordAnalyzer.dll

EchoDelay.dll

EventFilter.dll

Quantize.dll

Transpose.dll

Velocity.dll

All state - "Unable to register the DLL/OCX: RegSvr32 failed exit code 0x3"

Also

"Code execution cannot proceed because VCRUNTIME140.dll was not found."

"Code execution cannot proceed because MSVCP140.dll was not found."

"Code execution cannot proceed because CONCRT140.dll was not found."

"Re-installing may fix this problem" – DID NOT FIX

CP will not boot

Not a beginner. Does anybody know the reason/fix?

King Burton

Win10   Presonus Firestudio

Share this post


Link to post
Share on other sites

The most likely reason is a missing Visual C++ Redistributable library. These libraries were installed as standard in Windows XP / Windows 7, but are missing in Windows 10.

IRRC, it's Visual C++ Redistributable for Visual Studio 2015 that is needed for Sonar X3:

https://www.microsoft.com/en-gb/download/details.aspx?id=48145

If this doesn't work, try working backwards and install these:

VS2013 redist: https://www.microsoft.com/en-gb/download/details.aspx?id=40784

VS2012 redist: https://www.microsoft.com/en-gb/download/details.aspx?id=30679

VS2010 redist: https://www.microsoft.com/en-gb/download/details.aspx?id=5555

  • Like 2

Share this post


Link to post
Share on other sites

AWESOME guys. Worked fine.

Still couldn't install sections to where I needed them but moved manually.

 

I appreciate the help.

k

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...