Jump to content
Mates

Overloading PC when using VIs in CbB

Recommended Posts

Hello, 

I've got some problem with using cakewalk. I'm working on laptop Lenovo y700, i7 8gb ram, OS and DAW is instaled on SSD drive. Also using Mackie Onyxia Blackjack as audio device. To recording  using  NI Kontakt. When i load four track using kontakt ( Alcia Keys, Session string pro 2,  some harp plugin from kontakt and Lumina) the program start popping, cracking, and sometimes freezes. Once time the audio device was disconnected .I thought the laptop specification should be enough to project like this. Maybe i add VIs in wrong way? I always open new kontakt instrument, for each track, from add instrument button. Maybe  something wrong with program settings? I'm using Mackie asio as audio driver.  Thanks for help and sorry for my english. 

Edited by Mates

Share this post


Link to post
Share on other sites

Your ASIO buffer is too small.  Kontakt and lots of complex soft synths are going to need a much, much higher number than what you'd use for recording.  Try 1024 or 2048 for a buffer size, whatever your interface's highest value is.

Share this post


Link to post
Share on other sites

One other thing you might have to deal with, ProjectSAM's Lumina has the Max Voice count set to 256, but for a lot of the stories it's really easy to exceed that if you play fast notes, which causes Kontakt to kill voices and things to sound bad.  It's not the popping/cracking/freezing your describing but it's still a problem.  The solution is to raise the Max Voice count.  Drove me nuts when I first got Lumina.

Share this post


Link to post
Share on other sites

Matthew, thanks for help. 

Where should i change sample rate? On CbB or in driver settings? I've set it to 512 in driver settings becouse of high lattency ( have no midi interface, and conecting midi controler direct by usb cable to my laptop) One thing i forgot to describe, it dosn' hapend when i have only one or two VIs loaded. It crahing when load more then two or three. 

Share this post


Link to post
Share on other sites

In the ASIO driver settings, which you can get to from inside Cakewalk though I usually exit Cakewalk and change the settings outside in the driver control panel.

I'm not sure the Onyx Blackjack is very well supported, which might explain why it's handling things so badly it crashes.    You don't say what version of Windows your running but the driver and it's config is certainly the problem your describing.  Normally 512 should be reasonable for some synths, but it all depends on the ASIO driver really.

You also may need to make sure your laptop and OS are configured correctly for highest performance and turn off all the USB power management features.  But even with all that it may not be enough to do what you want with that computer and audio interface.  Lumina and Session Strings 2 Pro are both very computationally complex Kontakt instruments.

But start with making sure you have the more recent/best ASIO driver.  Set it to the highest ASIO buffer you can.  Then configure you computer the best you can.  If you are running Windows 10 this guide isn't bad:

https://www.sweetwater.com/sweetcare/articles/pc-optimization-guide-for-windows-10/

For Windows 7:

https://www.sweetwater.com/sweetcare/articles/pc-optimization-guide-for-windows-7/

 

Share this post


Link to post
Share on other sites

Start with Matt's advice, as it's always the first step and often solves the issue.

However, there are many potential reasons for dropouts, clicks and pops. Wifi adapters, for instance, are notorious for eating CPU cycles and should be disabled during audio sessions. Kontakt alone has its own extensive set of issues and solutions, but mostly it's just very resource-hungry (CPU, RAM and disk I/O). For example, 8GB should be plenty but some Kontakt libraries gobble up more than 2GB per instance and it's not impossible to run out of memory and start paging. 

So try increasing the buffers first, then report back if that didn't resolve the problem.

Share this post


Link to post
Share on other sites

Thank guys, that was buffer size. I set it to higher i can ( 8k something) and now is ok. But now i have lattency almost 100 ms, and my midi controler is unplayable. So when i need to record something i just turn back to 512 buffer and then recording. Whats wired,  when i switch from higher bufer to lower sometimes the plugins play well even on lower.  Onyx blackjack have no support on win 10, on which i working, i think thats the problem. I instal driver using compatibility mode with win 7.  Thank you a loot fou your help. Cheers 

Share this post


Link to post
Share on other sites

One work around for cpu heavy soft synths on cpu light computers is to freeze tracks you finished. My second suggestion isn't the best solution but it has worked for me if I have lots of tracks and the soft synth I was using had latency. I would use a very lightweight similar sound for playing and then use "replace synth" feature to load the heavier version. For instance maybe if tracking intense piano use something like a Korg M-1 piano to track, then replace it with that 20gig monstrosity you really wanted to use after you lay down the midi.

Share this post


Link to post
Share on other sites

The notion of cranking up the ASIO Buffer Size to a large value is not a viable solution during the recording phase of a music project.

ASIO Buffer Sizes of greater than around 128 samples, (which is still OK), begin to cause an audible delay between triggering a note and hearing it, and thus during the recording/tracking phase of a project, an ASIO Buffer Size larger than 128 samples is not workable.

During mixing/mastering, by all means jack up the ASIO Buffer Size to either 1024 or 2048, because that allows for plugins like convolution reverb types, or linear phase effects, to have enough buffer size to work their magic properly.

For the rest of time, folks switch back and forth, between smaller ASIO Buffer Sizes, and larger ones (128 or lower when recording, and 1024 or higher when mixing).

As far as your current issues - I suggest you try setting your ASIO Buffer Size to 128 samples, and also make sure you don't have anything interfering with the ability of your computer's streaming audio capability.  Sometimes, which plugins are loaded into a project can adversely affect DPC Latency - such as a convolution reverb or linear phase effect.  You can quickly test that scenario out, by hitting the letter 'E' on your computer keyboard,  just prior to playback, which will toggle on/off the bypassing of all loaded effects.  If your issues instantly go away with the effects bypassed, then you know that at least one effect plugin is not likely meant to be used during recording, but instead is designed to be used during mixing, when the ASIO Buffer Size can be set to a much larger value.  (turn effects back on by hitting 'E' again, by the way).

Another possibility is that your wireless transmitter/drivers could be gumming up the works, this does not always occur, but can, and you can also test this out by temporarily disabling the wireless adapter in Device Manager (some laptops have a function key or physical switch to disable WiFi, as well), and then launching Cakewalk, and seeing if that resolves the issues for you.  If it DOES, then your solution would be to temporarily disable the WiFi adapter in Device Manager, then launch CbB and when finished, then enable the WiFi adapter again in Device Manager.

LatencyMon is a free app that you can download and run, to also produce a report that indicates possible things that interfere with your computer's ability to do the streaming audio needed for clean sessions in Cakewalk (or any other DAW).

https://www.resplendence.com/latencymon 

And here is an example video talking about using LatencyMon (the guy put me to sleep, but it might help explain it to you, otherwise, search for other videos on YouTube that demonstrate using LatencyMon to resolve streaming audio issues): https://www.youtube.com/watch?v=78S0CMafigM

Bob Bone

Share this post


Link to post
Share on other sites

I have to run at 2048 during playback/mixing but during recording I turn off the effects (FX button). I turn them back on when finished recording. Turning off PDC (just below the FX button) also appears to affect the delay too but it's subtle so I am not so sure. IT doesn't hurt anything during recording. Switching the buffer while in CbB periodically makes my audio engine freak out so I prefer to leave it alone. I assume it's something with Presonus.

I asked for a feature /switch in CbB to automatically turn off FX during recording and flip it back when done. I don't expect it to be implemented but I think enough of us have to turn them off to stop the delay so it would be convenient (but not critical.)

As an aside, check your processor/GPU cooling. I had a problem with things starting out fine but crackles and pops would creeping in after a few minutes. Turns out my fan and heat sinks were dirty/dusty. I clean them once a week now and it solved that particular problem.

Edited by Terry Kelley

Share this post


Link to post
Share on other sites
1 hour ago, Terry Kelley said:

I have to run at 2048 during playback/mixing but during recording I turn off the effects (FX button). I turn them back on when finished recording. Turning off PDC (just below the FX button) also appears to affect the delay too but it's subtle so I am not so sure. IT doesn't hurt anything during recording. Switching the buffer while in CbB periodically makes my audio engine freak out so I prefer to leave it alone. I assume it's something with Presonus.

I asked for a feature /switch in CbB to automatically turn off FX during recording and flip it back when done. I don't expect it to be implemented but I think enough of us have to turn them off to stop the delay so it would be convenient (but not critical.)

As an aside, check your processor/GPU cooling. I had a problem with things starting out fine but crackles and pops would creeping in after a few minutes. Turns out my fan and heat sinks were dirty/dusty. I clean them once a week now and it solved that particular problem.

Generally speaking, as long as you don't load up any effects that, by their design, require large buffers to do their processing, such as convolution reverb and linear phase type plugins, you can still use reverb and delay, or amp modeling plugins, without issue. if you are not also running a super small ASIO Buffer Size.  I generally choose 128 samples for my buffer size, when recording.  I could go lower, but this is still small enough to where it doesn't produce a delay that messes up my tracking, but is large enough to allow for quite a few effects (I generally don't apply too many when tracking, but at that buffer size I never seem to have issues).

If you DO want to track with reverb, or whatever, just use one that doesn't induce a bunch of latency, or chew up too much CPU - even if that means using a less robust type of reverb, or whatever - and then when you are ready to start mixing, you can always load up the more resource-consumptive kinds of plugins, such as the nicer sounding convolution reverb or linear phase types of plugins.

Or, as you noted above - bypass the effects while recording.  Either way works.  :)

Bob Bone

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...