Jump to content

Question

Hi everyone, 

 

I've been a Sonar user

since the early stages already for a very long time. As I have transitioned towards this new version (that I still tend to call Sonar, sounds kinda cool), there were some minor issues surfacing from time to time which I plan to bring up eventually here. 

In this context, there is a problem with the MIDI assignment of inputs, which has changed since recently. Namely, when you connect a keyboard while Kontakt player is running and you assign the MIDI as it requests in a message, the inputs and outputs of all other MIDI synths will be randomly reassigned. However, when you plug in your MIDI controller and then run Cakewalk, everything is normal. 

I guess this is some sort of bug and needs to be fixed. Opinions and views are very welcomed indeed, perhaps there's some workaround or even fix that I haven't managed to come by so far for this. 

 

Cheers!

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 1
On 1/1/2020 at 12:10 PM, Bruno Dzogovic said:

Hi everyone, 

 

I've been a Sonar user

since the early stages already for a very long time. As I have transitioned towards this new version (that I still tend to call Sonar, sounds kinda cool), there were some minor issues surfacing from time to time which I plan to bring up eventually here. 

In this context, there is a problem with the MIDI assignment of inputs, which has changed since recently. Namely, when you connect a keyboard while Kontakt player is running and you assign the MIDI as it requests in a message, the inputs and outputs of all other MIDI synths will be randomly reassigned. However, when you plug in your MIDI controller and then run Cakewalk, everything is normal. 

I guess this is some sort of bug and needs to be fixed. Opinions and views are very welcomed indeed, perhaps there's some workaround or even fix that I haven't managed to come by so far for this. 

 

Cheers!

We're aware of this issue and it's logged with development. Like Dave said, we recommend not making changes to your MIDI device configuration while you have a project open in the meantime. 

Share this post


Link to post
Share on other sites
  • 0

I haven't noticed a change recently. It's always been the case that starting a project with hardware ports missing or adding hardware ports while a project is open can alter MIDI track I/O assignments. It's best to just avoid changing hardware setups with a project open. And when it does happen, close the project without saving, and it should come up correctly when the hardware setup is stabilized.

That said, MIDI/Instrument track outputs that are assigned to soft synths should not be altered by adding/removing hardware ports in my experience.

In order to know whether what you're seeing is new and/or unexpected, you'll need to detail exactly what the scenario is in terms of the project's track I/O assignments and Cakewalk's MIDI device configuration before and after adding the keyboard.

 

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...