Jump to content

Search the Community

Showing results for tags 'mackie'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • News & Announcements
    • Product Release Info
    • Frequently Asked Questions
  • Cakewalk Products
    • Cakewalk by BandLab
    • Instruments & Effects
    • Feedback Loop
  • Community
    • Content
    • Tutorials
    • Songs
    • General Music Discussion

Product Groups

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me

Found 7 results

  1. Hello All - I recently got a new M-Audio Hammer 88 Pro keyboard, and finally got it to control Cakewalk's faders, sliders, and transport. I thought I'd share with other M-Audio gear owners as I didn't see all this information in one single place. I do owe a lot of my success to several posts on this thread over in Instruments & Effects. Note that although the various M-Audio keyboards have slightly different control surfaces, the internals are basically the same. I took all my instructions from various posts about the Oxygen 25, 49, and 61. What you Need Cakewalk Installed and working at a basic level with your Hammer or Oxygen keyboard via USB or MIDI DIN and a MIDI card in your computer. Have read the basic User guide and know about DAW vs PRESET mode and how to interact with the keyboard. Create a project with 8 or more tracks, and have it open. You don't even need particular instruments assigned - can just be an empty audio or MIDI track. Record something for a few bars so that you can play with the transport controls once they're hooked up. How to Get the Mojo On your Keyboard, Press and hold the DAW button Turn the rotary encoder slowly until you see the BITWIG DAW preset show up. Click the Encoder knob to select it. BITWIG uses the Mackie protocol for communication with the DAW, out of the box. In Cakewalk Go to Edit -> Preferences or just hit P to open the preferences. Click on Control Surfaces, on the left, under MIDI Click the ugly yellow plus icon in the upper right (Add New Controller/Surface) From the Controller/Surface dropdown menu, pick the last one, Mackie Control For Input Port, pick MIDIIN3 (your keyboard name here) if you're on a PC, and Mackie/HUI if you are on a Mac. For instance, I have a Hammer Pro 88 so the option I pick is MIDIIN 3 (Hammer Pro 88). For Output port you can select --None-- since your keyboard does not have motorized faders and can't really change based on incoming data from Cakewalk. Click OK to save it. Click the WAI (Where Am I) checkbox on your new control surface and pick your favorite color. Close your preferences dialog. Go into Console mode or another mode where you can see the controls for each track. You should see tracks 1-8 have a thinnish bar at the very bottom in the color you selected, with a number in it. These numbers correspond to the faders and rotaries on your "mackie" keyboard. Back on the Keyboard Move sliders in turn, 1-8. Each should control the fader. Fiddle with the 8 rotaries. They should sync up with your PAN virtual rotary in Cakewalk and animate it. Press the PLAY button on the keyboard. It should start Cakewalk at wherever your NOW pointer is. Press STOP to stop it. Press the MODE/GLOBAL button once so that the red REC light lights up Now all the buttons beneath each slider will arm/disarm the corresponding track for Record Press MODE/GLOBAL twice so that the MUTE light is lit (I am not sure if SELECT does anything). Now all the buttons will selectively mute each track. Press MODE/GLOBAL again so that the SOLO light is lit. Now all the buttons will selectively SOLO each track. Oh, so sad. I need more than 8 tracks. I guess this Mackie thing is not for me. NO WAY! Check THIS out - Add a few more tracks beyond 8 in Cakewalk. On the Keyboard, on the top row in central section.. you should see two buttons separated by the word BANK. The one on left is PREV (<) and the one on the right is NEXT (>). Click the "Next Bank" button (>). Look at Cakewalk and shed a tear of joy :,-) The colored WAI stripes at the bottom of the 8 tracks that had the color stripe have moved to the right as far as they could, so that fader 8 now is controlling your last track, or track 16 if you had that many. Now your faders and rotaries talk to THOSE tracks. You can add more tracks and use your Bank Prev and Next buttons to "move" your virtual Mackie back and forth through your tracks, letting you use your faders and knobs to control any track. I went up to 66 tracks and just stopped trying. Since the board has four "banks" I thought it might stop at 32 or maybe 64, but it just kept going (even though the keyboard display halts at Bank 4). If anyone hits a maximum, please add a comment. About the Master Fader For some reason, the BITWIG setting does NOT let you use your ninth fader on the keyboard to control your Master Fader. That's a little sad because that one is really handy when doing mixing. Fortunately, there is a workaround - ACT to the rescue. Here's how to add in the Master Slider. I have seen some posters suggest you need to use the M-Audio Preset Editor for your keyboard to achieve that. And at first, I would agree with them. However, I got it to work without getting down to that level. Besides, it seems there is a bug in that software that once you download the BITWIG preset and change anything on it and attempt to upload it under a different patch name, your rotaries only give you 180 degrees of action on your pan, not the 300-some degrees that the physical rotary provides. I have opened a ticket with M-Audio to look into this. Fortunately, we don't need it! Here's how to get the Master Fader working: In Cakewalk, Open Preferences Go under Control Surfaces again Click the yellow plus in the upper right (New Controller/Surface) Select ACT MIDI Controller (should be the default) Select the MIDIIN 3 (<your controller name here>) port for hte input port Select NONE for the output port. Click OK to save the controller I would not select the WAI checkbox in this case, as you won't be controlling anything else but the Master, but all the global tracks will get WAI'd like Metronome and Preview. Go under Utilities menu along the top, and at the bottom you should see ACT MIDI Controller -1. Select it. You now have the ACT dialog up. You should see a matrix of green boxes with various things in it. Click the Bus radio button at the bottom, under "Control Group" Click the first green box in the second row of boxes (S1). It will now show Midi Learn.. in the box. On the keyboard, move slider 9 up or down. You should see the number change in the box as you move the slider. Type a name up in the box, maybe just call it Master Slider and save it. Just in case Now you got Master Slider. What You Don't Get So this setup is not perfect, but as far as I could tell from other threads, this is about as far as you can push automation on M-Audio keyboard controllers. I could not get the Loop button to work. You could probably use the Preset Editor to get that working, but not until M-Audio fixes the bug that ruins your rotary synchronization. I hope this was helpful. Cheers & Happy Remote Controlling... Jesse
  2. Hi folks! Many of you have had trouble setting up devices to control Cakewalk. In this video I hope to ease your frustration! WATCH HERE: https://youtu.be/K7x30ZmO5V0
  3. Hi The Problem: I have a Mackie Control Universal, the old grey one. It seems to have developed a problem in that it sends intermittent, uncommanded midi signals which cause the virtual master fader in cakewalk to move rapidly up and down about a decibel in volume. It seemingly happens randomly, several times a minute, sometimes once a minute or less, lasting a few seconds at a time. I have used Midi-Ox to record the output signals - see the attached pic. My Mackie has the upgraded cpu chip (v3.0.0 up from v2.1.2) and two PWM chips, upgraded to v3.50. Things I've Tried: Tried 2 different Midi interfaces - a Focusrite 4i4 and a Miditech 4x4. I have taken the Mackie all apart and undone and redone all the connectors. I have swapped all the chips with the other upgraded ones from my mackie extender. I've also tried putting the old chips back in (v2.1.2). I've tried pressing every button and turned every knob and moved ever fader to see if something was sticking. I disabled the physical Master Fader on the Mackie by pulling its connector off and ran Cakewalk to see if that would stop the problem. It didn't, the virtual Master Fader still recieved a midi signal from the Mackie and randomly shook the fader up and down. Checked the Mackie is in MCU mode. Checked the controllers setup in cakewalk - Mackie first, Extender 2nd amd C4 third. Ran Cakewalk with just the Mackie and no extender or C4 controller. The whole setup seems ruined now. It was working fine before the weekend. As it only affects the virtual Master Fader (or the Bus Fader - depending upon what I have the physical fader set too in the Mackie options), is there a way of disabling the Mackies input to cakewalk's Master Fader? I don't really use it so I wouldn't miss it. I know I can select in Cakewalks Mackie options which fader to assign to the physical Master fader - either 1.Master Fader or 2.Bus Fader. I would like to be able to disable it completley. Any help would be really appreciated. I've spent all weekend on this. And as I said, my whole Cakewalk/Mackie setup is ruined by this. Regards, Chris
  4. I have installed Bandlab/Cakewalk as well as the Mackie app for my Producer 2.2 interface. I cannot hear any audio output though the phones out on the 2.2 But Windows sounds are there in the phones so Windows likes the interface. I've followed the tutorials and opened a new project, insert instrument (drums) and can see the drum set and mouse hit the drums and it shows that it's triggering but no sound at all. I suspect it may be a bus assignment but I've tried everything I can think of (and I know MIDI) and no audio. Here's another thing. After installing Cakewalk I launched it without the interface attached and before I installed the Mackie application. On launching Cakewalk I got an error message that "the master bus is set to silent". So I tried to find the right setting and could not figure out the master bus problem. But now when I start Cakewalk without the interface connected (but with the app already installed) and now the error message is "the drivers installed are not compatible...." so I can't listen through the laptop headphone jack. I've looked everywhere and can't find a solution. Thanks in advance for your help. Mike in Nashville
  5. so, i have gone through all the support pages and looked through google but i cant find anything on this. i just received my mackie onyx artist 1-2 today and installed all the drivers. however it isnt appearing in any of the driver lists. like at all. its also not letting me playback mp3 or wav files saying unable to open audio playback device plz help
  6. Hi, I have been using a Mackie MCU Pro for a few weeks now with no issues (after the initial setup), loading a project today in cakewalk the following issues have arisen: - No buttons on the track strips in the MCU will update Cakewalk, but muting (for eg) in Cakewalk will set the button on the MCU. - Transport not responding - None of the buttons in the view, fader bank, or the whole right hand section respond - the faders do map okay, but i can't move off the 1st bank. I've tried re-mapping the Mackie in Cakewalk as a surface, restarting Cakewalk and the Mackie and loading them in order (i.e. Mackie on 1st), restarting PC, loading other Cakewalk projects. I'm reading and looking for answers now, but any advice or help or links would be fantastic. Thanks in advance Chris.
  7. This issue seems to have been in Sonar as long as I can remember and it's still in the latest Cakewalk, but it's really annoying me now as I've been working on a control surface plugin with some different selection options. To repro, you need a control surface using the Mackie plugin with the "Select highlights track" option set and a project with multiple tracks - I'm going to use tracks 1 and 2 but the actual track numbers don't matter From the control surface press the SELECT button for track 1 - track 1 is now highlighted Press the comma key on the PC keyboard - track 1 is now selected From the control surface press the SELECT button for track 2 - track 2 is now highlighted Press the comma key on the PC keyboard - tracks 1 and 2 are now selected Now this all works fine until you use the GUI, either mouse or keyboard up/down keys to highlight a track. Once you've done that for the first time, the behaviour changes and the comma key select toggle will ignore any track highlight changes that came from the control surface. So you get this: From the GUI (either mouse or keyboard) move to track 1 - track 1 is now highlighted Press the comma key on the PC keyboard - track 1 is now selected From the control surface press the SELECT button for track 2 - track 2 is now highlighted Press the comma key on the PC keyboard - no tracks are selected Press the comma key on the PC keyboard again - track 1 is selected So, the highlighting via the control surface is a sort of "second class" highlight that doesn't work with everything. To restore the correct behaviour, you need to close and reopen the project.
×
×
  • Create New...