Jump to content

synkrotron

Members
  • Content Count

    1,256
  • Joined

  • Last visited

  • Days Won

    4

Everything posted by synkrotron

  1. Hi @micv I searched using google and it didn't really bring up anything helpful. In the meantime I found the SONAR Platinum manual on my hard drive and I have posted a screenshot of the relative section on External Insert above. I'm sorry, I do not quite follow you there. I am using External Insert on an Aux track so that once I know I am done with my project I can "print" the output of that effect to audio, prior to final mixing. I will post a screenshot of my Cakewalk Driver Settings page:- As you can see, my Buffer Size is set to 384. The reported Roundtrip is then calculated below that and works out to be 1534 samples. Quite a bit more than double my 384 Buffer Size. Okay, I might be misleading you in my original post. 70 samples isn't the Roundtrip, it is an offset that is added to the reported Roundtrip. Here is a screenshot from REAPER's ReaInsert:- Please note the greyed out text just below the setting for "Automatic device latency adjustment," which I have checked/selected. It says, "Reported latency 1534 samples," which is the same value in the Cakewalk Driver Settings dialogue box. Then below that there is a box for "Additional Delay Compensation:" and in that box it currently says, "66" samples (I rounded that up to 70 in my OP just because). So I think that REAPER adds 66 to 1534. To be honest, I still don't have a clue what is going on here. I mean, I do, in a way, but my head is spinning with the technicality of it all. At the end of the day, perhaps it doesn't matter as long as I manage to get the hardware MIDI synth audio lining up with the soft synth audio. It's just that. for some reason, there is a difference of around 100ms between Cakewalk and REAPER and I am trying to understand why. Cheers, and thanks for your input here, andy
  2. Okay @Gswitz , I have watched the first video about using External Insert, so thanks for that. I am a bit confused because when you do the ping, by clicking in the top box in the Delay section you then type that number in the text box below labelled "Offset (samples)." I dug out the old SONAR manual and it doesn't mention that here for some reason:- It mentions in item 5 to "Click the Delay Measurement control..." but does not then follow up with "now type that in the Offset box." Having said that, if I leave the offset at zero, instead of typing in the measured delay, it just means that I have to adjust the timing offset on any MIDI tracks associated with any soft synths. Doing so then matches the timing of my hardware synths that are being played via MIDI. So, for now, my External Insert plugin looks like this:- And I have done the same as you and typed in the figure in the top box into the box below. cheers andy
  3. Thanks Geoff, I will watch those videos later... Faffing with something else at the moment You are right that I should be checking out LatencyMon, and I have been doing. If I think I am doing anything "serious" I will usually fire up task manager and shut down obvious processes that I do not need, like Adobe updater, Skype etc. But what is bothering me, I guess, is that I do not get the same amount of "trouble" when using REAPER, although I have to admit that I am not doing a fair comparison because they are not the "same" projects, in terms of tracks and effects, just "similar." At some point I need to really create a project in Cakewalk and port it over to REAPER, and then see. Also, as I pointed out above, REAPER's ReaInsert is reported a considerably lower delay than Cakewalk's External Insert, and that is the main reason for my post here. I suppose I could try an empty project in Cakewalk, add an instance of External Insert, do the ping, and see what that turns out to be, and then do the same in REAPER. I'll do that when I get time later... cheers andy
  4. Sorry, I should have stated here, and elsewhere, that I am using ASIO driver, currently set to 384 samples (I have tried lower but I get too many dropouts, crackles and pops) And regardless of the so called "round trip" latency, I am getting much more than that when using External Insert.
  5. I think I may have discovered something... if you highlight a bit of text in another post a little widget pops up allowing you to quote just that text. Excuse me, I'm a bit slow...
  6. Yeah, but sometimes I want to interject at different points of a quote and I have yet to decide on how best to do that.
  7. If you think that the following YouTube videos are a "Guitar Clinic," then, forget it. You ain't gonna learn much about guitar techniques here I'm afraid. For me, this is more of a therapy thing and I have watched quite a few of Devin's "Guitar Clinics" over the last couple of weeks and I really enjoy them. Let me know if you manage to watch all four parts, and what your thoughts are:- cheers andy
  8. Just wanted to say what a great forum this is not you lot, I mean how you can easily format your posts and how standard keyboard shortcuts seem to work here. And how videos and pictures are instantly added with no formatting. A cut above most of the other forums I use... Only thing I sometimes struggle with is using quoting other posts. Okay, carry on
  9. Ha! No! But some "on topic" posts were made and I wanted to chip in cheers andy
  10. Hi Peeps Just to explain I have spent around the last two weeks now, going between Cakewalk and REAPER, trying to incorporate my outboard effects in my test projects. I have been having no end of issues with terrible and somewhat inconsistent "timing" issues when trying to synchronise my hardware MIDI gear and my modular system. I have posted elsewhere about that so I will not go into details here. My school boy error I found out only the other day, from a post in the REAPER forum, that I should be pinging the outputs/inputs while the effects in the outboard units are bypassed, which is especially important with reverb. Because of my ignorance I was getting wildly different delay times when pinging, anything between 2000 to 4000 samples in Cakewalk's External Insert plugin. Now that I know that, and I have re-pinged my instances of External Insert (in Cakewalk) and ReaInsert (in REAPER) I am pretty much getting stuff synchronised now. Still some issues, but I don't think they can be linked with my outboard effects. A question Okay, now that I "think" I know what I am doing, I have a question There is a big difference between Cakewalk's and REAPER's insert plugins, in terms of delay. In External Insert, the delay is being reported as 1215 samples. In ReaInsert the delay is being reported as 70 samples. And so the question is, why is there such a big difference between the reported delay times in the two plugins? What to do? I'm in a quandary. I really want Cakewalk to work for me. As I have been getting back into Cakewalk I have reminded myself what a great DAW it is. I love instrument definitions, how you can edit them so that things like patch names and controller names are presented properly in Cakewalk and therefore easier and quicker to apply/assign to MIDI tracks and envelopes. But while using my outboard effects the delay between hitting a key on my controller and the note sounding is simply too large, even for a sloppy player like myself. Advice (now were are getting to it...) Is there anything I can do to tackle the delay issue? Am I using External Insert correctly? Could I manually change the delay time to a lower value and hope that it works (I suppose I should just try that)? Am I expecting too much from my setup? (in-depth details here) Okay, I think that covers it, I'll hand it over for consideration and hope that someone is able to help. cheers andy
  11. Ah,okay, well that is certainly one way of looking at it thanks, andy
  12. Hi @Gswitz Glad to hear you got to the bottom of your problem 👍 Regarding the MIDI thing, it's a pity that Cakewalk doesn't handle the removing and adding of MIDI stuff in preferences. I messed up test project when I decided to test operation with just the one OCTA-CAPTURE, just in case linking the two together was causing my issues. It took me a bit of time to notice that Cakewalk had changed the input ports on any track that used #2 OCTA-CAPTURE to ports on the #1 OCTA-CAPTURE. I think it would be nice if Cakewalk took a look at how REAPER handles Audio and MIDI devices. It works great for being able to add and remove controllers. I've not tried doing it while REAPER is open, as I developed the habit, forced on me by SONAR, of shutting down, plugging something in, and then started SONAR again before configuring the device in preferences. I'm not saying that I want Cakewalk to be like REAPER, but in certain areas of the software I think that BandLab should take a good hard look at what it can do. I think even Studio One handles the fact that some controller or device may no longer be present... cheers andy
  13. Hi Jonathan I'm not sure how that works to be honest. I mean, the money that we all spent in SONAR, Platinum, lifetime and all that would have gone straight into the Cakewalk owners (Roland or Gibson, I'm not sure who was the owner at that time) pot and paid for wages/bonuses for staff at that time. There is no way that BandLab would have benefited from any of that money. And when BandLab got the code from Gibson, did they get it free? cheers andy
  14. Aye! I'm on dodgy ground there though... I've probably blown about five grand on the modular for starters haha. You can get a lot of cushions for five grand!
  15. Hi @Gswitz, Yeah, I have an Arturia Keystep which I can either connect to my DAW via USB or MIDI. Then there is my OB-12 hardware synth. I also have an Acorn Masterkey 49. Trouble is, I'm having my own issues with synchronising stuff at the moment so I'm using step sequencer to create simple patterns so I can test things out, so I can't say whether or not they work with Cakewalk yet. They certainly worked okay with REAPER and Studio One. cheers andy
  16. Haha! Yeah, I always forget that one Mind you, obtaining forgiveness is still virtually impossible... I am often reminded of my "unreasonable spending habits." So, I should just get this thing and explain that all it means is that we will be in the soup kitchen a couple of months earlier than expected...
  17. Well, sounds like a great idea, but when I mentioned to SWMBO yesterday that I was spec'ing up a new pooter she weren't happy. So getting a Studio Cat would probably even more out of the question
  18. Also slightly frustrating for SONAR users was when looking into various pieces of hardware or software SONAR was rarely ever on the list of tested/trusted DAWs. Roland used to package a "lite" version of SONAR with their interfaces, presumably because they owned it at the time. They now give away licenses for Live lite. So I have always felt like I've been using the "poor man's" digital audio workstation, although I have to add then I have NEVER felt the it was in reality, if you know what I mean. If a discussion came up about, "which DAW do you use" on non-DAW forums, I'd be the odd one out using SONAR. Never put me off though... Page 11 I feel another video coming on.......
  19. Hi @Gswitz I run with two OCTA-CAPTURE interfaces, a MOTU micro lite and a HX Effects box, all connected to my laptop via USB. All appear in Cakewalk as MIDI devices and when checked/selected appear to be working fine in both Cakewalk and REAPER. Good luck with sorting your stuff out. cheers andy
  20. Hiya @Jim Roseberry Thanks for taking a peek and commenting, much appreciated. I guess that until I update my pc I'm going to have to put up with those glitches. And even then, such is the way with computers, there are no guarantees, is seems. I powered up about half an hour ago. I opened task manager and stopped as many background processes as I could. And then I ran LatencyMon again. Here is the main page after just six minutes of running. And, to be honest, until a massive spike, DPC was running at around the 200uS mark:- And here is the Drivers page:- As far as I could tell there was no real activity spikes showing up in Task Manager. So I'm at a loss. I have to admit that I also use my laptop for occasional gaming, which may attract derision from some I am sure. I use a Logitech keyboard and mouse when in my studio, so tasks are usually running for those, although for the above test I had shut them down. Fortunately, just a hobbyist, so I can put up with those glitches I guess. Thanks again for your time Jim cheers andy
  21. I can only see USB-C on the back panel. Will be interesting to see how it is received
  22. It does look impressive and I like the sound of "inserts." Not impressed by USB-C though. I have an Arturia Beatstep Pro and a Keystep, both with USB-C connections and, although mine are okay and probably safe in a home studio situation, they are prone to failure.
×
×
  • Create New...