Jump to content


  • Content Count

  • Joined

  • Last visited

Everything posted by bgewin

  1. Ok thank you John - that works. Man, super bummer but at least there's a workaround. I tried the global effects bypass and that got the timing problem solved, and Cakewalk definitely respects the offset now (changing the offset has an effect now). I have a lot of effects and soft synths in this project. I'll try and figure out which the culprit is an post it here.
  2. Yes John - "Studio Live Series III ASIO (64 in, 64 out)". This happens to be the only option in the dropdown; there's no other choice.
  3. I was noticing that my bass guitar playing seemed rushy and thought it might be time for another sync test. I connected a cable from my analog headphone amp's output to an input on my presonus mixer. I soloed an analog track, and recorded its output (through the headphone output and analog input above) onto a new track. Sure enough, the copied version of the audio was ahead by 1020 samples. No problem, just go into EDIT=> PREFERENCES => AUDIO => SYNC AND CACHING and play with the MANUAL OFFSET under "Record Latency Adjustment" until the incoming wave syncs with the pre-recorded stuff. Only thing is, whether I set the offset to 0, 5, 1000, 5000 or even -5000, the new, copied audio is about 1020 samples ahead of the original. The system seems to be completely ignoring the Manual Offset setting. I experimented with checking and un-checking "Use ASIO Reported Latency" and it doesn't make a difference. I've tried multiple takes, and closing Cakewalk and going back in; no difference. Please help, and thank you.
  4. bgewin

    Midi record timing offset

    Thanks for chiming in folks. On input, I'm playing a Yamaha P-515 digital piano connected via USB, and I typically just use its speakers to monitor the keyboard part I'm playing on the way in, so I think we can agree that there's no monitoring latency problem as far as the keyboard. I'm using a Presonus StudioLive 32R digital mixer as my sound interface (and mixer). I appreciate the suggestion regarding "Timing Offset (msec) under Preferences > Audio> Sync and Caching", but as you say, that simply advances playback and leaves my midi notes behind the grid, which is a mess for editing. So why can't there be a setting like there is for analog recording (Edit==>Prefereces==>Audio==>Sync and Caching ==> Record latency adjustment) that simply shifts midi notes on their way into the project by a user-specified offset? The need was obviously recognized with audio recording; why is it such a leap to work out an offset for recording midi?
  5. bgewin

    Midi record timing offset

    I'm noticing that my midi notes are recorded about 25 ms after I play them on my controller. Under Edit==>Prefereces==>Audio==>Sync and Caching there's a "record latency adjustment" I can change. I've calibrated this for audio and I've got it down to the sample. It doesn't seem to effect my midi note placement. Is there such a setting for Midi? Please tell me that there is, and that the midi latency adjustment is separate from the audio adjustment! Thanks for your help and for all the enhancements and bug fixes. Billy
  6. I have a cakewalk (2020.1) project that uses analog tracks, Pianoteq and Arturia's B3 V2 organ. I noticed that after I added the organ, when I then record analog audio, the newly-recorded analog audio comes into the project 50ms early. I thought I was just playing really sloppy on my acoustic guitar but finally brought in a click loop, ran it out of the sound interface solo'ed back into my sound interface and sure enough the analog audio comes in 50 ms early. Removing the Arturia soft synth solves the problem immediately. I figured it was a midi buffer thing of something similar, but the project works fine with Pianoteq, and removing Pianoteq and leaving the Arturia synth does not fix the issue. Just to be clear, I tried: Arturia B3 V2 | Pianoteq | Issue --------------------------------------- Yes | Yes | Yes Yes | No | Yes No | Yes | No No | No | No Is anyone else having timing issues like this, and is there a solution or suggestion? Thank you! Edit: Note that simply Archiving the Arturia B3 V2 soft synth tracks solves the timing issue, and that the issue returns immediately after un-archiving the track.
  7. Take a look at my original post -- I added some setting info there (including a midi playback buffer setting) that I think helped me -- it was the last setting I changed. I'm using Pianoteq in my project.
  8. EDIT 2020, Mar 8. The setting changes below seem to be working. If you're having the same problem and reading this, see if these changes help you. I'd like to add my name to the list of those complaining about dropouts after recent cakewalk updates. I can take a cwp file and play it flawlessly over and over again in Sonar X3e. The same project hiccups, stutters and stops in Cakewalk Bandlab. When it happens, I notice that all 12 cores (my cpu has 6 cores that can handle 2 threads each) seem to max out for a second on the performance monitor. Flattening multiple takes and rendering Melodyne clips seems to help, but only modestly. I did the following: - raised my DropoutMSec from 250 to 750, but the immediate result was stuttering rather than dropping out entirely. - raised ExtraPluginBufs to 4 (is there any negative consequence to this?). - raised ThreadSchedulingModel from 0 to 2. I noticed that Buffers In Playback Queue (Preferences==>Audio==>Driver Settings) is stuck at 2; I can't raise that value. - raised my buffer size to 2048, - checked the Safe Mode box under Preferences==>Audio==>Driver Settings==>ASIO Panel - I also changed Preferences==>Midi==>Playback & recording==>Playback==>Prepare Using ___ Ms Buffers to 500. I ran the last two Cakewalk updates pretty close together, so I can't say if it was the most recent update or the prior one. I updated my Beheringer X32r driver to the most recent (4.59) and I'm running CWB 2020.01, build 28. I also should mention that I removed a Session Drummer soft synth in an effort to clean up the project. I don't know if it helped or not as (unfortunately) I didn't try my experiments one-at-a-time. Thanks so much, Billy
  • Create New...