Jump to content

johnchowseymour

Members
  • Content Count

    5
  • Joined

  • Last visited

Posts posted by johnchowseymour


  1. So, after working with this some more over the past weeks, I can add:

    I now think there's something wrong the one particular USB slot on my tower that I had first plugged the TASCAM into.  When I moved it from that USB 3 to a USB 2 slot, the problem went away, as I reported earlier.  But, I have since tried it in other USB 3 slots with no issue - so, I don't believe the USB 2.0/3.0 difference is the problem.  I think I just have a bad slot on my Dell tower and didn't notice until I plugged the TASCAM in there,  

    So since the solution was still "try a different USB port" I'll leave that as the selected answer, but I no longer think the USB 2 vs 3 issue has anything to do with it. 

    As for winkpain's issue - it's not that I've lost interest, but I simply haven't uncovered anything that would help.  My setup isn't popping at the same times theirs is. (I tried specifically to reproduce that issue, but couldn't get my setup to pop when switching programs, etc.  Even on the bad USB slot it only ever popped during recording.)

    Just to cover all the bases, are you hearing these pops in the line-outs (on the back of the TASCAM)?  I haven't used those at all so far; I only ever use the headphone jack (on the front).  It really shouldn't pop in either case, but if it does pop at one output but not another, it's at least a point of data in the troubleshooting.


  2. So many great suggestions here!  I really love the Cakewalk community; everyone's so polite and helpful. I tried (almost) all of them and here's how it worked out:

     

    On 3/1/2021 at 4:51 AM, Hatstand said:

    Before you go down a rabbit hole of tweaks, is it worth reinstalling the ASIO drivers or even contemplating if it is the actual interface or the cable itself that is the problem?

    Reinstalling the ASIO drivers seemed worth a shot, and it doesn't take long.   Alas, it didn't help in this case.  (Both times, I was very careful to plug things in exactly when directed by the instructions). 

    As for the cable, the one that came with it is the only USB A -> USB C cable I have, although I'll be sure to invest in some more so I have backups if I go forward with the TASCAM.

     

    6 hours ago, NealClark said:

    Simple things to try:-

    Windows Power settings - should be "performance".
    Make sure your USB ports are NOT set to "let windows manage power"
    Make sure their are no other windows apps trying to take control of your audio devices.

    yes, yes and yes.

    6 hours ago, NealClark said:

    Make sure that your windows audio bit depth and sample rate match your DAW ASIO settings to avoid any conflict. So for example 24bit "Studio Quality" for Windows and 24bit 48Khz for your CbB DAW ASIO setting.

    Oh, that's a new one on me.  It happened that my settings did match, but I'm glad you made me aware that this was even something to check. Thanks.

    In case anyone else is looking for it, in Windows 10, it's Settings > Sound > [select the interface from the dropdown]   Device properties > Additional Device Properties (way over on the righthand side of the screen) > 'Advanced' tab.

     

    On 3/1/2021 at 3:10 AM, Promidi said:

    Try disabling C-states and Intel Speedsteep (This is done in the PC's BIOS and the method varies between PCs)

    Try Start + run "control powercfg.cpl,,1" (without quotes) and set CPU Min and Max to 100%

    In preferences | Audio | Configuration File try adjusting the following:
    EnableSetThreadIdealProcessor = False
    MixThreadCount = {number of cores minus 1}

    You might like to exit Cakewalk by Bandlab, go to the following folder and make a copy of the AUD.INI file before doing this:

    %appdata%\Cakewalk\Cakewalk Core

    I will keep this list of additional tweaks handy if I ever run into performance issues.  Thank you so much for taking the time to write them out.

     

    On 3/1/2021 at 3:10 AM, Promidi said:

    Also, did you completely uninstall ASIO4ALL?

    Well, it comes with its own 'uninstall' program, which I ran.  It seems to have 'cleaned up' after itself, even deleting its files.  If you know of any way to more thoroughly uninstall it, please share!

     

    On 3/1/2021 at 6:41 AM, Matthew Sorrels said:

    Try a USB 2 port.  Not all USB 3 ports work right with USB 2 devices (like the TASCAM).

    This is what did it!

    And here I assumed newer was just better, but no - apparently the US-HD 4x4 works unreliably with a USB 3.0 port, or at least the USB 3.0 ports on my computer.  Moving it to a USB 2.0 port made the near-constant popping go away.

     

    Thank you so much, everyone! 

    • Like 1
    • Thanks 1

  3.      Recently bought a TASCAM US-HD 4x4, and using the custom ASIO drivers it comes with, it can't record or play back without pops/crackles/dropouts.  I've read all the other threads about optimizing latency and system settings to reduce this, nothing works.

    More Details:

         For years I've used a TASCAM US-122; it's too old to support ASIO but it ran well with ASIO4ALL.  I could record on its L and R inputs flawlessly, and I had no trouble with playback even with 20+ tracks of multiple VSTi synths.

         But, I wanted to record on three channels at once (vocals + stereo hardware synth), so I 'upgraded' to the US-HD 4x4, which has its own custom ASIO driver.  I keep hearing that a good interface with a custom ASIO driver is the best solution... but in this case, even with just a single, mono audio track, the playback through the US-HD4x4 has lots of little pops and crackles.  And while the system recognizes all four inputs, I can't record on even one at a time without the same pops and crackles ending up in the recording.

         I have tried all the usual performance-optimization things that get suggested: tried a variety of buffer sizes in the 4x4's custom panel, from 128 to 2048 (the largest possible setting).  I did all the Windows system performance optimization stuff in the system control panel ("Visual Effects" and so on).  Turned off WLAN and Bluetooth.  Basically, everything in the TASCAM manual's "troubleshooting" page AND everything I could find in other threads on the Cakewalk support forums.  None of this helps; it's still unable to handle even a single mono audio track without crackle.

         I honestly don't think system resources are the issue.  I have a Win10 64-bit Dell, with a 3.40GHz i7 and 16GB RAM, with about 120GB free on the main SDD.  The CPU usage monitor in Cakewalk never gets above 28% (in my single mono audio track tests).

         Instead of system resources, I feel like there must be something to configure that I haven't configured properly.  I'm at my wit's end trying to figure out what I missed, though.  

    Some other things I tried:

         If I restart the system and go back to the older US-122 and ASIO4ALL it runs well again (so, it's not the mic or mic cable!), but of course I'd be limited to two channels again.

         I'm using the USB cable that came with it (type A on the computer end, type C on the TASCAM end), and I made sure it's in one of the "SS" USB 3.0 slots.  The AC power for the TASCAM is also plugged in.

         The TASCAM ships with a download code for Cubase LE, so I tried that, just to make sure Cakewalk wasn't the problem.  Nope, same popping/crackling issues in Cubase, on both record and playback. 

         If anyone has any further suggestions, that'd be great.  Otherwise, I guess I give up and return it.  Is my computer (stats listed above) really not good enough to run an audio interface with a dedicated ASIO driver?  Maybe I'll have to go the route of a 4-channel mixer into a single stereo audio-in.  Shame not to have the tracks separate in the DAW though.

         Thanks in advance. I'm hoping there's some obvious thing to try that I just didn't think of.  Let me know if there's any additional info that would be useful to provide.


  4. I am having a similar problem, in Windows 10, with no audio interface besides the vanilla "Realtek high definition audio".

    Just so we're on the same page, here's what I mean by "same" problem:

    • playback of VST softsynths is both buzzy/crackly and too slow (notes do not sound in tempo)
    • TTS-1 works fine, other softsynths do not
    • this happened after I updated this morning, was fine yesterday before update
    • switching from WASAPI Shared to WASAPI Exclusive makes no difference (problem is still there); ASIO makes no sound at all on any track; MME-32 does remove the problem but (predictably) causes other horrible latency issues across all tracks.

    I can add the following observations, which is why I'm adding to this thread:

    • if I run the same softsynths in standalone mode (for example, Kontakt can run standalone, i.e. not in a DAW) the problem is NOT there. It sounds fine.
    • if I freeze the softsynth track and play the resulting audio, the problem is NOT there.... meaning, it can mixdown perfectly fine

    So, only realtime playback is compromised, and only when run through Cakewalk.

    I hope the folks at Bandlab can issue a hot patch (quick follow-up update) to address this.  In the meantime, I guess I finish the composing work in glitchy-sounding  MME-32 and then switch back to WASAPI for mixdown.

×
×
  • Create New...