Jump to content

Wei Liang Yap

Members
  • Content Count

    36
  • Joined

  • Last visited

Everything posted by Wei Liang Yap

  1. Hi, don't know if grantobrien (http://forum.cakewalk.com/Instrument-definition-for-Roland-RD2000-m3788479.aspx) or anyone else is interested, but here is an instrument definition file for the RD-2000 https://github.com/yapweiliang/RD-2000.INS
  2. Although there are various places to annotate, it would be nice to have an Index or TOC page that could summarise and hyperlink to the respective clip or folder or track marker or etc etc that has text. Sorry i appreciate this is a bit different to what the OP is asking. (DOI: i have no current need for this facility but i think it would be nice to have a means to keep track of multiple small things which could get buried. E.g. Effects on a single small clip.) Wei Liang
  3. OK thanks I'll stop here for now. Having a different midi device as the first device then changes the order of the rest of my MIDI devices which is inconvenient when re-opening previous projects. However having a loopback device permanantly installed and 'looped' to the Control Surface will work, but it shifts the problem to the loopback device to remember to re-connect to the Control Surface. Hopefully at some stage there will be a way for CbB to 'remember' disconnected USB MIDI devices Thanks for your time Mark. Wei Liang
  4. Hello, I've been tinkering, and it does seem no matter what I do, that when the control surface (Zoom R16) is unplugged, that CbB goes for the first rather than the last device. Any other suggestions? Below is the equivalent snippet from my TTSSEQ.INI. I also deleted and re-created the TTSSEQ (the [MIDI In Device Map] /[MIDI Out Device Map] does not seem relevant.) [MIDI Input Devices] 0=Port 1 on Micro 1=Port 2 on Micro 2=Port 3 on Micro 3=Port 4 on Micro 4=ZOOM R16_R24 Audio Interface MaxInPort=4 [MIDI Output Devices] 0=Port 3 on Micro 1=Port 6 on Micro 2=Port 5 on Micro 3=Port 2 on Micro 4=Port 4 on Micro 5=ZOOM R16_R24 Audio Interface MaxOutPort=5 Thanks in advance, Wei Liang
  5. I think most audio interfaces are set up as Stereo Pairs. So Zoom Channel 1 = 1 Left Zoom Channel 2 = 1 Right 3 = 2 Left 4 = 2 Right 5 = 3 Left etc. On CbB track if you make a mono track, you can assign either left or right input (e.g. Zoom 1 Left). But that is just the name of the input channel, and on the mixing console the mono track would normally be Pan in the Centre by default. What you can also do is rename the Input Drivers. At the bottom of your first picture, you can tick Use Friendly Names to Represent Audio Drivers. Then you can rename "Zoom R16... 1" (sorry your picture is out of focus I cannot read exactly) into "Zoom Ch 1/2" and the next one into "Zoom Ch 3/4" etc to help you to remember. You should probably also try the ASIO mode (Audio > Playback and Recording > Driver Mode) to see if it works better for you. Hope this helps Wei Liang
  6. Thank you for your thoughts. In my situation, when the control surface device (the Zoom) is unplugged, the control surface thingmy on CbB defaults to the first rather than the last device. (And when it is plugged in, it is already set as the last device). Your post has also prompted me to try the following, unfortunately didn't work 1 - with Zoom unplugged, set the output device to a 'spare' device (i.e. not my digital piano) 2 - save settings 3 - quit CbB 4 - plug in Zoom 5 - start CbB 6 - set output device to Zoom 7 - save settings 8 - quit CbB 9 - unplug Zoom 10 - start CbB ..... unfortunately same problem as initially described. (I was hoping it would remember a 'plan b' setup) I notice that my TTSSEQ.INI also has a [MIDI Out Device Map] heading which may or may not be in your TTSSEQ.INI. I'm not sure what this headings are for (MIDI In Device Map, and MIDI Out Device Map) these headings do not include my Zoom; however the [MIDI Output Devices] and [MIDI Input Devices] do include the Zoom. I'm going off on holiday soon, so probably will do the tinkering when I return, and try to learn what the Device Map is for. If you have any further thoughts it will be appreciated. Thanks, Wei Liang
  7. (I am new to control surfaces, but in any case I have a Zoom R16, and it works as a control surface once set-up) (I think the Zoom/Driver combination presents a USB MIDI Port for CbB to use) What I have noticed however, is, when the Zoom is not plugged in, CbB then chooses another available MIDI Port (in my case, it chooses the digital piano). What this means is that on starting up CbB, it sends a loud MIDI note to the piano (which duly produces the sound, a high 'A' note). It only happens on starting up CbB, and not subsequently (e.g. when open/close project files). What I am asking is whether - CbB can remember the Control Surface device, and, disable the control surface if the device is not plugged in, rather than choosing another MIDI port? (It does remember the correct MIDI port, when the Zoom is subsequently plugged in). Thank you (Using latest Zoom driver, latest (not Early Release) CbB, Windows 10, MOTU micro express, MOTU 828 mkII USB)
  8. I use a wireless computer keyboard. The sequence i press to achieve the same thing are: Space (stop) Ctrl z (undo recording) W (rewind to start) R (start recording) Much faster than doing the same with mouse. And no need to focus on the computer screen. Make sure the options are set such that "stop" stops at the time rather than stop and rewind to initial location (unless that is what you intend). Wei Liang
  9. I looked at it again - it appears that Bandlab (assistant) only exports audio, not MIDI; However if you open Bandlab Editor then you can export a region as MIDI (see https://help.bandlab.com/hc/en-us/articles/360019607454-How-do-I-export-my-MIDI-files-) Hopefully if Noel or Meng are reading this they could comment on whether there are plans to integrate import/export of MIDI 'stems' together with the audio stems? To me, the value of Bandlab is in collaboration. If I wanted to work on a project on my own whilst 'on the go' I would use my own laptop with my familiar tools (Cakewalk), or, I would use Bandlab (mobile phone app) to make a rough outline, but work on it properly in my home. Wei Liang PS: best of luck : I hope you write a winning song for Eurovision or any other competition 😊
  10. @florinkoin my opinion : i do not think that Bandlab is the correct tool to edit a complex MIDI song 'on the road'. It may be better to bring your laptop with Cakewalk instead. As far as I know the MIDI sound module (virtual instruments) for Bandlab is different from the ones bundled with Cakewalk. Wei Liang
  11. I note you have already found your solution. Another thought is to use a 1U line mixer (no tone controls, just for the synths) plus a 3U rack mixer (e.g. RX1202FX) or 2u (IMG Stageline MPX-622/SW 6-Channel Stereo Audio Mixer) for submix plus vocals The above 2 examples are just from Google search. I don't know how heavy duty they are. Wei Liang
  12. I'll need to figure out how to get Chrome to use ASIO.
  13. Yes the clicks in the flute track are from the recording process from the browser Bandlab (Mix Editor). It sounds similar to the clicks on the play back so i think it is an issue with the combination of W10. Chrome. Audio driver. (i have no issues with CbB btw. The above issue seems limited to BandLab's Mix Editor). Wei Liang
  14. Thanks Tim. I've tweaked the balance (mix) a bit, cut out half of my cello part, and muted the electric guitar part. (nice sax BTW). So in terms of your workflow when tweaking my flute part - seeing as the clip did not start at zero - did you have to do much to get the clip back in the correct position in the time-line? (in other words did you have to manually align it, or, did it remember the correct place when you imported it back?) So far - I foresee my usage of BandLab as a tool for collaborating with other musician(s) remotely, who do not have the equipment nor interest in using fully-fledged DAW - i.e. they just record their part in sync with a guide-track using the simplest of equipment (e.g. mobile phone +/- Link Analog). But having said that I still have some latency issues to iron out before I would use for real. I think if I were to collaborate with another known CbB user - I would probably use DropBox and ensure that only one band member was working on the file at one time. But on the other hand, I would never have had the pleasure of working with you, Tim, if not for the Bandlab platform. We may or may not lay down more tracks. In terms of next phase(s) in production - perhaps the BandLab platform would work well for people to tweak the mix and comment. For example "I" could adjust the mix as I thought fit, and other members would chip in and say there was too-much/too-little drums here or there, and that could be tweaked; and so on, until the band was more-or-less happy with the result. What would be interesting to see, is whether the integration between CbB and BandLab become more invisible - in other words - CbB potentially working directly on the BandLab tracks, without having to import/export Wei Liang
  15. Hello. Hopefully this is the right place to ask. I'm having some difficulty with latency settings on this app. It seems to require that the latency correction is turned off. Go back. Turn on latency correction. Go back. Save project. Exit project. Reopen project. Then only it seems to be correctly applied. Does anyone else have this issue? (steps to reproduce : 1. Put earphones next to mic. 2. Metronome on. 3. Press record (record metronome on track 1) 4.metronome off. 5. Make new track. Rewind to beginning. 6. Put earphones next to mic 7. Press record. If latency is correct then then both tracks should align.) Thanks Wei Liang The phone is One Plus 3T. Latency measured by the app ranges from 61 to 63 ms via earphones. Different latency if phone's loudspeaker used.
  16. Try whitelisting bandlab on your adblocker? At least for me it sorted out issue where some buttons seemed to be missing. But i don't know about emojis
  17. I do agree with witchwyzwurd though. It would be nice to know what has changed with each update.
  18. Do you mean Cakewalk By Bandlab (which is what Sonar Platinum used to be) Or Bandlab Assistant?
  19. @StariseFeel free to add, delete, change, etc : this is about trying out BandLab as a collaboration tool. Also, feel free to make the piece public, invite others in, etc. In regards latency - so here is some feedback from my experience of trying Bandlab. YMMV. But before that - just to say that the actual latency does not matter as I am not using live monitoring or live effects. So, even if the latency is 500ms, as long as it is correctly represented, it will all line up correctly. So with the mobile phone (BandLab app) - at least for my phone (android) - it allows you to measure the latency - which is basically the app makes a number of frequency sweeps and records itself - and comes up with its own measurement. I note that this latency is different, depending on whether I am using the headphones, or, the built-in speaker (by as much as about 20-30ms). In the particular version (which was the latest version at the time I recorded) I think there may be a bug - in that after it measured the latency, it did not seem to apply it. So in that particular recording, the cello was out of sync, and as I didn't feel like re-taking it, I just manually shifted it using the bandlab browser application - basically using the mouse, shift it a bit until it looks and sounds right. I think the actual quality of the phone's mic is not too bad. With the web browser BandLab interface a.k.a. Mix Editor - this also has its own process for measuring latency - which basically tells you to point your mic at the loudspeakers, and it makes some noises and measures its latency. On my particular system (Chrome browser, Windows 10, USB motu interface) it was a relatively high latency. But it was correctly measured (or near enough) and the recorded track was in sync. Earlier in the 'experiment' we had noticed that the Mix Editor on play back appears to have some clicky noises - ?? due to buffering or other issue - but we disregarded it as, when the Project was 'mixed' and played back as a whole, outside the the Mix Editor - it sounded fine. However with recording via the Mix Editor - I encountered the same problem - so the recorded Flute part does have some subtle noises which my guess (I am not an expert) are due to a buffering issue. With the Mix Editor - it uses the default/active playback device (Windows 10) and allows you to choose an input device (as available/visible to W10) - and I believe these would be the safe/slow drivers (i.e. not the ASIO drivers) - the measured latency was 193ms (much more than the mobile phone's latency) Now with the new 5.0.3 BLA feature of exporting the BandLab project as stems - firstly - this works quite effortlessly (thank you very much for this feature). I would prefer that it notified you which folder it was saving it in, and also notified you that downloading has started in the background and when downloading was finished, rather than a 'done' type of message (as I was pretty sure my broadband speed - is fast, but not that fast!). I imported the stems back into the same CbB project to see if the tracks lined up. They more or less do, but not sample-perfect (i.e. the null test fails - most likely due to temporal alignment). See picture - Track 13 is the original drum track, Track 16 is the re-imported track. It is possible that myself, or Tim, have accidentally nudged or 'touched' the track in the Mix Editor version. (I also assume that Addictive Drums 2 has not "re-recorded" itself with slightly different timings. But I also tried the null cancellation with the piano (Audio) track, and it did not cancel out). Anyway this is my own experience so far. Time permitting - more experimentation will be done. Wei Liang
  20. It was literally find 5 spare minutes when kids are quiet. Take out cello. Plug headphones into phone. Ensure latency setting is correct (turns out it wasn't). Press record (bandlab app). So you are listening to a mere mortal playing a cello in non-ideal recording room using the mic from the mobile phone. I suggest the weakest link is my cello playing rather than equipment. The flute part was similar process but using the bandlab web interface and using my usual sound interface (motu) and C1000 mic and whatever sound driver (not ASIO) that Windows uses for its connection to the motu. Doesn't give me a choice. This time latency was correct but there must be some buffering issue in the web interface as you can hear some clicks recorded in the flute part. Wei Liang
  21. @Jesse JostHi Jesse I cannot see the option to "Download Stems". I am using BL Assistant 5.0.2 which I believe is the current (latest) version.
  22. OK So I have discovered that there are a number of buttons, such as PUBLISH, SHARE, DOWNLOAD, etc, etc that do not get shown unless my AdBlockPlus is disabled. For now I have whitelisted the Bandlab.com website. However DOWNLOAD does not appear to give the option of downloading in the .BLX format (BandLab Interchange) which seems to be what has now appeared in the Import menu of CbB. (It does give the option of downloading the mix as MP3/WAV/etc). EDIT : @Jesse Jost https://discuss.cakewalk.com/index.php?/topic/822-current-release-201901/&do=findComment&comment=6198 wrote that this was a preview feature. Cross reference to post by @Blades https://discuss.cakewalk.com/index.php?/topic/800-update-notes/&do=findComment&comment=6329 Wei Liang
  23. https://www.cakewalk.com/Documentation?product=Cakewalk&language=3&help=Mixing.57.html I found this - it explains the intended functioning (including that exports are private by default). So there must be a bug somewhere. I have uninstalled and reinstalled BL Assistant, so will see if the problem persists. (I was already on the latest version of BL Assistant). Wei Liang
×
×
  • Create New...